1. Приветствуем Вас на неофициальном форуме технической поддержки XenForo на русском языке. XenForo - новый и перспективный форумный движок от бывших создателей vBulletin.
Загрузка

1.4.x [8wayRun.Com] XenMedio (Media) 1.5.3a

Медиа-библиотека

  1. aligon

    aligon Активный пользователь

    Регистрация:
    19.04.12
    Сообщения:
    115
    Симпатии:
    3
    Версия XF:
    1.1.2
    Так, установил 1.3.8 русскую
    Всё встало нормально. Проблема в том , что не как не могу выбрать пару категорий.
    И shift зажимал, но всёровно в в выборе категорий, есть только general categoty
    Что делать?
     
  2. Александр

    Александр Местный

    Регистрация:
    06.11.10
    Сообщения:
    484
    Симпатии:
    188
    Версия XF:
    1.4.3
    Иногда выдаёт ошибку, при добавлении ссылки. Что скажете?
     

    Вложения:

  3. TAIFUN

    TAIFUN Человек

    Регистрация:
    27.09.10
    Сообщения:
    2.121
    Симпатии:
    1.560
    Версия XF:
    1.5.9
    Покажите текст ошибки в теге CODE, а не на скриншоте.
     
    Shmidtelson нравится это.
  4. Александр

    Александр Местный

    Регистрация:
    06.11.10
    Сообщения:
    484
    Симпатии:
    188
    Версия XF:
    1.4.3
    Код:
    Информация об ошибке
     
    Zend_Http_Client_Adapter_Exception: Unable to Connect to tcp://gdata.youtube.com:80. Error #0: php_network_getaddresses: getaddrinfo failed: hostname nor servname provided, or not known - library/Zend/Http/Client/Adapter/Socket.php:235
     
    Трассировка стэка
     
    #0 /www/library/Zend/Http/Client.php(973): Zend_Http_Client_Adapter_Socket->connect('gdata.youtube.c...', 80, false)
    #1 /www/library/EWRmedio/Model/Submit.php(34): Zend_Http_Client->request()
    #2 /www/library/EWRmedio/ControllerPublic/Media.php(179): EWRmedio_Model_Submit->fetchFeedInfo('http://youtu.be...')
    #3 /www/library/XenForo/FrontController.php(310): EWRmedio_ControllerPublic_Media->actionSubmit()
    #4 /www/library/XenForo/FrontController.php(132): XenForo_FrontController->dispatch(Object(XenForo_RouteMatch))
    #5 /www/index.php(13): XenForo_FrontController->run()
    #6 {main}
     
    Содержимое запроса
    array(3) {
      ["url"] => string(49) "http://www.сайт.ru/media/submit"
      ["_GET"] => array(0) {
      }
      ["_POST"] => array(3) {
        ["source"] => string(27) "http://youtu.be/GF-fvKZWhzI"
        ["submit"] => string(16) "Добавить"
        ["_xfToken"] => string(53) "1,1337609207,1cf862c46d7e3b983929bf0fedc2f08a8e95b885"
      }
    }
    
    ещё такая бывает
    Код:
    Zend_Http_Client_Adapter_Exception: Unable to Connect to tcp://i.ytimg.com:80. Error #0: php_network_getaddresses: getaddrinfo failed: hostname nor servname provided, or not known - library/Zend/Http/Client/Adapter/Socket.php:235
     
  5. Romchik®

    Romchik® The Power of Dreams Команда форума

    Регистрация:
    26.09.10
    Сообщения:
    5.740
    Симпатии:
    5.269
    Версия XF:
    1.5.11
    Не факт, что я прав, но вроде как по каким то причинам сервер или не получает нужный ему отклик, или же сам не может отправить. Если при этом все работает, то значит такое происходит в очень маленьком процентном отношении.
     
  6. infis

    infis Местный Команда форума

    Регистрация:
    27.06.11
    Сообщения:
    5.525
    Симпатии:
    3.321
    Версия XF:
    1.5.9
    DNS у него хреново работает. Либо медленно отдает, либо вообще по таймауту отваливается. В результате сервер не может отрезолвить (разрешить) имя в IP-адрес. Ну и дальше возникает ошибка типа "сервер не найден". Также вероятен вариант, когда у сервера DNS есть лимит на одновременное количество соединений от одного хоста, либо на общее количество запросов в некоторый промежуток времени. В таком случае нужно либо повышать лимит, либо искать, почему так много запросов валится с хоста на DNS.

    В любом случае либо пинать хостера, если это хостинг, либо провайдера, если свой сервер.
     
    Romchik® нравится это.
  7. frolov1992

    frolov1992 Пользователь

    Регистрация:
    11.01.12
    Сообщения:
    91
    Симпатии:
    4
    Есть ли настройка с Vk?
     
  8. Kelt

    Kelt Read only

    Регистрация:
    13.06.11
    Сообщения:
    146
    Симпатии:
    46
    Тем кто не обновился на 1.5.0, как сделать премиум:

    Создать файл Premium.php по следующему адресу /library/EWRmedio/model/

    Код:
    <?php
     
    class EWRmedio_Model_Premium extends XenForo_Model
    {
        public function exportService($service)
        {
            $document = new DOMDocument('1.0', 'utf-8');
            $document->formatOutput = true;
     
            $srv_node = $document->createElement('service');
            $document->appendChild($srv_node);
     
            $srv_node->appendChild($document->createElement('service_type', $service['service_type']));
            $srv_node->appendChild($document->createElement('service_media', $service['service_media']));
            $srv_node->appendChild($document->createElement('service_name', $service['service_name']));
            $srv_node->appendChild($document->createElement('service_slug', $service['service_slug']));
     
            $sub_node = $document->createElement('service_url', '');
            $sub_node->appendChild($document->createCDATASection($service['service_url']));
            $srv_node->appendChild($sub_node);
     
            $sub_node = $document->createElement('service_feed', '');
            $sub_node->appendChild($document->createCDATASection($service['service_feed']));
            $srv_node->appendChild($sub_node);
     
            $sub_node = $document->createElement('service_regex', '');
            $sub_node->appendChild($document->createCDATASection($service['service_regex']));
            $srv_node->appendChild($sub_node);
     
            $sub_node = $document->createElement('service_movie', '');
            $sub_node->appendChild($document->createCDATASection($service['service_movie']));
            $srv_node->appendChild($sub_node);
     
            $sub_node = $document->createElement('service_value2', '');
            $sub_node->appendChild($document->createCDATASection($service['service_value2']));
            $srv_node->appendChild($sub_node);
     
            $sub_node = $document->createElement('service_thumb', '');
            $sub_node->appendChild($document->createCDATASection($service['service_thumb']));
            $srv_node->appendChild($sub_node);
     
            $sub_node = $document->createElement('service_title', '');
            $sub_node->appendChild($document->createCDATASection($service['service_title']));
            $srv_node->appendChild($sub_node);
     
            $sub_node = $document->createElement('service_description', '');
            $sub_node->appendChild($document->createCDATASection($service['service_description']));
            $srv_node->appendChild($sub_node);
     
            $sub_node = $document->createElement('service_duration', '');
            $sub_node->appendChild($document->createCDATASection($service['service_duration']));
            $srv_node->appendChild($sub_node);
     
            $sub_node = $document->createElement('service_keywords', '');
            $sub_node->appendChild($document->createCDATASection($service['service_keywords']));
            $srv_node->appendChild($sub_node);
     
            $sub_node = $document->createElement('service_errors', '');
            $sub_node->appendChild($document->createCDATASection($service['service_errors']));
            $srv_node->appendChild($sub_node);
     
            $sub_node = $document->createElement('service_parameters', '');
            $sub_node->appendChild($document->createCDATASection($service['service_parameters']));
            $srv_node->appendChild($sub_node);
     
            $srv_node->appendChild($document->createElement('service_width', $service['service_width']));
            $srv_node->appendChild($document->createElement('service_height', $service['service_height']));
     
            return $document;
        }
     
        public function rebuildServices()
        {
            $files = scandir($xmlDir = XenForo_Application::getInstance()->getRootDir().'/library/EWRmedio/XML', 1);
     
            foreach ($files AS $file)
            {
                if (stristr($file,'xml') && $file != '_temp.xml')
                {
                    XenForo_Model::create('EWRmedio_Model_Services')->importService($xmlDir.'/'.$file);
                }
            }
     
            return true;
        }
    }
    Через фронт аддона обновить источники видео.
     
    dogkiller нравится это.
  9. r4mZeS

    r4mZeS Местный

    Регистрация:
    10.10.10
    Сообщения:
    240
    Симпатии:
    194
    Поставил сначала 1.5.0а, при нажатии на линк плейлистов, начало ругаться на ошибку в шаблоне
    EWRmedio_Playlists
    Код:
    Invalid argument supplied for foreach() in с:\www\localhost\library\XenForo\Template\Abstract.php(265) : eval()'d code, line 30:
    29:    ';
    30: foreach ($playList AS $list)
    31: {
    Снёс 1.5.0а, установив 1.3.8_ru, тоже самое. Всем так повезло или что-то не так установилось?
    Кто сталкивался, отзовитесь.
     
  10. r4mZeS

    r4mZeS Местный

    Регистрация:
    10.10.10
    Сообщения:
    240
    Симпатии:
    194
    Вчера разобрался-таки с этим. Баг совершенно идиотский. Для того, чтобы исчезла эта ошибка и шаб форума не перекосоё**ливало при переходе в раздел плейлистов, необходимо создать хотя бы один, этот самый, плейлист. В будущем можно оставить его пустым, главное, чтобы он был! Странно, Jaxel (разраб мода), уже давно осведомлён об этом "косяке", но из версии в версию никак не пофиксит его.
    Если загуглить, можно тут же узреть десятки форумов с аналогичной проблемой. Их админы, так и не найдя вразумительного фидбека по своей проблеме, предпочли попросту забить на неё. Так что, надеюсь, эта инфа хоть кому-то ещё пригодится. ;)
     
  11. Kelt

    Kelt Read only

    Регистрация:
    13.06.11
    Сообщения:
    146
    Симпатии:
    46
    тоже заметил этот баг и просто выпилил "плейлисты" из шаблона меню
     
  12. r4mZeS

    r4mZeS Местный

    Регистрация:
    10.10.10
    Сообщения:
    240
    Симпатии:
    194
    Ну вот и следующий баг. :)
    Код:
    Server Error
     
    Undefined index: $t
     
    XenForo_Application::handlePhpError() in EWRmedio/Model/Submit.php(64) : eval()'d code at line 1
    eval() in EWRmedio/Model/Submit.php at line 64
    EWRmedio_Model_Submit->fetchFeedInfo() in EWRmedio/ControllerPublic/Media.php at line 179
    EWRmedio_ControllerPublic_Media->actionSubmit() in XenForo/FrontController.php at line 310
    XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 132
    XenForo_FrontController->run() in c:/www/localhost/index.php at line 13
    Суть бага, судя по всему, заключается в том, что если при добавлении видео, скрипт не может получить время ролика, он тупо отваливается у еррор. Вот наглядный пример:
    Код:
    http://www.youtube.com/watch?v=wJdjh3ToXSk
    Собственно, вопрос к тем, у кого стоит версия 1.5.0(а), попробуйте вставить линк, интересно, автор пофиксил это в последних релизах (отличных от 1.3.8) или всё же надо будет допиливать эту хрень самостоятельно?
     
  13. dogkiller

    dogkiller Активный пользователь

    Регистрация:
    01.05.11
    Сообщения:
    1
    Симпатии:
    2
    В версии 1.5.0(а) Premium.php нужно создать не в папке /library/EWRmedio/Model/ а в /library/EWRmedio/XML/
    и еще в этом файле нужно найти строку
    Код:
    class EWRmedio_Model_Premium extends XenForo_Model
    и изменить на
    Код:
    class EWRmedio_XML_Premium extends XenForo_Model
    P.S:
    регулярка для Vimeo (xml висит в раннем посте, импортировать и отредактировать в источниках)
    Код:
    http://[\w\.]*?vimeo\.[a-z]+/(?P<sval1>[\w-]+)
    Если есть у кого-то xml для Vk, плиз поделитесь
     
    resonansER и stcrox нравится это.
  14. Shmidtelson

    Shmidtelson Местный

    Регистрация:
    26.02.12
    Сообщения:
    108
    Симпатии:
    5
    Версия XF:
    1.1.3
    Есть у кого xml для ru.twitch и own3d.tv скиньте плз!)

    норм работает
     
  15. r4mZeS

    r4mZeS Местный

    Регистрация:
    10.10.10
    Сообщения:
    240
    Симпатии:
    194
    Трансляция закончилась ещё в начале августа, Вы пишешь в октябре. По сему вопрос, что и где работает? Если проверял на другом потоке, дай пожалуйста примеры лив стрима и ссылку в туда, где это "норм работает"?
     
  16. Shmidtelson

    Shmidtelson Местный

    Регистрация:
    26.02.12
    Сообщения:
    108
    Симпатии:
    5
    Версия XF:
    1.1.3
    есть ли адреса потоков? или самому искать?
     
  17. r4mZeS

    r4mZeS Местный

    Регистрация:
    10.10.10
    Сообщения:
    240
    Симпатии:
    194
    Полагаю, что возможно это кому-то покажется оригинальным стилем общения, отвечать вопросом на вопрос, спешу разочаровать, я явно не в их числе. Так всё же... Ты говоришь, что всё "норм работает", вот я резонно и спрашиваю, где можно глянуть пример этой самой нормальной работы с лив стримом, так сказать воочию? Ты же не голосновно ляпнул это или я ошибаюсь..?
     
  18. Shmidtelson

    Shmidtelson Местный

    Регистрация:
    26.02.12
    Сообщения:
    108
    Симпатии:
    5
    Версия XF:
    1.1.3
    Адрес сайта не хочу палить! но был в шоке - потому та ссылка при добавлении в медиа - это или стрим или я ошибаюсь
     
  19. r4mZeS

    r4mZeS Местный

    Регистрация:
    10.10.10
    Сообщения:
    240
    Симпатии:
    194
    Ничего не понял из вышесказанного. Ты написал, "работает норм", вот я и спрашиваю, какой именно смысл изначально вкладывался во фразу "работает норм"?
     
  20. Shmidtelson

    Shmidtelson Местный

    Регистрация:
    26.02.12
    Сообщения:
    108
    Симпатии:
    5
    Версия XF:
    1.1.3
    Так наверное очень понятно будет!) ;)
    Безымянный.jpg
     

Поделиться этой страницей