1. Приветствуем Вас на неофициальном форуме технической поддержки XenForo на русском языке. XenForo - новый и перспективный форумный движок от бывших создателей vBulletin.
Загрузка

1.4.x [8wayRun.Com] XenPorta (Portal) [RU] 1.6.0

Портальная система для XenForo

  1. Romchik®

    Romchik® The Power of Dreams Команда форума

    Регистрация:
    26.09.10
    Сообщения:
    5.740
    Симпатии:
    5.269
    Версия XF:
    1.5.11
    Значит дело в файлах. Ведь понятно все из ошибки. Либо это неверные файлы, либо они старой версии и скорей всего несовместимы.
     
  2. TITAN-UZ

    TITAN-UZ Местный

    Регистрация:
    14.06.11
    Сообщения:
    41
    Симпатии:
    4
    Версия XF:
    1.3.3
    Заливай 1.4.4 и удалы я так сделал удалился! Это был на 1.1.0 3 beta на 1.0.4 без проблем удалился!
     
  3. KakBeOlolo

    KakBeOlolo Местный

    Регистрация:
    08.10.11
    Сообщения:
    511
    Симпатии:
    91
    Версия XF:
    1.1.2
    Спасибо за помощь, но мне уже помогли удалить :thumbsup: .
     
  4. Макар

    Макар Вопрошатель

    Регистрация:
    07.10.10
    Сообщения:
    216
    Симпатии:
    70
    не помогло

    сделал по другому

    закомментировал блок отвечающий за удаление таблиц из бд

    Код:
     /* $this->_getDb()->query("
     DROP TABLE IF EXISTS
     `EWRporta_blocks`,
     `EWRporta_caches`,
     `EWRporta_layouts`,
     `EWRporta_options`,
     `EWRporta_promotes`
     ");*/
    и деинсталяция пошла ..............

    // не понимаю, нахрена при удалении плагина удалять и его таблицы с данными ? они что есть просят без плагина........
    // потом при повторной установке заново все настраивать............
     
  5. infis

    infis Местный Команда форума

    Регистрация:
    27.06.11
    Сообщения:
    5.525
    Симпатии:
    3.321
    Версия XF:
    1.5.9
    Странно, что при комментировании этой части кода удаление плагина прошло, а без комментирования не шло. По идее, если этих таблиц нет, то запрос все равно отработает. Там же используется "IF_EXISTS", т.е. таблицы удаляются, если они присутствуют, но сам запрос все равно будет корректным.
    Обычно удаляют для того, чтобы не оставалось мусора в базе.
    А обновление плагина, как правило, делают через обновление, а не удаление, а затем установку. При обновлении, естественно, данные не удаляются.
     
  6. Макар

    Макар Вопрошатель

    Регистрация:
    07.10.10
    Сообщения:
    216
    Симпатии:
    70
    не шло, так как матюкалось на
    не правильный вызов метода
    нет метода = нет ошибки

    в контексте всего метода странного ничего нет

    PHP:
        public static function uninstallCode()
        {
            
    $blocks XenForo_Model::create('EWRporta_Model_Blocks')->getAllBlocks();

            foreach (
    $blocks AS $block)
            {
                
    XenForo_Model::create('EWRporta_Model_Blocks')->uninstallBlock($block);
            }

    /*        $this->_getDb()->query("
                DROP TABLE IF EXISTS
                    `EWRporta_blocks`,
                    `EWRporta_caches`,
                    `EWRporta_layouts`,
                    `EWRporta_options`,
                    `EWRporta_promotes`
            ");*/
        
    }
    отрабатывает деинсталяция блоков без затрагивания таблиц в бд
    я привык к тому что при удалении мода мне дают право выбора - удалять таблицы или оставлять, но это на другом скрипте реализовано.........
     
  7. infis

    infis Местный Команда форума

    Регистрация:
    27.06.11
    Сообщения:
    5.525
    Симпатии:
    3.321
    Версия XF:
    1.5.9
    Так с этого и нужно было начать. Это баг плагина. По идее нужно багрепорт разработчику было отправить.
     
  8. Gatses

    Gatses Местный

    Регистрация:
    05.02.11
    Сообщения:
    421
    Симпатии:
    579
    Версия XF:
    1.5.9
  9. infis

    infis Местный Команда форума

    Регистрация:
    27.06.11
    Сообщения:
    5.525
    Симпатии:
    3.321
    Версия XF:
    1.5.9
    Ну что же. Такой разработчик. Я не стал всю ветку читать, он вообще починил это в следующих версиях или нет?
     
  10. Gatses

    Gatses Местный

    Регистрация:
    05.02.11
    Сообщения:
    421
    Симпатии:
    579
    Версия XF:
    1.5.9
    Без понятия, вроде как не отвечал на данное сообщение.
     
  11. snake302

    snake302 Активный пользователь

    Регистрация:
    26.09.11
    Сообщения:
    43
    Симпатии:
    10
    Версия XF:
    1.1.0 Final
    хм у меня на модуль стали пропадать права то есть сначала могу удалять и ректировать текст - потом нет, хотя на форуме все стабильно) может есть аналог?
     
  12. hbq

    hbq Активный пользователь

    Регистрация:
    27.07.11
    Сообщения:
    58
    Симпатии:
    23
    Версия XF:
    1.1.2
    Помогите с ошибкой, вылезает стабильно раз по 5-6 на день.
    Код:
    ErrorException: Undefined index: forum - library/EWRporta/ControllerPublic/Forum.php:14
     
    #0 /home/qqqqq/data/www/qqqqq/library/EWRporta/ControllerPublic/Forum.php(14): XenForo_Application::handlePhpError()
    #1 /home/qqqqq/data/www/qqqqq/library/XenForo/FrontController.php(310): EWRporta_ControllerPublic_Forum->actionIndex(Object(XenForo_RouteMatch))
    #2 /home/qqqqq/data/www/qqqqq/library/XenForo/FrontController.php(132): XenForo_FrontController->dispatch()
    #3 /home/qqqqq/data/www/qqqqq/index.php(13): XenForo_FrontController->run()
    #4 {main}
    array(3) {
    ["url"] => string(46) "http://qqqqqqq/forums/-/index.rss"
    ["_GET"] => array(0) {
    }
    ["_POST"] => array(0) {
    }
    }
    Как бы мне ее исправить..
     
  13. Romchik®

    Romchik® The Power of Dreams Команда форума

    Регистрация:
    26.09.10
    Сообщения:
    5.740
    Симпатии:
    5.269
    Версия XF:
    1.5.11
    Судя по всему портал не совместим полностью с XF 1.1. Ругается на глобальную ленту RSS наверно.
     
    hbq нравится это.
  14. hbq

    hbq Активный пользователь

    Регистрация:
    27.07.11
    Сообщения:
    58
    Симпатии:
    23
    Версия XF:
    1.1.2
    Ясно спасибо.
     
  15. KolobOKs

    KolobOKs Активный пользователь

    Регистрация:
    12.12.10
    Сообщения:
    25
    Симпатии:
    2
    Версия XF:
    1.1.0 Final
    Доброго времени суток. Пытаюсь уже какой день удалить XenPorta 1.3.8, чтобы попробовать новую версию, однако удалить у меня его не получается конкретно:
    Сначала пытался удалить с текущими файлами и получал ошибку: "не найден там какой-то шаблон"
    После этого воспользовался советом закомментить код удаления таблиц в бд - нет результата.
    После этого попробовал заменить файлы на 1.4.4 и удалить вместе с ними. Ошибка изменилась на : "не найдена таблица EWRporta_blocks. Пробовал закомменить удаление таблиц - нет результата.
    Пробовал удалить всё. Файлы, таблицы - нет результата. В админке портал остается и новый никак не поставить.
    Посоветуйте что-нибудь пожалуйста!
     
  16. SeM13

    SeM13 Создатель системы

    Регистрация:
    05.01.11
    Сообщения:
    747
    Симпатии:
    252
    Версия XF:
    1.1.3
    Как я и думал, портал сплошная дырка, дырка на дырке блин.
     
  17. Romchik®

    Romchik® The Power of Dreams Команда форума

    Регистрация:
    26.09.10
    Сообщения:
    5.740
    Симпатии:
    5.269
    Версия XF:
    1.5.11
    В базе данных удаляли таблицы портала?

    Версия 1.5.0 в первом сообщении обновлена. Судя по всему там много изменений по сравнению с бетой.
     
    Gatses нравится это.
  18. KolobOKs

    KolobOKs Активный пользователь

    Регистрация:
    12.12.10
    Сообщения:
    25
    Симпатии:
    2
    Версия XF:
    1.1.0 Final
    Да, удалял
     
  19. Romchik®

    Romchik® The Power of Dreams Команда форума

    Регистрация:
    26.09.10
    Сообщения:
    5.740
    Симпатии:
    5.269
    Версия XF:
    1.5.11
    Я не знаю, что еще можно посоветовать.
    Попробуйте просто удалить все файлы от портала, затем залить от 1.5.0 и установить плагин 1.5.0. Если поставится без ошибок, удалите его на всякий случай, а потом поставьте еще раз.
     
  20. KolobOKs

    KolobOKs Активный пользователь

    Регистрация:
    12.12.10
    Сообщения:
    25
    Симпатии:
    2
    Версия XF:
    1.1.0 Final
    Я вот к сожалению не могу поставить его, даже после удаления файлов и таблиц. При установке говорит, что "такой плагин уже установлен"

    А при попытке удалить вот такая ошибка:
    PHP:
    Server Error
     
    Mysqli prepare error
    Table 'public_beta.EWRporta_modules' doesn't exist
     
        Zend_Db_Statement_Mysqli->_prepare() in Zend/Db/Statement.php at line 115
        Zend_Db_Statement->__construct() in Zend/Db/Adapter/Mysqli.php at line 381
        Zend_Db_Adapter_Mysqli->prepare() in Zend/Db/Adapter/Abstract.php at line 478
        Zend_Db_Adapter_Abstract->query() in Zend/Db/Adapter/Abstract.php at line 734
        Zend_Db_Adapter_Abstract->fetchAll() in EWRporta/Model/Modules.php at line 25
        EWRporta_Model_Modules->getModules() in EWRporta/Install.php at line 97
        EWRporta_Install::uninstallCode()
        call_user_func() in XenForo/DataWriter/AddOn.php at line 193
        XenForo_DataWriter_AddOn->_postDelete() in XenForo/DataWriter.php at line 1645
        XenForo_DataWriter->delete() in XenForo/ControllerAdmin/AddOn.php at line 117
        XenForo_ControllerAdmin_AddOn->actionDelete() in XenForo/FrontController.php at line 310
        XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 132
        XenForo_FrontController->run() in /***/public-beta.ectorus.ru/admin.php at line 13
     

Поделиться этой страницей