1. Приветствуем Вас на неофициальном форуме технической поддержки XenForo на русском языке. XenForo - новый и перспективный форумный движок от бывших создателей vBulletin.
Загрузка

1.4.x [8wayRun.Com] XenPorta (Portal) [RU] 1.6.0

Портальная система для XenForo

  1. CyberAP

    CyberAP Местный

    Регистрация:
    05.10.10
    Сообщения:
    2.577
    Симпатии:
    1.614
    Версия XF:
    1.5.10
    H2 и должен быть ссылкой.
     
  2. Kelt

    Kelt Read only

    Регистрация:
    13.06.11
    Сообщения:
    146
    Симпатии:
    46
    Небольшая проблема с дефолтным слайдером, как правильно убрать превьюшки картинок? Иначе текст не помещается.
    144.png
     
  3. GroupR

    GroupR Активный пользователь

    Регистрация:
    22.10.11
    Сообщения:
    44
    Симпатии:
    9
    Версия XF:
    1.1.2
    Найдите в шаблоне RecentSlider это:
    Код:
    <div class="tagline" style="height: {$option.itemheight}px;">
        <div class="image" style="height: {$option.imgheight}px; width: {$option.imgwidth}px; background-image: url('{xen:link attachments, $news.attach}'); background-position: {$option.anchor} top;"></div>
        <div class="title" style="margin-{$option.position}: {$option.itemwidth}px;">{xen:helper wordtrim, $news.title, {$option.trimtitle}}</div>
    </div>
    И замените все на:
    Код:
    <div class="tagline" style="height: {$option.itemheight}px;">
        <div class="title">{xen:helper wordtrim, $news.title, {$option.trimtitle}}</div>
    </div>
     
    Kelt нравится это.
  4. shaman480

    shaman480 Местный

    Регистрация:
    22.12.10
    Сообщения:
    640
    Симпатии:
    479
    Версия XF:
    1.4.3
    Может не в тему вопрос, но так и не смог разобраться с модулем RecentSlider! Как его запустить в работу! Не могу понять что писать в "Slide Filename"
     
  5. Kelt

    Kelt Read only

    Регистрация:
    13.06.11
    Сообщения:
    146
    Симпатии:
    46
    Сто раз обсуждалось.
    Когда создаешь тему, прикрепляй картинку с названием slide.jpg (по дефолту стоит). Модуль сам находит эту картинку и выводит её в слайдер. Каждый раз при добавлении картинки надо заново сохранять настройки модуля в админ панели.
     
    shaman480 нравится это.
  6. Evgeniy Apanasenko

    Evgeniy Apanasenko Пользователь

    Регистрация:
    23.10.11
    Сообщения:
    41
    Симпатии:
    1
    У меня проблема такая, если выйти из своего профиля, то все новости на главной пропадают. То есть незарегистрированный пользователь их не видит, что делать?
     
  7. Zum07

    Zum07 Местный

    Регистрация:
    01.07.11
    Сообщения:
    55
    Симпатии:
    12
    Версия XF:
    1.4.3
    Разобрался это всё из-за вот этого Esthetic Quote Selected отключил и всё заработало[
     
  8. TAIFUN

    TAIFUN Человек

    Регистрация:
    27.09.10
    Сообщения:
    2.121
    Симпатии:
    1.560
    Версия XF:
    1.5.9
    Я восстановил Ваше сообщение, если Вы не против. Так как информация важная.
     
  9. Zum07

    Zum07 Местный

    Регистрация:
    01.07.11
    Сообщения:
    55
    Симпатии:
    12
    Версия XF:
    1.4.3
    У меня с этим модом не работало
    1)сворачивание sidebar
    2)не работал слайдер когда залогинешся
     
  10. motionvalue

    motionvalue Пользователь

    Регистрация:
    10.02.12
    Сообщения:
    6
    Симпатии:
    0
    Столкнулся со следующей проблемой поставил "XenPorta (Portal) v1.5.2 ru" на "XenForo.v1.1.2" не появляется вкладка portal, нельзя написать новую статью и не работает навигация wiki. Очень прошу помочь с этой проблемой, весь инет обшарил решения так и не нашел.
     
  11. infis

    infis Местный Команда форума

    Регистрация:
    27.06.11
    Сообщения:
    5.525
    Симпатии:
    3.321
    Версия XF:
    1.5.9
    Вы аддон поставили или русификацию только? И еще. Нужно сначала дать права администратору.
     
  12. motionvalue

    motionvalue Пользователь

    Регистрация:
    10.02.12
    Сообщения:
    6
    Симпатии:
    0
    Аддон ставил. Скачал архив их него в library закинул папку XenForo, в js паку 8wayrun. В настройках назначил права администратору. Все это делаю на локалхосте на денвере. Модули для XenPorta работают почти все, модуль новостей в форуме отображает новые посты. А вот вкладки portal как на картинке http://www.bormotuhi.net/imagehosting/2010/10/21/14cc0848f7ac7d.png не появляется, собственно и функция статьи писать тоже не появляется. Так же не работает и Wiki навигация. Пробовал ставить самые ранние версии XenPorta, там как и подобает появляется вкладка Porta и функция статей, но на новых версия работать отказывается. Собственно есть желание реализовать структуру похожую на http://do4a.com/ с такой же навигацией и системой статей, для этого и пытаюсь настроить XenPorta. Помогите разобраться.
     
  13. proof

    proof Пользователь

    Регистрация:
    18.01.12
    Сообщения:
    44
    Симпатии:
    9
    Версия XF:
    1.1.2
    Сделайте скрин , покажите, что у вас. Так будет понятнее ваша проблема
     
  14. motionvalue

    motionvalue Пользователь

    Регистрация:
    10.02.12
    Сообщения:
    6
    Симпатии:
    0
    Прикрепил скриншоты, на них показал что в панели управления включил "Стандартизировать боковую панель index (Боковая панель на форуме index будет соответствовать порталу.)" и при переходе на главную страницу действительно отображается содержание портала, если же эту функцию не ключать портал не появится. Как я понял по скришотам разработчиков при установке аддона вкладка Portal должна появляться автоматически, хотя может я и ошибаюсь.

    Тем не менее на самом сайте на главной странице во вкладке "администрирование модулей" добавил модули RecentNews и WikiNav, это видно на скриншоте. После того как я их применил на главной странице стали отображаться новости, но навигации сбоку так и не появилось(в этом то и заключается проблема). Так же в панели управления я отметил "Включить специальный шаблон для новостей/статей", но никакого шаблона я не увидел, статьи так и нельзя писать(это вторая часть проблемы).
     

    Вложения:

    • 1.jpg
      1.jpg
      Размер файла:
      78,7 КБ
      Просмотров:
      89
    • 2.jpg
      2.jpg
      Размер файла:
      65,4 КБ
      Просмотров:
      86
    • 3.jpg
      3.jpg
      Размер файла:
      52,8 КБ
      Просмотров:
      87
  15. Reborns

    Reborns Местный

    Регистрация:
    24.11.11
    Сообщения:
    91
    Симпатии:
    48
    Версия XF:
    1.5.5
    оппа мне тоже интересно как сделан пункт НАВИГАЦИЯ ? тут http://do4a.com/ у меня стоят Ксен 1.1.2 и Портал 1.5.2 но такого не вижу у себя , и кстати у меня настройки портала выглядят иначе, не так как у motionvalue. Это нормально ?
    Capture.PNG
     
  16. motionvalue

    motionvalue Пользователь

    Регистрация:
    10.02.12
    Сообщения:
    6
    Симпатии:
    0
    у меня просто на скриншоте другая версия портала, более ранняя, но смысл тот же. я какие уже только не перепробовал версии ставить, вкладки портал не появилось и режима написания статей тоже.
     
  17. hbq

    hbq Активный пользователь

    Регистрация:
    27.07.11
    Сообщения:
    58
    Симпатии:
    23
    Версия XF:
    1.1.2
  18. motionvalue

    motionvalue Пользователь

    Регистрация:
    10.02.12
    Сообщения:
    6
    Симпатии:
    0
    Это конечно все здорово, но написание статей от этого не появится. Его как небыло так и нет.
     
  19. Romchik®

    Romchik® The Power of Dreams Команда форума

    Регистрация:
    26.09.10
    Сообщения:
    5.740
    Симпатии:
    5.269
    Версия XF:
    1.5.11
    А кто вам сказал, что там стоит XenPorta?
     
  20. motionvalue

    motionvalue Пользователь

    Регистрация:
    10.02.12
    Сообщения:
    6
    Симпатии:
    0
    Если поставить портал одну из самых ранних версий то навигация очень схожая и режим написания статей поддерживается. На последних же версиях портала ни навигация ни режим написания статей почему то не включаются, хотя предусмотрены.
     

Поделиться этой страницей