1. Приветствуем Вас на неофициальном форуме технической поддержки XenForo на русском языке. XenForo - новый и перспективный форумный движок от бывших создателей vBulletin.

Not a Bug Class 'XFCP_XfRu_MergeDoubleUserPost_ControllerPublic_Thread' not found in

Тема в разделе "Баги XenForo", создана пользователем Pavel, 9 ноя 2010.

Загрузка
  1. Pavel

    Pavel Местный

    Регистрация:
    26.09.10
    Сообщения:
    392
    Симпатии:
    93
    Иногда выскакивает ошибка при обращении к странице http://www.bglife.ru/online/
    Что это может быть?
     
  2. Макар

    Макар Вопрошатель

    Регистрация:
    07.10.10
    Сообщения:
    216
    Симпатии:
    70
    ну так написано клас not found in
    виновный MergeDoubleUserPost
    или установил криво
    или не все файлы залил
    или после его установки ставил еще что то , что вмешивается в работу
     
  3. Pepelac

    Pepelac Продам луц в бутылках Команда форума

    Регистрация:
    28.09.10
    Сообщения:
    1.794
    Симпатии:
    1.348
    Меня это тоже очень интересует. Тут тоже несколько раз ловил эту ошибку, но так и не смог понять пока, что к ней приводит.
    Какой-то внутренний трабл движка, когда он не может разобраться с прокси-классом. Спрашивал у Кира и Майка, но ничего от них в ответ не получил. Так что буду разбираться.

    Павел, я бы порекомендовал в файл config.php вставить хотя бы это (ибо светить пользователям такие ошибки не очень хорошо):
    PHP:
    ini_set("display_errors"0);
    ini_set("log_errors"1);
    тем самым отключив вывод ошибок на экран. Они будут записываться в файл (который задан по умолчанию в настройках PHP)
     
    Pavel, vitalik, CyberAP и ещё 1-му нравится это.
  4. Dimm-skY

    Dimm-skY Активный пользователь

    Регистрация:
    26.10.10
    Сообщения:
    31
    Симпатии:
    11
    А разве без этой записи логи не пишуца?
     
  5. Pepelac

    Pepelac Продам луц в бутылках Команда форума

    Регистрация:
    28.09.10
    Сообщения:
    1.794
    Симпатии:
    1.348
    Не всегда и не везде. Все зависит от хостера.
     
  6. FractalizeR

    FractalizeR XenForo Addicted Команда форума

    Регистрация:
    27.09.10
    Сообщения:
    1.085
    Симпатии:
    822
    Версия XF:
    1.3.2
    Вы кеширование не включали? Некоторые версии APC иногда дают примерно такие же симптомы. Если APC активен (не на форуме, а вообще на сервере) попробуйте выключить.
     
    Pavel нравится это.
  7. Pepelac

    Pepelac Продам луц в бутылках Команда форума

    Регистрация:
    28.09.10
    Сообщения:
    1.794
    Симпатии:
    1.348
    Ну тут точно не было кэширования (если только хостер без моего ведома не включил :)). Так что где-то еще проблема будет.
     

Поделиться этой страницей