1. Приветствуем Вас на неофициальном форуме технической поддержки XenForo на русском языке. XenForo - новый и перспективный форумный движок от бывших создателей vBulletin.

Fatal error: Class name must be a valid object or a string in ... on line 280

Тема в разделе "Для новичков", создана пользователем ShanKo, 23 май 2011.

Загрузка
  1. ShanKo

    ShanKo Местный

    Регистрация:
    16.10.10
    Сообщения:
    17
    Симпатии:
    14
    Вот такую ошибку выдает при попытке обновить кэш поиска:

    Fatal error: Class name must be a valid object or a string in .../library/XenForo/Search/DataHandler/Abstract.php on line 280 Доходит до последнего сообщения на форуме и прерывается, после чего вылезает ошибка.

    При чем, такая же ошибка проявляется и при поиске новых сообщений в профиле у админа, а у остальных пользователей на первый взгляд все нормально.

    Из аддонов поставлено только:

    • Find users sharing the same IP 0.0.2
    • Likes Review 1.0.0
    • Post Message Regex Replacer 1.0.0
    • Simple Sitemap 1.02
    • TaigaChat 0.4.3
    • Tapatalk 1.1.1
    • Who Has Read A Thread 0.9.2
    • Xen-TR.com Who Has Visited 2.5.1
    • [xfr] User Albums 1.0.0 b2
    • [xfr] Предотвращение даблпостинга 1.2.0
    Ни у кого нет идей из-за чего такое может проявляться и где раскопки производить? А то у самого идеи, кроме как поудалять все моды, уже исчерпались :)
     
  2. Gatses

    Gatses Местный

    Регистрация:
    05.02.11
    Сообщения:
    421
    Симпатии:
    579
    Версия XF:
    1.5.9
  3. ShanKo

    ShanKo Местный

    Регистрация:
    16.10.10
    Сообщения:
    17
    Симпатии:
    14
    Угу, но насколько помню тред дальше, то там автор заявил что исправил это во второй бете или я не прав? Так как, физически сносил мод и его файлы, но не помогло.
     
  4. Romchik®

    Romchik® The Power of Dreams Команда форума

    Регистрация:
    26.09.10
    Сообщения:
    5.740
    Симпатии:
    5.269
    Версия XF:
    1.5.11
    Ну если на самом деле уверены, что у вас стоит последняя версия альбомов и дело не в них (ибо это на самом деле исправлено во второй бете альбомов), то скорей всего дело в другом плагине. Советую сносить по одному и проверять. Лично я начал бы с Who Has Read A Thread.
     
  5. ShanKo

    ShanKo Местный

    Регистрация:
    16.10.10
    Сообщения:
    17
    Симпатии:
    14
    Если интересно, то это всё от аддона альбомов. Даже во второй бета версии проявляется ошибка. Удалил аддон начисто, вычистил базу полной перестановкой и перекопированием нужных таблиц - ошибка исчезла. Ошибка проявляется при перестройке поискового индекса, когда полностью проходит индексация сообщений и, в стандарте, должна переключиться на индекс тем. До индексации тем, конечно, она не доходит.
     
    Romchik® нравится это.
  6. Romchik®

    Romchik® The Power of Dreams Команда форума

    Регистрация:
    26.09.10
    Сообщения:
    5.740
    Симпатии:
    5.269
    Версия XF:
    1.5.11
    Продублируйте в теме альбомов или просто укажите ссылку на это сообщение. Возможно автор поправит, если ошибка действительно имеет место быть.
     

Поделиться этой страницей