1. Приветствуем Вас на неофициальном форуме технической поддержки XenForo на русском языке. XenForo - новый и перспективный форумный движок от бывших создателей vBulletin.

Fixed Глюк в XenForo 1.1.2 с кириллическим доменом

Тема в разделе "Баги XenForo", создана пользователем Kronger, 3 мар 2012.

Загрузка
  1. Kronger

    Kronger Пользователь

    Регистрация:
    18.01.12
    Сообщения:
    31
    Симпатии:
    16
    Версия XF:
    1.1.3
    Всем добрый день.
    Наткнулся на мега глюк в новой версии 1.1.2 при работе с кирилическим доменом.
    У меня домен Что-Делать.su
    Седня ночью поставил на хостинг XF1.1.2 залил русский язык. Захожу пользователем жму в левом нижнем углу на язык И... - ничего. окно выбора языка не появляется. Вижу что что-то отрабатывает (мелькает в правом верхнем углу загрузка) и всё. Лезу в админку смотреть лог ошибок - ничего. Бился часа 2 - без результатно. Никаких хаков не стоит - голый форум.
    Зная проблемы кирилических сайтов я в настройках прописал его перекодированный адрес: xn----8sble4ao1ag1b8c.su - это устраняет ошибку rss кнопки. но язык не выбирается.

    Снес базу и весь сайт нахрен.
    Поставил XF 1.1.1 Пролил язык. Всё заработало. Поставил обновление 1.1.2 - выбор языка перестал работать. Блин думаю. Фиг с ним не критично. Продолжил настраивать сайт - права, группы, префисы, дерево узлов. Поставил только 1 хак: "XenPorta (Portal) v.1.5.1"
    Добрался до создания первого поста о дне рождении сайта, написал текст жму "создать тему" - моргает загрузка в правом перхнем углу и ничего не происходит - тема не создается.
    Сносить сайт уже не хочу столько трудов по настройке.
    Но глюк уже критичный.
    В логах ошибок пусто.

    Плиз - хелп ми :(

    p.s. перед этим на локале всё настраивал. но адрес на локале английскийю И в 1.1.1 и в 1.1.2 там всё норм. Так что думаю это связано именно с кирилическим доменом.
    --- добавлено : Mar 3, 2012 2:18 PM ---
    Нашел ище одни подобный глюк: не работает выбор аватарки при нажатии на аватаре.
    и предварительный просмотр тоже не пашет.

    А в XF есть возможность даунгрейда? Если да, то подскажите.
     
  2. limonka

    limonka Заблокирован

    Регистрация:
    18.12.11
    Сообщения:
    5
    Симпатии:
    0
    Версия XF:
    1.1.1
    Надо покупать лицензию и задавать вопросы разработчику.
     
  3. TAIFUN

    TAIFUN Человек

    Регистрация:
    27.09.10
    Сообщения:
    2.120
    Симпатии:
    1.558
    Версия XF:
    1.5.9
    Создайте тестовый аккаунт и дайте ссылку на форум.
     
    Air Jordan нравится это.
  4. Kronger

    Kronger Пользователь

    Регистрация:
    18.01.12
    Сообщения:
    31
    Симпатии:
    16
    Версия XF:
    1.1.3
    У меня лицензионный форум.
    Всё снес и поставил 1.1.1 - пашет как трактор. Тьфу-Тьфу. Но глюков в нем не вижу.
    1.1.2 - глюкнутый.
    --- добавлено : Mar 4, 2012 1:04 PM ---
    Разработчику написал.
     
    TAIFUN нравится это.
  5. Kronger

    Kronger Пользователь

    Регистрация:
    18.01.12
    Сообщения:
    31
    Симпатии:
    16
    Версия XF:
    1.1.3
    Ответили буржуины.
    Мол зашли на ваш сайт. Ошибки не нашли. Наверное потому, что вы перешли на 1.1.1.
    Помочь ничем не можем.

    P.S. Я так понимаю у себя они там не особо собираются моделировать ошибку.
     
  6. TAIFUN

    TAIFUN Человек

    Регистрация:
    27.09.10
    Сообщения:
    2.120
    Симпатии:
    1.558
    Версия XF:
    1.5.9
    Дык им нужно увидеть ошибку, чтобы понять в чем дело. Не покупать же кирилл. домен.
     
    Romchik® нравится это.
  7. Romchik®

    Romchik® The Power of Dreams Команда форума

    Регистрация:
    26.09.10
    Сообщения:
    5.736
    Симпатии:
    5.263
    Версия XF:
    1.5.10
    В любом случае в настройках всегда нужно указывать такой вариант: xn----8sble4ao1ag1b8c.su
    Раньше проблем с такими доменами не было, может и правда в 1.1.2 баг вылез. Тут на самом деле только обновляться до 1.1.2 и снова разработчиков звать.
     
  8. mahorka42

    mahorka42 Местный

    Регистрация:
    08.10.10
    Сообщения:
    210
    Симпатии:
    18
    Версия XF:
    1.4.0
    тс чрез какой браузер пробовали ? у меня такие же проблемы если зайти на форум с оперы
     
  9. Kronger

    Kronger Пользователь

    Регистрация:
    18.01.12
    Сообщения:
    31
    Симпатии:
    16
    Версия XF:
    1.1.3
    С разных.
    IE9, FireFox, Opera
    Всегда проверяю из нескольких.

    Кстати в 1.1.1 - всё нормуль.
    Буду пока на 1.1.1
     
  10. Romchik®

    Romchik® The Power of Dreams Команда форума

    Регистрация:
    26.09.10
    Сообщения:
    5.736
    Симпатии:
    5.263
    Версия XF:
    1.5.10
    Если это все же баг, то его нужно править. Сделайте копию и обновите на 1.1.2, чтобы разработчики могли посмотреть.
     
  11. Kronger

    Kronger Пользователь

    Регистрация:
    18.01.12
    Сообщения:
    31
    Симпатии:
    16
    Версия XF:
    1.1.3
    В общем после догих выяснений дал я им доступ на свой FTP. Они поковырялись и признали наличие глюка. Вот официальный ответ:
    Hi,
    I have worked around this on your site now. I will look at including a fix for this in the next release of XenForo.
    Regards,
    Mike

    Осталось выяснить когда будет этот фикс.
     
    Romchik®, TAIFUN, Ra и ещё 1-му нравится это.
  12. Romchik®

    Romchik® The Power of Dreams Команда форума

    Регистрация:
    26.09.10
    Сообщения:
    5.736
    Симпатии:
    5.263
    Версия XF:
    1.5.10
    Вот видите, о чем и речь была :thumbsup:

    Ну а фикс должен быть в 1.1.3.
     
  13. sa1nt

    sa1nt Местный

    Регистрация:
    01.03.12
    Сообщения:
    20
    Симпатии:
    1
    Версия XF:
    1.1.3
    Остается только ждать скорейшего обновление релиза.
     

Поделиться этой страницей