1. Приветствуем Вас на неофициальном форуме технической поддержки XenForo на русском языке. XenForo - новый и перспективный форумный движок от бывших создателей vBulletin.

Не работает ID для Google Analytics

Тема в разделе "Основные вопросы по XenForo", создана пользователем ikar, 7 авг 2011.

Загрузка
  1. ikar

    ikar Активный пользователь

    Регистрация:
    27.07.11
    Сообщения:
    11
    Симпатии:
    0
    При внесении в поле - ID для Google Analytics - своего ID с Аналитикса, код на сайте выводится в изуродованном виде и естественно статистика Гугла не работает.
     
  2. TAIFUN

    TAIFUN Человек

    Регистрация:
    27.09.10
    Сообщения:
    2.121
    Симпатии:
    1.560
    Версия XF:
    1.5.9
    Покажите.
     
  3. ikar

    ikar Активный пользователь

    Регистрация:
    27.07.11
    Сообщения:
    11
    Симпатии:
    0
    Код:
    <script type="text/javascript">
        <!--
        var _gaq = [['_setAccount', 'UA-xxxxxx-x'], ['_trackPageview']];
        !function(d, t)
        {
            var g = d.createElement(t),
                s = d.getElementsByTagName(t)[0];
            g.async = true;
            g.src = ('https:' == d.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
            s.parentNode.insertBefore(g, s);
        }
        (document, 'script');
        //-->
        </script>
    --- добавлено : Aug 7, 2011 10:06 AM ---
    т.е. скрипт его комментирует по всей видимости.
     
  4. Pepelac

    Pepelac Продам луц в бутылках Команда форума

    Регистрация:
    28.09.10
    Сообщения:
    1.794
    Симпатии:
    1.349
    Вы ради прикола сравните его с тем, который на этом сайте. Абсолютно нормальный у вас скрипт.
     
  5. ikar

    ikar Активный пользователь

    Регистрация:
    27.07.11
    Сообщения:
    11
    Симпатии:
    0
    мне ради прикола пришлось вручную вставлять код, т.к. если через админку, то код не фиксируется в гугле.
     
  6. TAIFUN

    TAIFUN Человек

    Регистрация:
    27.09.10
    Сообщения:
    2.121
    Симпатии:
    1.560
    Версия XF:
    1.5.9
    Лицензионная версия или зануленая?
     
  7. ikar

    ikar Активный пользователь

    Регистрация:
    27.07.11
    Сообщения:
    11
    Симпатии:
    0
    Знакомые ставили нулл, чтобы тестить, и вот на тестах обнаружили такую серьезную проблему.
    Если нулл, то причем тут обработка кода Гугла?
     
  8. Yoskaldyr

    Yoskaldyr Пользователь

    Регистрация:
    27.09.10
    Сообщения:
    1.921
    Симпатии:
    1.160
    Версия XF:
    1.0.4
    ну если в нуле игрались с шаблонами, то легко такое может быть :)
     
  9. ikar

    ikar Активный пользователь

    Регистрация:
    27.07.11
    Сообщения:
    11
    Симпатии:
    0
    А в чем там играться возможно? Разве нулл там делают?
     
  10. snake007v

    snake007v Местный

    Регистрация:
    22.01.11
    Сообщения:
    37
    Симпатии:
    25
    Версия XF:
    1.1.2
    Какая версия xenforo, где скачали? Пробовал и на локалке и на рабочем форуме: код устанавливается правильно и гугл его распознает. Попробуйте ввести ID сразу же после установки движка, на чистом форуме.
     
  11. Yoskaldyr

    Yoskaldyr Пользователь

    Регистрация:
    27.09.10
    Сообщения:
    1.921
    Симпатии:
    1.160
    Версия XF:
    1.0.4
    в нуллах любят убирать все ссылки из шаблонов, может и код гугла вырезали :)
     
  12. snake007v

    snake007v Местный

    Регистрация:
    22.01.11
    Сообщения:
    37
    Симпатии:
    25
    Версия XF:
    1.1.2
    А в приведенном вами выводе, вы затерли аккаунт или там так и выводит: UA-xxxxxx-x ?
     
  13. ikar

    ikar Активный пользователь

    Регистрация:
    27.07.11
    Сообщения:
    11
    Симпатии:
    0
    нет, затерли.
    не понял вас.
    в ориг. шабах никакого гугла нет просто.
     
  14. snake007v

    snake007v Местный

    Регистрация:
    22.01.11
    Сообщения:
    37
    Симпатии:
    25
    Версия XF:
    1.1.2
    Yoskaldyr нравится это.
  15. Yoskaldyr

    Yoskaldyr Пользователь

    Регистрация:
    27.09.10
    Сообщения:
    1.921
    Симпатии:
    1.160
    Версия XF:
    1.0.4
    вообще-то есть в оригинальных шаблонах и шаблон как ни странно называется google_analytics :)
     
    snake007v и ikar нравится это.
  16. ikar

    ikar Активный пользователь

    Регистрация:
    27.07.11
    Сообщения:
    11
    Симпатии:
    0
    вот за ответ спасибо.
    еще подскажите пожалуйста, где в самом скрипте можно переставить выводимый код Аналитикса, чтобы он выводился сразу перед - </head> ?
     
  17. Yoskaldyr

    Yoskaldyr Пользователь

    Регистрация:
    27.09.10
    Сообщения:
    1.921
    Симпатии:
    1.160
    Версия XF:
    1.0.4
    PAGE_CONTAINER
     

Поделиться этой страницей