1. Приветствуем Вас на неофициальном форуме технической поддержки XenForo на русском языке. XenForo - новый и перспективный форумный движок от бывших создателей vBulletin.

1.1.2 Не устанавливаются дополнения

Тема в разделе "Основные вопросы по XenForo", создана пользователем salemok, 24 апр 2012.

Загрузка
  1. salemok

    salemok Активный пользователь

    Регистрация:
    13.02.11
    Сообщения:
    3
    Симпатии:
    8
    При попытке установить любое дополнение вылетает "Пожалуйста, введите корректное имя метода обработчика", потом дополнение появляется в списке установленных, однако не каких изменений в шаблонах нет.
     
  2. Romchik®

    Romchik® The Power of Dreams Команда форума

    Регистрация:
    26.09.10
    Сообщения:
    5.740
    Симпатии:
    5.269
    Версия XF:
    1.5.11
    При установке любого дополнения, прежде чем импортировать XML файл в админке, всегда нужно сначала заливать файлы на FTP.
     
  3. infinityspace666

    infinityspace666 Новичок

    Регистрация:
    21.01.16
    Сообщения:
    21
    Симпатии:
    2
    Версия XF:
    1.5.5
    Всем привет. Любое дополнение, будь то стиль, или плагин не устанавливается. Выдает сообщение при попытке установить дополнение.

    Все файлы из папки "Upload" первым делом заливаю на сервер, а по том уже пытаюсь установить дополнение.

    движок стоит XenForo 1.5.10
     
  4. infis

    infis Местный Команда форума

    Регистрация:
    27.06.11
    Сообщения:
    5.525
    Симпатии:
    3.320
    Версия XF:
    1.5.9
    Значит не тот файл пытаетесь "скормить" инсталлятору.
     
    Mirovinger и Kolya groza morey нравится это.
  5. infinityspace666

    infinityspace666 Новичок

    Регистрация:
    21.01.16
    Сообщения:
    21
    Симпатии:
    2
    Версия XF:
    1.5.5
    Все дело в том, что эти файлы, которые инсталлятор кушал с удовольствием просто перестал их кушать ( наверное переел ).... Ставлю стиль soft_responsive_gray, все отлично, после удаляю его. Через минут 10-ть снова его ставлю,и, он отказывается его употреблять, далее стили скаченные с Вашего форума, - не один стиль не принимает, не одно дополнение. Вот и пойми его, что за бзики)
     
  6. infinityspace666

    infinityspace666 Новичок

    Регистрация:
    21.01.16
    Сообщения:
    21
    Симпатии:
    2
    Версия XF:
    1.5.5
    Дополню. Причем снес движок и заново переустановил, все с нуля. Русифицировал и сразу в установить дополнение. И снова такая история. Эти стили и плагины я уже устанавливал, нот сейчас не как не хотят, даже на свежий двиг.
     
  7. infis

    infis Местный Команда форума

    Регистрация:
    27.06.11
    Сообщения:
    5.525
    Симпатии:
    3.320
    Версия XF:
    1.5.9
    Чудес не бывает. В чем-то Вы ошибаетесь. По моему мнению в том, что не тот файл пытаетесь использовать при установке.
     
  8. infinityspace666

    infinityspace666 Новичок

    Регистрация:
    21.01.16
    Сообщения:
    21
    Симпатии:
    2
    Версия XF:
    1.5.5
    Вот смотрите. Сначала файлы заливаются через FTP на сервер в корневую папку, после, админка/установить дополнение. Уже тысячу так делал и все устанавливалось как по маслу, сейчас не хотят. (Указанный файл не является корректным файлом дополнения в формате XML). Посмотрите сами на файлы.

    Модификация Robotic by X-Shar
     

    Вложения:

  9. infis

    infis Местный Команда форума

    Регистрация:
    27.06.11
    Сообщения:
    5.525
    Симпатии:
    3.320
    Версия XF:
    1.5.9
    Если ошибка "Указанный файл не является корректным файлом дополнения в формате XML.", то уже неважно, что и куда Вы залили на сервер. Сам по себе файл xml некорректный, либо вместо него пытаетесь тот же архив загрузить. Еще, как вариант, по какой-то причине файл xml при отправке на сервер "бьется", то есть загружается не до конца или с ошибками. В общем или обращайтесь к специалисту, чтобы он посмотрел ситуацию живьем на сервере, или разбирайтесь сами. Более ничем Вам помочь никто не сможет.
     
    infinityspace666 нравится это.
  10. infinityspace666

    infinityspace666 Новичок

    Регистрация:
    21.01.16
    Сообщения:
    21
    Симпатии:
    2
    Версия XF:
    1.5.5
    Тем не менее спасибо Вам за ответы. Попытаюсь сначала сам понять причину.
     
  11. rostov

    rostov Новичок

    Регистрация:
    24.09.16
    Сообщения:
    5
    Симпатии:
    0
    Версия XF:
    1.5.6
    та же проблема и у меня но версия форума 1.5.6.
     
  12. rostov

    rostov Новичок

    Регистрация:
    24.09.16
    Сообщения:
    5
    Симпатии:
    0
    Версия XF:
    1.5.6
    пишет Файлы, связанные с этим дополнением, не найдены. Пожалуйста, загрузите их и повторите попытку.
    что делать???? грузил с сервера и с компа.... проверял подходит ли версия... читал всякие там правки в файлах и их правил... не идут плагины не один(((
    помогите
    установлена ваша версия 1.5.6. внизу сайта написано перевод... я так сюда собственно на форум и попал))) где скачал ее не помню.. но врятли диверсанты бы были))
    Может че-то нужно включить???? или в шаблоне прописать в каком???
     
  13. infinityspace666

    infinityspace666 Новичок

    Регистрация:
    21.01.16
    Сообщения:
    21
    Симпатии:
    2
    Версия XF:
    1.5.5
    Вы возможно загружаете либо битый файл, либо путаете дополнение (Addon) со стилем (styles). Screenshot.png
    Screenshot1.png

    Если можете загрузите на форум те файлы, которые Вы пытаетесь установить как дополнение XenForo.

     
  14. infis

    infis Местный Команда форума

    Регистрация:
    27.06.11
    Сообщения:
    5.525
    Симпатии:
    3.320
    Версия XF:
    1.5.9
    Ну это говорит о том, что хотя бы xml файл загружаете правильный. Остается из архива дополнения файлы в нужное место скопировать на сервере.
     
    infinityspace666 нравится это.
  15. rostov

    rostov Новичок

    Регистрация:
    24.09.16
    Сообщения:
    5
    Симпатии:
    0
    Версия XF:
    1.5.6
    Да вот скачал и с форума файлы... А в какое место на сервере??? Я на сервере создал папку plagin и в нее все кидаю... далее в ней создаю папку с названием плагина и в ней распаковываю плагин и в дополнениях выбираю импорт и вбиваю как там и указано /plagin/.... и далее путь к аддону_хмл...
    может я не те версии качаю???
    Например устанавливаю stickyfirstpost у меня уже более 10-ти таких плагинов скаченных с разных мест и ничего не идет(((
    хотя я тут у вас не видел этот плагин для 1.5.6. + чаты перепробывал ничего не идут((( кроме того я ваще на всякий случай копаю все папки все уже хмл закидывал - одна и та же ошибка...
    --- добавлено : Sep 25, 2016 8:15 AM ---
    все спс заработало))) нигде не написано было или непрочитал или не пишут для чайников что папку upload сначала нужно закинуть на сервер и только ее)))
    все заработало СПС
    теперь бы разобраться как включить настройки этого обновления))) буду шарить но уже прогрес установилось
    --- добавлено : Sep 25, 2016 8:23 AM ---
    снова штопор)
    установил stickyfirstpost в настройки/закрепление первого поста захожу... но при выделить все (все разделы) или конкретный из них и нажатии сохранить не сохраняет((( и на форуме не меняется..я видел что где то нужно включить разрешение на работу данного плагина??? не найду(((
    Помогите!
    --- добавлено : Sep 25, 2016 8:28 AM ---
    так разобрался для новых тем это правило работает (созданных после установки плагина - закрепления первого поста) а для старых нет(((
    Может есть скрипт какой для шаблона или еще какие настройки??? Чтобы и в старых темах первый пост стал первым на всех страницах???
     
    Последнее редактирование модератором: 3 окт 2016
  16. infis

    infis Местный Команда форума

    Регистрация:
    27.06.11
    Сообщения:
    5.525
    Симпатии:
    3.320
    Версия XF:
    1.5.9
    Вручную.
     
  17. rostov

    rostov Новичок

    Регистрация:
    24.09.16
    Сообщения:
    5
    Симпатии:
    0
    Версия XF:
    1.5.6
    а как??? ненайду в настройках темы или сообщений??? где что нажать???
     
  18. infis

    infis Местный Команда форума

    Регистрация:
    27.06.11
    Сообщения:
    5.525
    Симпатии:
    3.320
    Версия XF:
    1.5.9
    Если не ошибаюсь, то в опциях темы (при просмотре темы вверху есть меню раскрывающееся) нужно установить галочку соответствующую. Также в списке тем при выделении темы (их можно выделить несколько) будет плавающее меню, где также можно выбрать соответствующее действие.
     
  19. rostov

    rostov Новичок

    Регистрация:
    24.09.16
    Сообщения:
    5
    Симпатии:
    0
    Версия XF:
    1.5.6
    спс но нету ничего)
    я видел на скринах что пишут что есть но у мя нет... там еще где-то что-то вкл нужно чтобы эта опция появилась но не найду где(((
    --- добавлено : 25 сен 2016 в 16:21 ---
    установил галочку показывать иконку закрепления в списке тем, но не найду где эта иконка или что)))
    --- добавлено : 25 сен 2016 в 16:26 ---
    это просто иконка оказалась и все))) которая показывает что первый пост закреплен))
    --- добавлено : 25 сен 2016 в 16:27 ---
    говорят права нужно дать плагину где не нашел пока(
    --- добавлено : 25 сен 2016 в 16:32 ---
    все короче нашел! В правах пользователя поставить закрепить шапку разрешить)) и далее можно вручную в старых темах)))
    СПС
     
    Последнее редактирование модератором: 3 окт 2016
  20. infis

    infis Местный Команда форума

    Регистрация:
    27.06.11
    Сообщения:
    5.525
    Симпатии:
    3.320
    Версия XF:
    1.5.9
    Ну так сначала права настраивают, а уж потом ими пользуются, но никак не наоборот :)
     

Поделиться этой страницей