1. Приветствуем Вас на неофициальном форуме технической поддержки XenForo на русском языке. XenForo - новый и перспективный форумный движок от бывших создателей vBulletin.

Nginx - обязательно ставить последнюю версию?

Тема в разделе "OFF-топик", создана пользователем Edward, 9 апр 2013.

Загрузка
  1. Edward

    Edward Местный

    Регистрация:
    19.11.12
    Сообщения:
    207
    Симпатии:
    42
    Версия XF:
    1.1.3
    Чем в основном отличается nginx из репозитория Debian 6 (nginx/0.7.67) от последней стабильной версии nginx (1.2.x) ?
    Обязательно ставить последнюю стабильную (1.2.x)?
     
  2. CyberAP

    CyberAP Местный

    Регистрация:
    05.10.10
    Сообщения:
    2.577
    Симпатии:
    1.614
    Версия XF:
    1.5.10
  3. Edward

    Edward Местный

    Регистрация:
    19.11.12
    Сообщения:
    207
    Симпатии:
    42
    Версия XF:
    1.1.3
    А что версия nginx 1.3.15 26 Mar 2013 является стабильной? Смотрю там в каждом change логе багфиксы присутствуют. Да и не приходилось встречать еще сервера настроенные на 1.3.x
    Просто хочется узнать чем отличается nginx 0.7.67 от последних стабильных версий. Встречал не мало хороших ресурсов на которых установлен именно nginx 0.7.67, не зря ведь веб-мастера его устанавливают, а не новые версии?
     
  4. Yoskaldyr

    Yoskaldyr Пользователь

    Регистрация:
    27.09.10
    Сообщения:
    1.921
    Симпатии:
    1.160
    Версия XF:
    1.0.4
    устанавливают потому что есть в репозитории. К тому же чистый nginx нужен только тем кому все равно какая версия стоит (т.е. тупая отдача статики). Кому нужно больше (geoip, расширенная работа с бекэндами и переменнами, отдача mp4 контента и т.д.) нужны дополнительные модули, которые приходится или собирать самому (т.е. полностью пересобирать nginx) или использовать сторонние репы где эти модули уже включены в сборку. И вот эти дополнительные модули очень часто требуют более новую версию nginx-а чем 0.7.67.

    Поэтому если nginx устраивает по функционалу - то можно оставаться на текущей версии, а если же нужно больше - то искать нужную сборку нужной версии или собирать самому с нужными модулями.
     
    Oleg-2012 и Edward нравится это.

Поделиться этой страницей