1. Приветствуем Вас на неофициальном форуме технической поддержки XenForo на русском языке. XenForo - новый и перспективный форумный движок от бывших создателей vBulletin.

Server Issue No such file or directory error

Тема в разделе "Баги XenForo", создана пользователем Artlasers, 21 мар 2013.

Загрузка
  1. Artlasers

    Artlasers Новичок

    Регистрация:
    27.02.13
    Сообщения:
    4
    Симпатии:
    0
    Версия XF:
    1.1.3
    Здравствуйте! Очень много ошибок в логах типа:
    Код:
    2013/03/21 14:30:28 [error] 16381#0: *7889 open() "/home/***/www/forum/threads/Отражение-луча-попало-в-глаз.23/data/avatars/m/0/3.jpg" failed (2: No such file or directory), client: 213.242.202.13, server: www.lasers.org.ru, request: "GET /forum/threads/%D0%9E%D1%82%D1%80%D0%B0%D0%B6%D0%B5%D0%BD%D0%B8%D0%B5-%D0%BB%D1%83%D1%87%D0%B0-%D0%BF%D0%BE%D0%BF%D0%B0%D0%BB%D0%BE-%D0%B2-%D0%B3%D0%BB%D0%B0%D0%B7.23/data/avatars/m/0/3.jpg?1303025372 HTTP/1.1", host: "lasers.org.ru"
    2013/03/21 14:30:28 [error] 16381#0: *7897 open() "/home/***/www/forum/threads/Отражение-луча-попало-в-глаз.23/data/avatars/m/0/1.jpg" failed (2: No such file or directory), client: 213.242.202.13, server: www.lasers.org.ru, request: "GET /forum/threads/%D0%9E%D1%82%D1%80%D0%B0%D0%B6%D0%B5%D0%BD%D0%B8%D0%B5-%D0%BB%D1%83%D1%87%D0%B0-%D0%BF%D0%BE%D0%BF%D0%B0%D0%BB%D0%BE-%D0%B2-%D0%B3%D0%BB%D0%B0%D0%B7.23/data/avatars/m/0/1.jpg?1298804149 HTTP/1.1", host: "lasers.org.ru"
    2013/03/21 14:30:28 [error] 16380#0: *7895 open() "/home/***/www/forum/threads/Отражение-луча-попало-в-глаз.23/data/avatars/m/0/108.jpg" failed (2: No such file or directory), client: 213.242.202.13, server: www.lasers.org.ru, request: "GET /forum/threads/%D0%9E%D1%82%D1%80%D0%B0%D0%B6%D0%B5%D0%BD%D0%B8%D0%B5-%D0%BB%D1%83%D1%87%D0%B0-%D0%BF%D0%BE%D0%BF%D0%B0%D0%BB%D0%BE-%D0%B2-%D0%B3%D0%BB%D0%B0%D0%B7.23/data/avatars/m/0/108.jpg?1298855607 HTTP/1.1", host: "lasers.org.ru"
    2013/03/21 14:30:28 [error] 16380#0: *7896 open() "/home/***/www/forum/threads/Отражение-луча-попало-в-глаз.23/data/avatars/m/0/2.jpg" failed (2: No such file or directory), client: 213.242.202.13, server: www.lasers.org.ru, request: "GET /forum/threads/%D0%9E%D1%82%D1%80%D0%B0%D0%B6%D0%B5%D0%BD%D0%B8%D0%B5-%D0%BB%D1%83%D1%87%D0%B0-%D0%BF%D0%BE%D0%BF%D0%B0%D0%BB%D0%BE-%D0%B2-%D0%B3%D0%BB%D0%B0%D0%B7.23/data/avatars/m/0/2.jpg?1362041615 HTTP/1.1", host: "lasers.org.ru"
    2013/03/21 14:30:28 [error] 16381#0: *7898 open() "/home/***/www/forum/threads/Отражение-луча-попало-в-глаз.23/data/avatars/m/0/66.jpg" failed (2: No such file or directory), client: 213.242.202.13, server: www.lasers.org.ru, request: "GET /forum/threads/%D0%9E%D1%82%D1%80%D0%B0%D0%B6%D0%B5%D0%BD%D0%B8%D0%B5-%D0%BB%D1%83%D1%87%D0%B0-%D0%BF%D0%BE%D0%BF%D0%B0%D0%BB%D0%BE-%D0%B2-%D0%B3%D0%BB%D0%B0%D0%B7.23/data/avatars/m/0/66.jpg?1298836400 HTTP/1.1", host: "lasers.org.ru"
    
    хотя форум исправно работает и авы показывает. откуда это может расти?
     
  2. infis

    infis Местный Команда форума

    Регистрация:
    27.06.11
    Сообщения:
    5.450
    Симпатии:
    3.274
    Версия XF:
    1.5.9
    У Вас вообще-то некорректно работает mod_rewrite апача, если таковой вообще включен. Попробуйте выключить ЧПУ и посмотреть, какие ошибки останутся.
     
  3. Artlasers

    Artlasers Новичок

    Регистрация:
    27.02.13
    Сообщения:
    4
    Симпатии:
    0
    Версия XF:
    1.1.3
    mod_rewrite включен, работает, проверил. Без ЧПУ и ошибок нет, это да..
    .htaccess родной от xenforo.
    А вот почему некорректно путь составляется, не могу понять.
    ведь если вместо
    Код:
    /home/***/www/forum/threads/Отражение-луча-попало-в-глаз.23/data/avatars/m/0/66.jpg
    написать
    Код:
    /home/***/www/forum/data/avatars/m/0/66.jpg
    то файл найдется.
     
  4. infis

    infis Местный Команда форума

    Регистрация:
    27.06.11
    Сообщения:
    5.450
    Симпатии:
    3.274
    Версия XF:
    1.5.9
    А как проверяли, что работает? Ведь как раз ошибка виртуального пути и указывает на то, что не работает. У Вас вообще htaccess работает? Попробуйте туда написать абракадабру какую-нибудь в первой строке. Если сайт/форум при этом будут открываться, значит у Вас этот файл не работает в принципе. Если выдаст ошибку 500, значит файл работает, и нужно искать уже причину в апаче. И, кстати, у Вас апач стоит?
     
  5. Artlasers

    Artlasers Новичок

    Регистрация:
    27.02.13
    Сообщения:
    4
    Симпатии:
    0
    Версия XF:
    1.1.3
    и абракадабру и просто правила писал, все корректно обрабатывается..
    апач+nginx стоит.
     
  6. infis

    infis Местный Команда форума

    Регистрация:
    27.06.11
    Сообщения:
    5.450
    Симпатии:
    3.274
    Версия XF:
    1.5.9
    Странно. Хорошо, а как проверяли mod_rewrite?
     
  7. Artlasers

    Artlasers Новичок

    Регистрация:
    27.02.13
    Сообщения:
    4
    Симпатии:
    0
    Версия XF:
    1.1.3
    написал правило чтоб открывался index.php при любом адресе, и он открывался.
    UPDATE
    причем ошибка не появляется каждый раз, только иногда. например если сразу перейти на ref ссылку ошибки, то ошибка не повторяется.
     
  8. infis

    infis Местный Команда форума

    Регистрация:
    27.06.11
    Сообщения:
    5.450
    Симпатии:
    3.274
    Версия XF:
    1.5.9
    Тогда даже и не знаю, на что грешить...
     

Поделиться этой страницей