1. Приветствуем Вас на неофициальном форуме технической поддержки XenForo на русском языке. XenForo - новый и перспективный форумный движок от бывших создателей vBulletin.

Ошибка "An unexpected error occurred. Please try again later."

Тема в разделе "Основные вопросы по XenForo", создана пользователем Alesto, 10 мар 2012.

Загрузка
  1. Alesto

    Alesto Пользователь

    Регистрация:
    10.03.12
    Сообщения:
    7
    Симпатии:
    0
    Добрый вечер,форумчане.
    Решил поставить себе xenForo,установка прошла успешна.
    Все нормально установилось,начал проверять форум.
    Зашел на него,и выбило такую ошибку "An unexpected error occurred. Please try again later."
    Посмотрел в базе xf_error_log ошибку.
    Сама ошибка в данном файле:
    library\XenForo\ViewRenderer\HtmlPublic.php (line 56)

    ErrorException


    В чем возможна данная проблема?
    Тесты на работоспособность форума проходил.
    Писало что все рабочее,и т.п :)
     
  2. TAIFUN

    TAIFUN Человек

    Регистрация:
    27.09.10
    Сообщения:
    2.121
    Симпатии:
    1.560
    Версия XF:
    1.5.9
    Версию форума в профиле укажите или в сообщении.
     
  3. Alesto

    Alesto Пользователь

    Регистрация:
    10.03.12
    Сообщения:
    7
    Симпатии:
    0
    Та уже все версии ставил.
    А на данный момент стоит xen foro 5 beta
     
  4. Yoskaldyr

    Yoskaldyr Пользователь

    Регистрация:
    27.09.10
    Сообщения:
    1.921
    Симпатии:
    1.160
    Версия XF:
    1.0.4
    Ну это же очень старая версия...
     
  5. Alesto

    Alesto Пользователь

    Регистрация:
    10.03.12
    Сообщения:
    7
    Симпатии:
    0
    Та уже все версии ставил.
    В основном такая ошибка :(
    --- добавлено : Mar 10, 2012 10:36 AM ---
    Сейчас поставил версию 1.0.2
    Точно такая же ошибка.
    Установил,вошел в панель админа. Перешел на форум,зашло.
    Потом пробую еще раз,и уже ошибка
     
  6. Alesto

    Alesto Пользователь

    Регистрация:
    10.03.12
    Сообщения:
    7
    Симпатии:
    0
    Заметил очень интересную штучку)
    При заходи вот так:
    www.moysayt.ru/forum1 ( выбивает ошибку,при заходе на главную страницу форума)
    А вот скопировал,уже какую-то тему и решил зайти
    http://www.rf-rof.in/forum1/index.php?/tema то заходит)
    Очень интересная ситуация )
     
  7. TAIFUN

    TAIFUN Человек

    Регистрация:
    27.09.10
    Сообщения:
    2.121
    Симпатии:
    1.560
    Версия XF:
    1.5.9
    Что за ошибка?
     
  8. Alesto

    Alesto Пользователь

    Регистрация:
    10.03.12
    Сообщения:
    7
    Симпатии:
    0
    Такая же :(
    Именно главная страница форума-ошибка.
    А если по сыллке на тему зайти,то все нормально работает.
     
  9. TAIFUN

    TAIFUN Человек

    Регистрация:
    27.09.10
    Сообщения:
    2.121
    Симпатии:
    1.560
    Версия XF:
    1.5.9
    Код:
        * Renders a view.
        * [USER=1205]Seeing better[/USER]iewRenderer_Abstract::renderView()
        */
        public function renderView($viewName, array $params = array(), $templateName = '', XenForo_ControllerResponse_View $subView = null)
        {
            $this->_contentTemplate = $templateName;
    Почему не установите последнюю версию XenForo? Какой хостинг используете? Лицензия или зануленная версия?
     
  10. Alesto

    Alesto Пользователь

    Регистрация:
    10.03.12
    Сообщения:
    7
    Симпатии:
    0
    У меня стоит выделенный сервер.
    На нем висит сайт,решил поставить форум.
    На главную страницу форума выбивает данную ошибку.
    В чем проблема,непойму
    P.s Уже все Версии поставил.

    Смотрите,для теста решил проверить форум.
    Вот захожу так:
    http://www.moy_sayt.in/forum/index.php (1 раз зашло,потом ошибка)
    Скопировал именно темку на форуме и решил зайти:
    http://www.moy_sayt.in/forum/index.php?forums/main-forum.2/ (Постоянно заходит)
    В чем проблема ?
     
  11. infis

    infis Местный Команда форума

    Регистрация:
    27.06.11
    Сообщения:
    5.525
    Симпатии:
    3.320
    Версия XF:
    1.5.9
    А никак не заходит. Либо что-то намудрили с htaccess, либо какие-то проблемы с ЧПУ, либо какой-то скрипт "косячит". Начать следует с изучения логов веб-сервера - как с access, так и с errors. Затем удостовериться, что htaccess корректный. Проверить скрипты на целостность еще не мешает.
    Кстати, на указанном Вами сайте вообще практически любой запрос приводит к ошибке 404. Т.е., даже нагло указав прямой путь типа /forum/rgba.php или /forum/css.php, получим ошибку 404. Такого по идее быть не должно.
     
  12. Alesto

    Alesto Пользователь

    Регистрация:
    10.03.12
    Сообщения:
    7
    Симпатии:
    0
    Если вы пытались перейти по мое

    Если вы пытались перейти по моей сыллке,то вполне возможна данная ошибка )
    Т.к я ставил уже кучу форумом,и всегда 2 варианта:
    1)Падает апач
    2)Ошибка 500
    3)С вашим форумом,ошибка указана в теме)
    P.s А форум то ваш понравился,буду мучаться значит.
     
  13. infis

    infis Местный Команда форума

    Регистрация:
    27.06.11
    Сообщения:
    5.525
    Симпатии:
    3.320
    Версия XF:
    1.5.9
    Ну тогда попробуйте кардинальный метод - поменять ОС ;)
     

Поделиться этой страницей