1. Приветствуем Вас на неофициальном форуме технической поддержки XenForo на русском языке. XenForo - новый и перспективный форумный движок от бывших создателей vBulletin.

Ошибка при загрузке аватар: а server error occured

Тема в разделе "Основные вопросы по XenForo", создана пользователем KirillDE, 9 окт 2010.

Загрузка
  1. KirillDE

    KirillDE Местный

    Регистрация:
    09.10.10
    Сообщения:
    17
    Симпатии:
    7
    при загрузке аватары вылезает сообщение

    20101009-200229.jpg

    права доступа к папке data выставлены на 777, туда всё остальное нормально пишется, и сама аватара тоже загружается туда (/data/avatars/l/0/1.jpg), но потом почему то не обрабатывается.
    даже не знаю, в какую сторону копать. есть идеи?
     
  2. g0rn

    g0rn Местный

    Регистрация:
    03.10.10
    Сообщения:
    107
    Симпатии:
    146
    В админке во вкладке Tools есть Server Error Log — там что-то есть?
     
  3. KirillDE

    KirillDE Местный

    Регистрация:
    09.10.10
    Сообщения:
    17
    Симпатии:
    7
    спасибо за подсказку, не знал, что в движке есть логи)

    да, там есть:
    rename(/var/tmp/phpj2COhn,/usr/home/pvpmania/www/forum/data/avatars/l/0/1.jpg) [<a href='function.rename'>function.rename</a>]: Operation not permitted

    File: library/XenForo/Model/Avatar.php:302
     
  4. Макар

    Макар Вопрошатель

    Регистрация:
    07.10.10
    Сообщения:
    216
    Симпатии:
    70
    А я вот себе тут еле аватар поставил. Выбираю картинку а ничего не происходит. А потом захожу в профиль а она (последняя из тех что пробовал) установилась .
     
  5. KirillDE

    KirillDE Местный

    Регистрация:
    09.10.10
    Сообщения:
    17
    Симпатии:
    7
    проблема до сих пор сталась, на офф сайте никто про подобное не писал вроде..
     
  6. KirillDE

    KirillDE Местный

    Регистрация:
    09.10.10
    Сообщения:
    17
    Симпатии:
    7
    Stack Trace

    #0 [internal function]: XenForo_Application::handlePhpError(2, 'rename(/var/tmp...', '/usr/home/pvpma...', 302, Array)
    #1 /usr/home/pvpmania/www/forum/library/XenForo/Model/Avatar.php(302): rename('/var/tmp/phpj2C...', '/usr/home/pvpma...')
    #2 /usr/home/pvpmania/www/forum/library/XenForo/Model/Avatar.php(189): XenForo_Model_Avatar->_writeAvatar(1, 'l', '/var/tmp/phpj2C...')
    #3 /usr/home/pvpmania/www/forum/library/XenForo/Model/Avatar.php(67): XenForo_Model_Avatar->applyAvatar(1, '/var/tmp/phpj2C...', 3, 152, 155, Array)
    #4 /usr/home/pvpmania/www/forum/library/XenForo/ControllerPublic/Account.php(482): XenForo_Model_Avatar->uploadAvatar(Object(XenForo_Upload), 1, Array)
    #5 /usr/home/pvpmania/www/forum/library/XenForo/FrontController.php(303): XenForo_ControllerPublic_Account->actionAvatarUpload()
    #6 /usr/home/pvpmania/www/forum/library/XenForo/FrontController.php(132): XenForo_FrontController->dispatch(Object(XenForo_RouteMatch))
    #7 /usr/home/pvpmania/www/forum/index.php(15): XenForo_FrontController->run()
    #8 {main}
     
  7. KirillDE

    KirillDE Местный

    Регистрация:
    09.10.10
    Сообщения:
    17
    Симпатии:
    7
    как я понял, проблема с правами, но не понятно, в чём конкретно. форум по идее должен создавать подпапки (avatars, l, 1) с 755 а создаёт с 777
     
  8. KirillDE

    KirillDE Местный

    Регистрация:
    09.10.10
    Сообщения:
    17
    Симпатии:
    7
    вложенные файлы при этом загружаются нормально, так что наверное всё таки не из за прав это. пробовал полностью удалить папку data и создать заново - не помогло.
     
  9. KirillDE

    KirillDE Местный

    Регистрация:
    09.10.10
    Сообщения:
    17
    Симпатии:
    7
    разобрался, загружаемые мной изображения были меньше, чем 200*200 пикселей.

    нерешённым остался только один вопрос - как изменить эти цифры? максимальный вес аватары изменяется в правах групп пользователей, а вот размер где?
     
  10. KirillDE

    KirillDE Местный

    Регистрация:
    09.10.10
    Сообщения:
    17
    Симпатии:
    7
    ап, при загрузке аватаров меньше, чем 200*200 пикселей вылезает ошибка из первого поста.

    есть идеи?
     
  11. KirillDE

    KirillDE Местный

    Регистрация:
    09.10.10
    Сообщения:
    17
    Симпатии:
    7
    пофиксил,

    library/XenForo/Model/Avatar.php:302 :
    PHP:
                $success rename($tempFile$filePath);
    >>>>>>>>
                
    $success = @rename($tempFile$filePath);
     
    Ku4a, offroad, Firkys и 3 другим нравится это.
  12. Romchik®

    Romchik® The Power of Dreams Команда форума

    Регистрация:
    26.09.10
    Сообщения:
    5.740
    Симпатии:
    5.269
    Версия XF:
    1.5.11
    А как вышли на это решение?
     
  13. FractalizeR

    FractalizeR XenForo Addicted Команда форума

    Регистрация:
    27.09.10
    Сообщения:
    1.085
    Симпатии:
    823
    Версия XF:
    1.3.2
    Странно, что тут rename() используется, а не move_uploaded_file как должно.

    А описание причины тут: http://bugs.php.net/bug.php?id=50676
     
  14. Romchik®

    Romchik® The Power of Dreams Команда форума

    Регистрация:
    26.09.10
    Сообщения:
    5.740
    Симпатии:
    5.269
    Версия XF:
    1.5.11
    Я просто к тому, нужно ли разработчиком об этом сообщить, если это на самом деле баг.
     
  15. Pepelac

    Pepelac Продам луц в бутылках Команда форума

    Регистрация:
    28.09.10
    Сообщения:
    1.794
    Симпатии:
    1.349
    а там move_uploaded_file не прокатит, ибо же эти временные файлы генерятся самим скриптом в том же классе в методе applyAvatar
     
    FractalizeR нравится это.
  16. FractalizeR

    FractalizeR XenForo Addicted Команда форума

    Регистрация:
    27.09.10
    Сообщения:
    1.085
    Симпатии:
    823
    Версия XF:
    1.3.2
    Ну, это документированное поведение rename(). Но вот отсутствие @ заставляет скрипт выдавать ошибку. Надо предупредить, я думаю.
     
  17. KirillDE

    KirillDE Местный

    Регистрация:
    09.10.10
    Сообщения:
    17
    Симпатии:
    7
    гуглил по ошибке, не только у ксенфоры такая проблема, это повсеместно встречается.
     
    Romchik® нравится это.
  18. KirillDE

    KirillDE Местный

    Регистрация:
    09.10.10
    Сообщения:
    17
    Симпатии:
    7
    проблемы продолжаются)
    при каждом обновлении приходится изменять вышеназванную строчку

    думаю это как то связано с параметрами сервера, но не пойму с чем конкретно.

    может всё таки написать разработчикам? сам не зареган у низ, так как пока официально не клиент(
     
  19. Romchik®

    Romchik® The Power of Dreams Команда форума

    Регистрация:
    26.09.10
    Сообщения:
    5.740
    Симпатии:
    5.269
    Версия XF:
    1.5.11
    http://xenforo.com/community/threads/possible-bug-with-avatars.17763/
     
    KirillDE нравится это.
  20. Romchik®

    Romchik® The Power of Dreams Команда форума

    Регистрация:
    26.09.10
    Сообщения:
    5.740
    Симпатии:
    5.269
    Версия XF:
    1.5.11
    Ну Майк ответил, сменил статус на [Awaiting Feedback], но я как-то даже не знаю, чего ему еще написать :rolleyes:
     

Поделиться этой страницей