1. Приветствуем Вас на неофициальном форуме технической поддержки XenForo на русском языке. XenForo - новый и перспективный форумный движок от бывших создателей vBulletin.

1.1.2 Ошибка сервера, не работает форум

Тема в разделе "Основные вопросы по XenForo", создана пользователем Oleg, 19 апр 2012.

Загрузка
  1. Oleg

    Oleg Пользователь

    Регистрация:
    19.04.12
    Сообщения:
    8
    Симпатии:
    0
    Версия XF:
    1.1.2
    Доброе время суток господа. Решал перейти на данные форум с VB.
    По пользовался на локалке, все замечательно, все понравилось.
    Столкнулся с такой проблемой, что форум не хочет работать на хостинге.
    Подскажите пожалуйста, какие функция надо включить хостеру, что бы работал форум XF.

    Всё что мне удалось узнать о сервере:
    Настройки сервера
    Вебсервер
    Apache/2.2.3 (CentOS)
    PHP Версия 5.3.3
    MySQL Версия 5.0.77
    safe_mode Выключено
    register_globals Выключено
    magic_quotes_gpc Выключено
    display_errors off
    post_max_size 15M (15728640 bytes)
    upload_max_filesize 10M (10485760 bytes)
    max_execution_time 30

    PHP Модуль
    bcmath Да
    gmp Да
    GD
     
  2. carliker

    carliker Местный

    Регистрация:
    03.10.11
    Сообщения:
    274
    Симпатии:
    114
    Версия XF:
    1.1.1
  3. Oleg

    Oleg Пользователь

    Регистрация:
    19.04.12
    Сообщения:
    8
    Симпатии:
    0
    Версия XF:
    1.1.2
    Странно, но скрипт пишет: Your server meets all of XenForo's PHP requirements.
    думаю врать не будет)

    Скажите пожалуйста, какие настройки нужны для корректной работы форума?
    Всё что мне удалось узнать о сервере:
    Настройки сервера
    Вебсервер
    Apache/2.2.3 (CentOS)
    PHP Версия 5.3.3
    MySQL Версия 5.0.77
    safe_mode Выключено
    register_globals Выключено
    magic_quotes_gpc Выключено
    display_errors off
    post_max_size 15M (15728640 bytes)
    upload_max_filesize 10M (10485760 bytes)
    max_execution_time 30

    PHP Модуль
    bcmath Да
    gmp Да
    GD
     
  4. Romchik®

    Romchik® The Power of Dreams Команда форума

    Регистрация:
    26.09.10
    Сообщения:
    5.740
    Симпатии:
    5.269
    Версия XF:
    1.5.11
    А как вы его установили на хостинг? Залили базу с локалки или ставили по новой? Вообще скрипт установки тоже не запускается?
     
  5. Oleg

    Oleg Пользователь

    Регистрация:
    19.04.12
    Сообщения:
    8
    Симпатии:
    0
    Версия XF:
    1.1.2
    До этого дело не дошло. Форум вообще не работает, не запускает ни один файл, в том числи и файл установки.
     
  6. carliker

    carliker Местный

    Регистрация:
    03.10.11
    Сообщения:
    274
    Симпатии:
    114
    Версия XF:
    1.1.1
    А вы уверены что залили все в нужную папку на хостинге?
     
  7. Romchik®

    Romchik® The Power of Dreams Команда форума

    Регистрация:
    26.09.10
    Сообщения:
    5.740
    Симпатии:
    5.269
    Версия XF:
    1.5.11
    Значит нужно посмотреть логи сервера. Возможно там стоит более подробное описание ошибки.
     
  8. Oleg

    Oleg Пользователь

    Регистрация:
    19.04.12
    Сообщения:
    8
    Симпатии:
    0
    Версия XF:
    1.1.2
    Вы, конечно извините, но я не до такой степени глуповат. Куда бы я не заходил пишет:
    Думаете мне хостер даст логи сервера? Я в этом сомневаюсь...
    Ну а всё таки что требует для корректной работы форума? Почему может вылазить такая ошибка, ведь на локалке он работает на ура...
     
  9. carliker

    carliker Местный

    Регистрация:
    03.10.11
    Сообщения:
    274
    Симпатии:
    114
    Версия XF:
    1.1.1
    Вы меня, конечно, тоже извините, но всякое может быть. У каждого хостера свои причуды. Залейте на хотинг файл txt какой нить и попробуй его открыть через браузер. Вот и выяснится, туда залили или нет);)

    И еще, а какие права папок/файлов у вас стоят?
    И если не секрет, что за хостинг у вас?
     
    Romchik® нравится это.
  10. Oleg

    Oleg Пользователь

    Регистрация:
    19.04.12
    Сообщения:
    8
    Симпатии:
    0
    Версия XF:
    1.1.2
    Все нормально с работает, по мимо форума есть и еще сайты. Вот именно форум XF не работает... До этого стоял VB 4.0.2\4.1.2 - все хорошо.

    На папке форума 775, внутри нее 664.
    Я тоже кстати подумал о правах доступа, но пока не дошел до них.
     
  11. carliker

    carliker Местный

    Регистрация:
    03.10.11
    Сообщения:
    274
    Симпатии:
    114
    Версия XF:
    1.1.1
    Могу предположит что при заливки файлов через ФТП вылезла ошибка с нулевым размером каких либо файлов. Сам с таким сталкивался. Файл залит, а размер 0. Попробуйте перезалить, или лучше архив залить и распаковать
     
  12. Oleg

    Oleg Пользователь

    Регистрация:
    19.04.12
    Сообщения:
    8
    Симпатии:
    0
    Версия XF:
    1.1.2
    К сожалению с этим всё в порядке.
    --- добавлено : Apr 19, 2012 8:36 AM ---
    Такс, мне кажется вся проблема в правах доступа. Можете сказать, на какие файлы какие права надо установить?
     
  13. carliker

    carliker Местный

    Регистрация:
    03.10.11
    Сообщения:
    274
    Симпатии:
    114
    Версия XF:
    1.1.1
    Какой то мистический у вас хостинг :) Может быть случайно файл .htaccess залили левый какой-нибудь. Жаль что не смогли помочь. Пинайте хостера, просите у него логи ошибок, он их обязан предоставить (на нормальных хостингах они по дефолу доступны).
    Папки 755, файлы 644. Так 100% должно работать.

    А вообще у меня: js, library, styles - 700 стоят. Но мне кажется, что файловый менеджер хостера пургу какую то показывает)
     
  14. TAIFUN

    TAIFUN Человек

    Регистрация:
    27.09.10
    Сообщения:
    2.121
    Симпатии:
    1.560
    Версия XF:
    1.5.9
    Для папок
    data - 777
    internal_data - 777

    * - для их подпапок аналогичные атрибуты

    Для остальных папок - 755
    Для всех файлов - 644

    Проверьте атрибуты папки домена.
     
    Romchik® нравится это.
  15. Oleg

    Oleg Пользователь

    Регистрация:
    19.04.12
    Сообщения:
    8
    Симпатии:
    0
    Версия XF:
    1.1.2
    Спасибо за ответы, но к сожалению ни чего не помогает. Жду ответа хостинга.
     
  16. Oleg

    Oleg Пользователь

    Регистрация:
    19.04.12
    Сообщения:
    8
    Симпатии:
    0
    Версия XF:
    1.1.2
    Не дождался ответа от хостера.
    Может быть всё таки знает кто, какие модули\настройки нужны для корректной работы данного форума?
    С атрибутами тут все в порядке. Еще раз повторю, что до этого стоял VB 4.1.2 или 4.0.2 и всё работало на ура.
     
  17. TAIFUN

    TAIFUN Человек

    Регистрация:
    27.09.10
    Сообщения:
    2.121
    Симпатии:
    1.560
    Версия XF:
    1.5.9
    Вы читаете что Вам пишут или нет? Спутал с другой темой.
    http://www.xf-russia.ru/xenforo/faq.html#sys-reqs
     
  18. krlmisha

    krlmisha Активный пользователь

    Регистрация:
    20.11.11
    Сообщения:
    12
    Симпатии:
    1
    Версия XF:
    1.0.1
    Похожая тема: http://www.xf-russia.ru/forum/threads/Ошибка-сервера-не-работает-форум.3806/

    Абсолютно та же проблема, что и сверху. Переехал на другой хост, перенес форум, бд, поменял настройки под новую бд, настроил права, но ничего не работает :( Настроил права, как было сказано в одном из ответов в верхней теме, но не помогло. Обращался к хостеру, он писал, что все таки проблема в правах. Помогите плз.

    Сам проблемный форум: http://yourminemind.ru/forum/
     
  19. krlmisha

    krlmisha Активный пользователь

    Регистрация:
    20.11.11
    Сообщения:
    12
    Симпатии:
    1
    Версия XF:
    1.0.1
  20. krlmisha

    krlmisha Активный пользователь

    Регистрация:
    20.11.11
    Сообщения:
    12
    Симпатии:
    1
    Версия XF:
    1.0.1

Поделиться этой страницей