1. Приветствуем Вас на неофициальном форуме технической поддержки XenForo на русском языке. XenForo - новый и перспективный форумный движок от бывших создателей vBulletin.

Проблема при установке на хостинг

Тема в разделе "Для новичков", создана пользователем vadimon, 4 авг 2011.

Загрузка
  1. vadimon

    vadimon Местный

    Регистрация:
    30.07.11
    Сообщения:
    122
    Симпатии:
    11
    Версия XF:
    1.5.0
    Сразу оговорюсь, на локальном хостинге устанавливается и работает отлично, а вот при установке на хостинге возникли проблемы. Первый шаг установки выглядит так:
    [​IMG]
    У меня же при установке, вот такая неполная:
    [​IMG]
    Что я только не делал: и кеш чистил и браузеры менял и ftp-клиенты менял и с бубном танцевал и вручную вбивал ссылку, чтобы перейти на следующий шаг установки типа /install/index.php?install/step/1. Любой другой движок, форум и все что угодно ставится без проблем, а с XF возникла проблема. Кто может сказать, в чем дело?
     
  2. TAIFUN

    TAIFUN Человек

    Регистрация:
    27.09.10
    Сообщения:
    2.121
    Симпатии:
    1.560
    Версия XF:
    1.5.9
    Весело. Что за хостер?
     
  3. vadimon

    vadimon Местный

    Регистрация:
    30.07.11
    Сообщения:
    122
    Симпатии:
    11
    Версия XF:
    1.5.0
    Timeweb.ru. Озадачил их этим вопросом, сказали попробуют сами установить, я им честно сказал, что движок нуленый, ответили, что возможно в этом и причина. Говорю, на денвере полет нормальный, да и другие люди на хостах своих не жалуются. Видимо, обиделесь, поэтому взялись сами устанавливать ))
     
  4. TAIFUN

    TAIFUN Человек

    Регистрация:
    27.09.10
    Сообщения:
    2.121
    Симпатии:
    1.560
    Версия XF:
    1.5.9
    Сомневаюсь что проблема в дистибутиве.
     
  5. vadimon

    vadimon Местный

    Регистрация:
    30.07.11
    Сообщения:
    122
    Симпатии:
    11
    Версия XF:
    1.5.0
    Я думаю, если установлю версию ниже 1.0.4, ничего ведь не изменится?
     
  6. Yoskaldyr

    Yoskaldyr Пользователь

    Регистрация:
    27.09.10
    Сообщения:
    1.921
    Симпатии:
    1.160
    Версия XF:
    1.0.4
    ничего.
    В общем хостинг не удовлетворяет минимальным требованиям ксенфоро (или версия пхп и установленных модулей или версия мускуля)
     
  7. exarh

    exarh Местный

    Регистрация:
    05.11.10
    Сообщения:
    364
    Симпатии:
    78
    Версия XF:
    1.1.3
    У меня на этом же хостинге стоит форум. Установилось без проблем, квартируюсь у них уже месяца 2 все путево. Может быть у меня сервер другой, проверьте.
    Форум ниже.
     
  8. R.J.

    R.J. Местный

    Регистрация:
    04.10.10
    Сообщения:
    168
    Симпатии:
    59
    Поддерживаю, на Timeweb нормально крутится Ксен.
     
  9. infis

    infis Местный Команда форума

    Регистрация:
    27.06.11
    Сообщения:
    5.525
    Симпатии:
    3.322
    Версия XF:
    1.5.9
    Такое ощущение, что файлы некорректно распаковались, либо были скопированы с ошибкой - на полуслове обрываться не может фраза просто так.
     
  10. vadimon

    vadimon Местный

    Регистрация:
    30.07.11
    Сообщения:
    122
    Симпатии:
    11
    Версия XF:
    1.5.0
    Сказал им требования, ответили, что все параметры удовлетворяют их хостингу, да я и сам вижу, что удовлетворяет, но трабла есть.
    У меня такое же ощущение. Так как вижу некоторое несовпадение по размерам файлов в дистрибутиве и на сервере.
    Хостер ничего сделать не смог. Сказал, что причину такого поведения инсталяционных файлов, он объяснить не может.

    Вот, думаю, может сначала vBulletin поставить, а потом как-нибудь на XS перескочить
     
  11. spy

    spy ИнквизитоР

    Регистрация:
    04.03.11
    Сообщения:
    373
    Симпатии:
    188
    если двиг нулл, то мож другой дистр попробавать установить?! от кого нулл?
     
  12. vadimon

    vadimon Местный

    Регистрация:
    30.07.11
    Сообщения:
    122
    Симпатии:
    11
    Версия XF:
    1.5.0
    XenForo 1.0.4 Null FS. Хотя, думаю, проблема не в этом.
     
  13. vadimon

    vadimon Местный

    Регистрация:
    30.07.11
    Сообщения:
    122
    Симпатии:
    11
    Версия XF:
    1.5.0
    Установил XS на локальном сервере, затем перенес сам двиг и дамп базы на хост. В итоге вся верстка поползла в разные стороны, а в админке отоображается пустая страница. Есть идеи, что еще можно сделать? Опять у меня такое ощущение, что файлы "недозагруженными" получаются. Вот, сделал пока на тестовом: http://sos.webtm.ru/
     
  14. Wertrend

    Wertrend Активный пользователь

    Регистрация:
    11.04.11
    Сообщения:
    78
    Симпатии:
    11
    Версия XF:
    1.1.1
    В фтп-клиенте проверить и сравнить все папки с файлами не пробовали? Бывает глюк, что не все с 1 раза загружается или у хостера лимит на количество/размер файлов.

    Можно поробовать установить более старую версию форума, после обновить.
     
  15. vadimon

    vadimon Местный

    Регистрация:
    30.07.11
    Сообщения:
    122
    Симпатии:
    11
    Версия XF:
    1.5.0
    Да я и через ftp-клиент закачивал и через файловый менеджер в своем аккаунте на хосте и архив хостеру кидал, он сам его распаковывал и пытался установить. Все бесполезно. Все версии перепробовал, начиная с самой первой и разные нулы. Результат никакого, прям мистика какая-то, либо все просто и лежит на поверхности, но я этого не вижу. Интересно, что такое есть в денвере, что он на нем без проблем устанавливается и чего нет у хостера? ))
     
  16. Romchik®

    Romchik® The Power of Dreams Команда форума

    Регистрация:
    26.09.10
    Сообщения:
    5.740
    Симпатии:
    5.269
    Версия XF:
    1.5.11
    А скрипт проверки на совместимость сервера с XF хоть запускали?
     
  17. vadimon

    vadimon Местный

    Регистрация:
    30.07.11
    Сообщения:
    122
    Симпатии:
    11
    Версия XF:
    1.5.0
    Запускал. Требования удовлетворены.
    Я у них квартируюсь уже 2 года и вот первый раз он меня вот так вот "подвел".
     
    Romchik® нравится это.
  18. vadimon

    vadimon Местный

    Регистрация:
    30.07.11
    Сообщения:
    122
    Симпатии:
    11
    Версия XF:
    1.5.0
    Ура, товарищи! Проблема разрешилась переездом на другой сервер. Отдельное спасибо exarh за намек.
     
  19. Wertrend

    Wertrend Активный пользователь

    Регистрация:
    11.04.11
    Сообщения:
    78
    Симпатии:
    11
    Версия XF:
    1.1.1
    Поздравляю, а вы не поинтересовались об отличиях между серверами?
     
  20. vadimon

    vadimon Местный

    Регистрация:
    30.07.11
    Сообщения:
    122
    Симпатии:
    11
    Версия XF:
    1.5.0
    Сервера, я думаю, одинаковые. Видимо, что-то на бывшем сервере не заладилось, либо был перегружен. Мне как-то важнее был результат, чем причина его некорректной работы.
     

Поделиться этой страницей