1. Приветствуем Вас на неофициальном форуме технической поддержки XenForo на русском языке. XenForo - новый и перспективный форумный движок от бывших создателей vBulletin.

Проблема с отображением IP

Тема в разделе "Основные вопросы по XenForo", создана пользователем werewolf78, 24 июл 2011.

Загрузка
  1. werewolf78

    werewolf78 Местный

    Регистрация:
    19.05.11
    Сообщения:
    5
    Симпатии:
    0
    Версия XF:
    1.5.6
    В некоторых темах видно IP написавшего сообщение:
    withip.jpg
    А в некоторых нет этой ссылки:
    withoutip.jpg
    Причем в одной теме на первых двух страницах есть ссылка на IP, потом ее нет.
    Все перерыл уже, и права групп, и права доступа к узлам, и права админов.
    Кто подскажет, где собака порылась?
     
  2. Romchik®

    Romchik® The Power of Dreams Команда форума

    Регистрация:
    26.09.10
    Сообщения:
    5.740
    Симпатии:
    5.269
    Версия XF:
    1.5.11
    Какие плагины установлены?
     
  3. werewolf78

    werewolf78 Местный

    Регистрация:
    19.05.11
    Сообщения:
    5
    Симпатии:
    0
    Версия XF:
    1.5.6
    Custom BBCode Manager
    TaigaChat
    Xen.TR.com Who Has Visited

    Отключал их и даже удалял, эффекта никакого.
     
  4. Romchik®

    Romchik® The Power of Dreams Команда форума

    Регистрация:
    26.09.10
    Сообщения:
    5.740
    Симпатии:
    5.269
    Версия XF:
    1.5.11
    Пробовали вернуть все измененные шаблоны? Ну или проще создать новый стиль и проверить в нем, где ни один шаблон не изменен.
     
  5. werewolf78

    werewolf78 Местный

    Регистрация:
    19.05.11
    Сообщения:
    5
    Симпатии:
    0
    Версия XF:
    1.5.6
    Создал новый стиль, никаких изменений:(
     
  6. Romchik®

    Romchik® The Power of Dreams Команда форума

    Регистрация:
    26.09.10
    Сообщения:
    5.740
    Симпатии:
    5.269
    Версия XF:
    1.5.11
    Если есть лицензия, можете обратиться в техподдержку, создав тикет.
    Иначе пока не знаю, что еще можно посоветовать.
     
    werewolf78 нравится это.
  7. werewolf78

    werewolf78 Местный

    Регистрация:
    19.05.11
    Сообщения:
    5
    Симпатии:
    0
    Версия XF:
    1.5.6
    Хостер включил поддержку Ipv6, теперь $_SERVER['REMOTE_ADDR'] выглядит как ::ffff:xxx.xxx.xxx.xxx
    Видимо из-за этого не отображается ссылка IP (форум поставил с нуля). Мне сказали что это исправляется с помощью хуков, но я не знаю как. Подскажите, уважаемые гуру, если возможно.
     

Поделиться этой страницей