1. Приветствуем Вас на неофициальном форуме технической поддержки XenForo на русском языке. XenForo - новый и перспективный форумный движок от бывших создателей vBulletin.

1.1.3 Проблема с регистрацией, "Запрашиваемая страница не найдена"

Тема в разделе "Основные вопросы по XenForo", создана пользователем naardox, 11 фев 2013.

Загрузка
  1. naardox

    naardox Новичок

    Регистрация:
    11.02.13
    Сообщения:
    3
    Симпатии:
    1
    Версия XF:
    1.1.3
    Здравствуйте.
    Недавно начал работать с xenForo, столкнулся со странной проблемой.
    Использую форум 1.1.3, по адресу типа domen.ru расположена страница XenPorta, сам же форум сидит в domen.ru/forum. При регистрации пользователь обязан подтвердить емейл переходом по ссылке. На почту приходит ссылка формата http://domen.ru/forum/account-confirmation/3/email?c=371eafcc288dbf4e, но при переходе по ней выскакивает ошибка "Запрашиваемая страница не найдена". Гугл и поиск по этому форуму ничего не подсказали, однако выяснилось, что если убрать из полученной по почте ссылки сегмент forum/, и перейти просто по http://domen.ru/account-confirmation/3/email?c=371eafcc288dbf4e регистрация проходит успешно.
    Конечно, можно написать об этой особенности в правилах форума (которые все, разумеется обязаны прочесть), но боюсь процесс неестественного отбора окажется слишком результативным.
    Подскажите пожалуйста, как это можно исправить. Всю голову поломал.

    И да, письма с форума приходят якобы с моего рабочего емейла, что указан в настройках "Основная информация о форуме". Не хочу чтобы он так часто светился, но при этом письма "обратной связи" должны приходить именно туда. Есть возможность сделать для двух этих функций разные адреса?

    Заранее спасибо.
    --- добавлено : 11 фев 2013 в 21:57 ---
    Решение второго вопроса закономерно обнаружилось в настройках электронной почты, с первым пока все тщетно.
     
  2. naardox

    naardox Новичок

    Регистрация:
    11.02.13
    Сообщения:
    3
    Симпатии:
    1
    Версия XF:
    1.1.3
    Решено.
    В разделе "Основная информация о форуме" url форума был указан как http://domen.ru/forum/, после исправления на http://domen.ru/ все заработало. Навигация на удивление не развалилась. Спасибо.
     
    Dimon ua нравится это.

Поделиться этой страницей