1. Приветствуем Вас на неофициальном форуме технической поддержки XenForo на русском языке. XenForo - новый и перспективный форумный движок от бывших создателей vBulletin.
Загрузка

1.4.x TaigaChat - AJAX Shoutbox [RU] 0.5.5

Бесплатный чат для XenForo

  1. vkams

    vkams Местный

    Регистрация:
    08.07.11
    Сообщения:
    129
    Симпатии:
    26
    Э
    Согласно инструкции, добавить <xen:include template="dark_taigachat"><xen:set var="$taigachat_alt">1</xen:set></xen:include>
    до этой строки:
    <xen:if is="{$re
    nderedNodes}"><xen:include template="node_list" /></xen:if>

    ----------

    А у меня в оконном режиме местами кракозябры :( Форум свежеустановленный, чат ставил тоже только первый раз, всё по инструкции. taiga.jpg
    Нехорошие места подчеркнул. В полноразмерном режиме проблем нет.

    В обоих случаях браузер должен выбирать кодировку автоматически, но в оконном режиме переходит в кириллицу (windows-1251). В Опере то же самое. Код страниц выглядит так:
    Полноразмерный:
    HTML:
    <html id="XenForo" lang="ru-RU" class="Public LoggedIn Sidebar" xmlns:fb="http://www.facebook.com/2008/fbml">
      <head>
    
      <meta charset="utf-8" />
    
    Оконный:
    HTML:
    <html id="XenForo" class="Public LoggedIn">
    <head>
        <meta charset="utf-8" />
     
  2. Romchik®

    Romchik® The Power of Dreams Команда форума

    Регистрация:
    26.09.10
    Сообщения:
    5.740
    Симпатии:
    5.269
    Версия XF:
    1.5.11
    Только в оконном режиме такое?
    А как насчет FF и IE, там нормально?
     
  3. infis

    infis Местный Команда форума

    Регистрация:
    27.06.11
    Сообщения:
    5.525
    Симпатии:
    3.321
    Версия XF:
    1.5.9
    Наверное, сайт по дефолту отдает кодировку windows-1251, а не utf-8. Если в страницах не прописана кодировка, то сайт будет отдавать в дефолтной. Для того, чтобы в любом случае сайт отдавал utf-8 можно попробовать принудительно установить кодировку для всех страниц, прописав в .htaccess следующую строку:
    Код:
    AddDefaultCharset UTF-8
     
  4. vkams

    vkams Местный

    Регистрация:
    08.07.11
    Сообщения:
    129
    Симпатии:
    26
    Дописал - с тем же результатом (кракозябрами).
    В этих то же самое.
    Только в оконном

    Всплывающая подсказка тоже пострадала: smile.jpg
     
  5. infis

    infis Местный Команда форума

    Регистрация:
    27.06.11
    Сообщения:
    5.525
    Симпатии:
    3.321
    Версия XF:
    1.5.9
    А сам .htaccess вообще работает или просто присутствует?
     
  6. vkams

    vkams Местный

    Регистрация:
    08.07.11
    Сообщения:
    129
    Симпатии:
    26
    .htaccess работает - я попробовал дописать в него redirect. Вот пример смешения кодировок:
    крако.jpg
    Слово на последней кнопке - "Отмена". В полноэкранном режиме нормально. Я думаю, что где-то не хватает указания на правильную кодировку в JS-кодах, которые формируют и обрабатывают оконный чат.
     
  7. Romchik®

    Romchik® The Power of Dreams Команда форума

    Регистрация:
    26.09.10
    Сообщения:
    5.740
    Симпатии:
    5.269
    Версия XF:
    1.5.11
    То есть по-вашему вы первый, кто этот чат установил на русском? Я к тому, что никто не жаловался пока. Посмотрите в базе кодировки, может там разнобой?
     
  8. GeN4uk

    GeN4uk Активный пользователь

    Регистрация:
    16.10.11
    Сообщения:
    10
    Симпатии:
    0
    Кстате говоря может кто подправить бб коды, при обведении текста и вставки бб кода он ставится в самом начале строки, что не очень удобно + цвета нету, пишется только color остальное приходится руками вписывать :confused:
     
  9. Алексей Раков

    Алексей Раков Местный

    Регистрация:
    04.08.11
    Сообщения:
    39
    Симпатии:
    7
    Версия XF:
    1.2.1
    Работает прекрасно, но смайлов нет. Ну тоесть адресс смайла показывается что в корне должны лежать смайлы под номерами от 1 до 12, но в архиве их нет. В чем проблема? как исправить? Возможно это из-за того что я вставил чат просто в шаблон сайдбар..пока не понятно.
     
  10. SeM13

    SeM13 Создатель системы

    Регистрация:
    05.01.11
    Сообщения:
    747
    Симпатии:
    252
    Версия XF:
    1.1.3
    Чат использует смайлы которые загружены в самом форуме, тоесть например по умолчанию- ":):confused::p"
     
  11. Алексей Раков

    Алексей Раков Местный

    Регистрация:
    04.08.11
    Сообщения:
    39
    Симпатии:
    7
    Версия XF:
    1.2.1
    Это я понял, у меня ссылка на смайлы ведет в корень, где эту ссылку ожно поправить? Для начала попробую переустновить.
     
  12. vkams

    vkams Местный

    Регистрация:
    08.07.11
    Сообщения:
    129
    Симпатии:
    26
    А может, не пробовали просто? Фразы-то одни и те же как в оконном, так и полноэкранном режиме. У кого чат установлен, гляньте, пожалуйста.
     
  13. SeM13

    SeM13 Создатель системы

    Регистрация:
    05.01.11
    Сообщения:
    747
    Симпатии:
    252
    Версия XF:
    1.1.3
    Все там нормально. И еще спорить умудряетесь.
     
  14. infis

    infis Местный Команда форума

    Регистрация:
    27.06.11
    Сообщения:
    5.525
    Симпатии:
    3.321
    Версия XF:
    1.5.9
    Глупый вопрос: а во всех браузерах проблема с кодировкой?
     
  15. vkams

    vkams Местный

    Регистрация:
    08.07.11
    Сообщения:
    129
    Симпатии:
    26
    Не глупый. Во всех. Мне странна избирательность кракозябров: например, если дата указывается абсолютно (17 окт...), то она выглядит одинаково правильно в обоих вариантах чата, а вот "вчера" или "только что" - в неправильной кодировке. Сами сообщения в обоих случаях отображаются правильно. Кодировки браузеры выставляют автоматически, но в оконном режиме перепрыгивают именно в windows-1251. В результате в коде страницы появляются строки:
    Код:
    jQuery.extend(XenForo.phrases,
    {
    cancel: "Отмена",
    
    a_moment_ago:    "только что",
    one_minute_ago:  "минуту назад",
    x_minutes_ago:  "%minutes% мин. назад",
    today_at_x:      "Сегодня, в %time%",
    
    Может быть, сервер отдаёт какой-то файл не в той кодировке, но что это за файл?
     
  16. infis

    infis Местный Команда форума

    Регистрация:
    27.06.11
    Сообщения:
    5.525
    Симпатии:
    3.321
    Версия XF:
    1.5.9
    Может выставить в настройке апача выдавать по дефолту в кодировке UTF-8 и это решит проблему?
     
  17. vkams

    vkams Местный

    Регистрация:
    08.07.11
    Сообщения:
    129
    Симпатии:
    26
    В .htaccess есть строка: AddDefaultCharset UTF-8
     
  18. infis

    infis Местный Команда форума

    Регистрация:
    27.06.11
    Сообщения:
    5.525
    Симпатии:
    3.321
    Версия XF:
    1.5.9
    Тогда с какого перепугу браузер пытается работать с кодировкой 1251?
     
  19. vkams

    vkams Местный

    Регистрация:
    08.07.11
    Сообщения:
    129
    Симпатии:
    26
    Infis и другие неравнодушные, спасибо! Полез в настройку к провайдеру, обнаружилось, что там кодировка сайта была 1251, исправил, теперь всё хорошо!:thumbsup:
     
  20. Justin Edwards

    Justin Edwards Пользователь

    Регистрация:
    22.10.11
    Сообщения:
    1
    Симпатии:
    1
    I dont know if this was posted yet, but heres the xml if you want the block to work with xenporta 1.5 (just take out the txt, its an xml file)
     

    Вложения:

    KakBeOlolo нравится это.

Поделиться этой страницей