1. Приветствуем Вас на неофициальном форуме технической поддержки XenForo на русском языке. XenForo - новый и перспективный форумный движок от бывших создателей vBulletin.

Установка XenForo на localhost

Тема в разделе "Для новичков", создана пользователем Sadorimatsu, 25 ноя 2010.

Загрузка
  1. Sadorimatsu

    Sadorimatsu Местный

    Регистрация:
    29.09.10
    Сообщения:
    145
    Симпатии:
    10
    Версия XF:
    1.1.3
    Большинство думаю столкнулась с такой проблемой, что форум ни в какую не ставится ни на один сервер под Windows. С чем связано пока никто не может сказать, даже знаменитый Kerk борется с этой проблемой, может решил своим способом не ясно, но для простой установки рекомендую сделать следующее:

    1. Скачать Denver новый PHP 5.3;
    2. Установить на него XenForo beta 2;
    3. Установка пройдёт стабильно и потом можете спокойно обновлять его на beta 3 и выше.
    Странно одно, что установка на денвер идёт только бета 2, другие на глухо не ставятся.
    Если есть решения установки на других серверах, то выкладывайте.
    Это проверялось на лицензии. Не нулл.
     
  2. FractalizeR

    FractalizeR XenForo Addicted Команда форума

    Регистрация:
    27.09.10
    Сообщения:
    1.085
    Симпатии:
    823
    Версия XF:
    1.3.2
    Гм... Beta 1/2 нули не ставились потому, что тот, кто нуллил зачем-то применил описанный на нашем форуме патч для установки языка. А его нужно было применять после установки. Как результат - сбой при импорте фраз. Я у себя на 5.3 поставил без проблем. Под Денвер, только пакет 5.3 скачивал оригинальный с php.net. Просто заменил как есть папку, где был 5.2 на 5.3. Запустил и все ок.

    Если у вас сбои - логи и сообщения в студию, пожалуйста. Телепаты в отпуске :)
     
    Romchik® и TAIFUN нравится это.
  3. g0rn

    g0rn Местный

    Регистрация:
    03.10.10
    Сообщения:
    107
    Симпатии:
    146
    У меня всё всегда ставилось на xampp и zend server.
     
  4. CyberAP

    CyberAP Местный

    Регистрация:
    05.10.10
    Сообщения:
    2.577
    Симпатии:
    1.614
    Версия XF:
    1.5.10
    • Ставим xampp
    • Ставим xenforo beta 3
    Ни единого глюка.
     
  5. shpunsetoy

    shpunsetoy Оболтус

    Регистрация:
    11.10.10
    Сообщения:
    57
    Симпатии:
    110
    xampp
    xenforo beta 3
    глюков навстречал
     
  6. FractalizeR

    FractalizeR XenForo Addicted Команда форума

    Регистрация:
    27.09.10
    Сообщения:
    1.085
    Симпатии:
    823
    Версия XF:
    1.3.2
    Навстречал или не встречал? :)
     
    CyberAP, Yoskaldyr и Romchik® нравится это.
  7. Sadorimatsu

    Sadorimatsu Местный

    Регистрация:
    29.09.10
    Сообщения:
    145
    Симпатии:
    10
    Версия XF:
    1.1.3
    Да дело в том, что я не использовал нули в обще, у меня лицензия)) Потому подобная проблема у меня на локалке и произошла. На другие сервера в обще установить не мог и только такой вариант для себя нашёл.
     
  8. Romchik®

    Romchik® The Power of Dreams Команда форума

    Регистрация:
    26.09.10
    Сообщения:
    5.740
    Симпатии:
    5.269
    Версия XF:
    1.5.11
    Подтверждаю - лицензия у него :)

    А может это были глюки родные у первой или второй беты? Пробовал уже 3-ю ставить на локалке? Если нет, советую потестить и рассказать.
     
  9. shpunsetoy

    shpunsetoy Оболтус

    Регистрация:
    11.10.10
    Сообщения:
    57
    Симпатии:
    110
    невыспалсо)))
     
  10. AleX

    AleX SPQR

    Регистрация:
    28.09.10
    Сообщения:
    411
    Симпатии:
    408
    Ставил на XAMPP с PHP 5.3 и явных проблем не было — всё прошло гладко, за исключением Beta 1. :)
     
  11. cocedreka

    cocedreka Активный пользователь

    Регистрация:
    08.12.10
    Сообщения:
    3
    Симпатии:
    0
    Устанавливайте нормальный сервер под Windows. И все пойдет:
    Код:
    http://nimpbox.ru
     
  12. AleX

    AleX SPQR

    Регистрация:
    28.09.10
    Сообщения:
    411
    Симпатии:
    408
    Плагиат на XAMPP. :)
     
  13. russia

    russia Местный

    Регистрация:
    18.01.11
    Сообщения:
    49
    Симпатии:
    12
    у меня тоже XAMPP даже RC1 ставил все ок
     
  14. Sadorimatsu

    Sadorimatsu Местный

    Регистрация:
    29.09.10
    Сообщения:
    145
    Симпатии:
    10
    Версия XF:
    1.1.3
    Забавно, пробовал на Denwer поставить лицензию RC3, тупо не проходило установка из-за отсутсвия прав chmod. Стоило поставить для прикола нулл RC2 пошло как ни в чём не бывало и затем обновил версию с лицензии. Вот думаю, что за прикол?))
     
  15. FractalizeR

    FractalizeR XenForo Addicted Команда форума

    Регистрация:
    27.09.10
    Сообщения:
    1.085
    Симпатии:
    823
    Версия XF:
    1.3.2
    Какие ж там на Windows chmod права? :) Или у вас Денвер в защищенном каталоге установлен?
     
  16. Sadorimatsu

    Sadorimatsu Местный

    Регистрация:
    29.09.10
    Сообщения:
    145
    Симпатии:
    10
    Версия XF:
    1.1.3
    Да не в этом дело. Самое смешное, что лицензия форума не пашет, как и на vertrigo, так и на XAMPP, какую версию не пробовал)) А вот нулл версия пашет на любом без проблем)) Как думаете, что за прикол такой?))
     
  17. FractalizeR

    FractalizeR XenForo Addicted Команда форума

    Регистрация:
    27.09.10
    Сообщения:
    1.085
    Симпатии:
    823
    Версия XF:
    1.3.2
    Наверное, надо логи PHP посмотреть. Какое-то расширение отсутствует, вероятно. Вообще Денвер - порядком глючен. Хоть и удобен...
     
  18. Sadorimatsu

    Sadorimatsu Местный

    Регистрация:
    29.09.10
    Сообщения:
    145
    Симпатии:
    10
    Версия XF:
    1.1.3
    Да что вы за денвер прицепились?)) Я и на другие тестировал и указал это даже, что та же ошибка и на других.
     
  19. FractalizeR

    FractalizeR XenForo Addicted Команда форума

    Регистрация:
    27.09.10
    Сообщения:
    1.085
    Симпатии:
    823
    Версия XF:
    1.3.2
    "Та же" - это какая? " тупо не проходило установка из-за отсутсвия прав chmod" - не совсем похоже на описание ошибки :) Можете кинуть ссылку на пост Кира, где он признается в своем бессилии решить эту проблему?
     
  20. Sadorimatsu

    Sadorimatsu Местный

    Регистрация:
    29.09.10
    Сообщения:
    145
    Симпатии:
    10
    Версия XF:
    1.1.3
    Да фиг его знает))) Ошибка именно из-за прав chmod. Какой сервер под винду не ставил ни в какую лицензия форума не ставится, а вот взял любой нулл, ставится как ни в чём не бывало. Вот и не пойму, какая там разница?? Что же такого там делают, что работает нуллы нормально, а лицензии фиг. Вот и гадаю. Так то проблем не вижу т.к. обошёл её таким вот вариантом))
     

Поделиться этой страницей