1. Приветствуем Вас на неофициальном форуме технической поддержки XenForo на русском языке. XenForo - новый и перспективный форумный движок от бывших создателей vBulletin.

WordPress 3 Bridge [RU]

Тема в разделе "Плагины для XenForo", создана пользователем TAIFUN, 29 окт 2010.

Загрузка
  1. Slam

    Slam Активный пользователь

    Регистрация:
    28.01.11
    Сообщения:
    79
    Симпатии:
    13
    Версия XF:
    1.1.3
    И такое бывает xD
     
  2. Karlitos

    Karlitos Активный пользователь

    Регистрация:
    10.01.11
    Сообщения:
    45
    Симпатии:
    4
    Версия XF:
    1.1.1
    У меня косяк с русскими никами в wordpress, не могут зайти в панель администрирования. Никто не знает как исправить?
     
  3. TAIFUN

    TAIFUN Человек

    Регистрация:
    27.09.10
    Сообщения:
    2.120
    Симпатии:
    1.558
    Версия XF:
    1.5.9
    Если проблема не касается плагина, которому посвящена тема, то создайте отдельную тему по своему вопросу в разделе OFF-topic и опишите проблему детальнее + укажите какая кодировка у таблиц.
     
  4. Karlitos

    Karlitos Активный пользователь

    Регистрация:
    10.01.11
    Сообщения:
    45
    Симпатии:
    4
    Версия XF:
    1.1.1
    Так ведь дело плагина касается, установил мост. Пользователи с форума у которых ники на кириллице не могут создавать записи в wordpress.
     
  5. TAIFUN

    TAIFUN Человек

    Регистрация:
    27.09.10
    Сообщения:
    2.120
    Симпатии:
    1.558
    Версия XF:
    1.5.9
    В какой кодировке таблицы базы форума и WP?
     
  6. Karlitos

    Karlitos Активный пользователь

    Регистрация:
    10.01.11
    Сообщения:
    45
    Симпатии:
    4
    Версия XF:
    1.1.1
    UTF8
     
  7. CyberAP

    CyberAP Местный

    Регистрация:
    05.10.10
    Сообщения:
    2.558
    Симпатии:
    1.590
    Версия XF:
    1.5.9
    Karlitos и TAIFUN нравится это.
  8. Karlitos

    Karlitos Активный пользователь

    Регистрация:
    10.01.11
    Сообщения:
    45
    Симпатии:
    4
    Версия XF:
    1.1.1
    Еще заметил косяк, ошибка при попытке посмотреть кто сейчас на форуме. Парни у кого мост установлен есть такой момент?
     
  9. CyberAP

    CyberAP Местный

    Регистрация:
    05.10.10
    Сообщения:
    2.558
    Симпатии:
    1.590
    Версия XF:
    1.5.9
    Плагин установлен, таких косяков не замечено.
    А что за ошибка?
     
  10. Karlitos

    Karlitos Активный пользователь

    Регистрация:
    10.01.11
    Сообщения:
    45
    Симпатии:
    4
    Версия XF:
    1.1.1
    Извиняюсь, это были кратковременные неполадки, сейчас сумел зайти.
     
  11. Slam

    Slam Активный пользователь

    Регистрация:
    28.01.11
    Сообщения:
    79
    Симпатии:
    13
    Версия XF:
    1.1.3
    Заметил глюк с постоянными ссылками при связке wp-bridge и buddypres.
    После активации плагина, при переходе на ссылку domain.com/blogs (список блогов в WP MU организации, которое выводится с помощью Buddypress), меня редиректит на domain.com/category/blogs, которая соответственно не существует.
    Написал автору через личную переписку, но пока молчок (
     
  12. Sidle Jinks

    Sidle Jinks Местный

    Регистрация:
    26.01.11
    Сообщения:
    44
    Симпатии:
    13
    Версия XF:
    1.1.1
    Совершенно аналогичная проблема. Дважды делал все заного, как сказано в этой теме. WordPress 3.1
    Указываю полный путь /home/xxxxx/domains/xxxxx.ru/public_html/forum/
    Пишет зелененьким "Соответствует".
    Регистрацию в WP включаю.
    После этого, если разлогиниваюсь в WP, то при попытке залогиниться перенаправляет на форум и финиш. Обратно не залогиниться, в админку WP не зайти. Приходится удалять БД WP.
    Если же указывать относительный путь ../forum/ - "Соответствует" тоже загорается, но эффекта никакого - на форум не перенаправляет для логина, с форума на WP не логинит.
     
  13. Slam

    Slam Активный пользователь

    Регистрация:
    28.01.11
    Сообщения:
    79
    Симпатии:
    13
    Версия XF:
    1.1.3
    А GlobalSalt каким образом указан?

    У меня в форуме config.php:
    $config['globalSalt'] = 'blablablarandomrandomrandom130-986365kldfjgldjgldfjg';

    в wordpress wp-config.php:
    define( 'AUTH_SALT', 'blablablarandomrandomrandom130-986365kldfjgldjgldfjg' );

    Эти ключи, вообще, можно сгенирировать по этому адресу https://api.wordpress.org/secret-key/1.1/
    Этот же blablablarandomrandomrandom130-986365kldfjgldjgldfjg, который вам придумает, и в админке вставляется.

    При наличие всего этого - авторизация будет проходить нормально.
     
  14. Sidle Jinks

    Sidle Jinks Местный

    Регистрация:
    26.01.11
    Сообщения:
    44
    Симпатии:
    13
    Версия XF:
    1.1.1
    Не помогает :(
    Ключи брал с https://api.wordpress.org/secret-key/1.1/salt/
    Допустим, мне генерирует:
    Код:
    define('AUTH_KEY',         '&a_/+r)2wzz|3$c*dtqa{Z>q+Pee-3n{;G?]J.{U)qSuw!6 Hpqp,o&+vh-5!RP1');
    define('SECURE_AUTH_KEY',  '`e-[P71&3Ok5cnA&618o[c(TW>C2%|+/TnTKkM 0Fpk5|(]m*OHVD};B,k,AQ%)e');
    define('LOGGED_IN_KEY',    'z!+&4v+-~8~]4 |xM;^|<Zq{2 ivQg&_+L7y+Fe|[pS[sS{:%v1kIP[S4@[q!wK1');
    define('NONCE_KEY',        'WpLFnS+ lo.M6%w=1_jK nPo2Jn15Gw6$!3vUT*_nQY#{_Ssi45PS8lffVocB7^U');
    define('AUTH_SALT',        '[.6+4c=MU-[)`i_M)][:NZ)M$V?RA@+<KM|z{{S5xH+-Um.20L&0j}6[*YC/ qE.');
    define('SECURE_AUTH_SALT', '^=|{kfZv7@V%@i/iPZh>2?55I38w0pa]yG|{[HdlZdEGdw.K@t#fUo:C:DQ+6|CZ');
    define('LOGGED_IN_SALT',   '7x>{TRZU-/Y]W,?T&m+?6 WhYt|ejSXptO`ah~#$C!9>{asB=6lPZ1%+wy6:AC))');
    define('NONCE_SALT',       'e)=<+NWy|R1@0r/V&sKBHtaA4}jrQiR$ Pa533VWxU@#8=Bg}9zU:DqTlU-08Lf2');
    
    Вставляю это все в wp_config.php
    В config.php форума: $config['globalSalt'] = '[.6+4c=MU-[)`i_M)][:NZ)M$V?RA@+<KM|z{{S5xH+-Um.20L&0j}6[*YC/ qE.';
    Нужно ли еще прописывать это в Application.php в /library/XenForo в строчку 'globalSalt' => '',?
    Впрочем, даже если вписать туда [.6+4c=MU-[)`i_M)][:NZ)M$V?RA@+<KM|z{{S5xH+-Um.20L&0j}6[*YC/ qE. - ничего не меняется.
    Проблема остается той же - после введения полного пути форума, разлогинивания из админки WP и при нажатии на главной странице WP "Войти", перенаправляет на форум, даже если там залогинен, и в WP больше не логинится, в админку не зайти (перенаправляет на главную страницу).
     
  15. Slam

    Slam Активный пользователь

    Регистрация:
    28.01.11
    Сообщения:
    79
    Симпатии:
    13
    Версия XF:
    1.1.3
    В Application.php я ничего не прописывал.

    После того, как вы все прописали и активировали плагин, вся работа по авторизации/регистрации переходит под управление XenForo.

    Важно, почтовый адрес и логин администратора Wordpress и Xenforo - должны совпадать. Пароль рабочий тот, который задан в XenForo.
     
  16. Sidle Jinks

    Sidle Jinks Местный

    Регистрация:
    26.01.11
    Сообщения:
    44
    Симпатии:
    13
    Версия XF:
    1.1.1
    Все заработало. Проблема была в том, что если в config.php форума указываешь строчку $config['globalSalt'] = '', то в админке WP строчку XenForo globalSalt нужно оставить пустой.
    Спасибо за помощь.
     
  17. Slam

    Slam Активный пользователь

    Регистрация:
    28.01.11
    Сообщения:
    79
    Симпатии:
    13
    Версия XF:
    1.1.3
    Странно, в админке она у меня тоже указана и все гуд работает, но всякое ведь бывает =)
     
  18. Madmess

    Madmess Местный

    Регистрация:
    24.12.10
    Сообщения:
    16
    Симпатии:
    4
    Версия XF:
    1.1.0 Final
    Почему-то работает только с установленной галочкой "Запомнить меня"
    Без нее ни на форум, ни в WP не входит
     
  19. undll

    undll Местный

    Регистрация:
    22.03.11
    Сообщения:
    91
    Симпатии:
    35
    Версия XF:
    1.1.5
    поставил мост на WP 3.1.2 и XF 1.0.1 - вроде работает. Но хотелось бы сделат так чтобы аккаунты были с форума, т.е. комменты в WP линковались на форумные профили.
     
  20. Daniel Wong

    Daniel Wong Активный пользователь

    Регистрация:
    25.06.11
    Сообщения:
    1
    Симпатии:
    0
    Ставил и на одну БД и на разные БД, все делал по инструкции, путь указывал абсолютный, интерграция не работает
    Правда все это на денвере пытался делать
    HELP with IT!
    Кстати в параметрах плагина только два поля (а не как на скрине)


    XenForo - путь
    XenForo globalSalt
     

Поделиться этой страницей