1. Приветствуем Вас на неофициальном форуме технической поддержки XenForo на русском языке. XenForo - новый и перспективный форумный движок от бывших создателей vBulletin.

1.1.3 Закрывающие теги включаются автоматом в ссылку

Тема в разделе "Баги XenForo", создана пользователем veron, 30 янв 2013.

Загрузка
  1. veron

    veron Местный

    Регистрация:
    23.12.12
    Сообщения:
    31
    Симпатии:
    2
    Версия XF:
    1.4.8
    Очень не приятный момент при заключении любым тегом ссылку, а именно, прилипание закрывающего тега к ссылке.
    Получается примерно так: хттп://abrakadabra,ру/faila,net[/spoiler] или [/hide]
    Приходится либо ставить пробел каждый раз перед закрывающем тегом, либо потом идти в редактор и править :(
    Если вставить ссылку в сам текст, то все нормально.
    Может кто решил этот момент? А то не знаю где шерстить и как конкрентно поправить :oops:
     
  2. infis

    infis Местный Команда форума

    Регистрация:
    27.06.11
    Сообщения:
    5.525
    Симпатии:
    3.322
    Версия XF:
    1.5.9
    А штатные теги тоже "прилипают"? Или это касается только дополнительных?
    Как пример: тут должна быть ссылка жирным. Еще один вариант: тут должна быть ссылка жирным.
    Вроде ничего не "прилипает". Если в штатных тегах это не наблюдается, значит, проблема не в XenForo (то бишь, это не его баг), а в тегах, которые аддонами были добавлены. Соответственно, вопросы по таким тегам нужно задавать в их темах.
    Ну и еще, навскидку. А не виноват ли плагин HIDE в таком поведении? Попробуйте его отключить или удалить. Если после отключения данного плагина все будет работать корректно, то либо покупайте платный HIDE, либо правьте его до рабочего состояния.
     
  3. veron

    veron Местный

    Регистрация:
    23.12.12
    Сообщения:
    31
    Симпатии:
    2
    Версия XF:
    1.4.8
    Со штатными все в порядке.
    Прилипает вот такой момент:
    http://abrakadabra.ru/faila.net[/spoiler]
    [hide]http://abrakadabra.ru/faila.ne[/hide]
    [opachki]http://abrakadabra.ru/faila.ne[/opachki]
    То есть любой BB код не из коробки. Я так понял что это как раз дело в самом редакторе т.к он не видит конца ссылки, или нет?
    Hide отключал - не из-за этого.
     
  4. infis

    infis Местный Команда форума

    Регистрация:
    27.06.11
    Сообщения:
    5.525
    Симпатии:
    3.322
    Версия XF:
    1.5.9
    Странно все это. Но явно это не ксен виноват.
     

Поделиться этой страницей