Новости

XenForo 1.5.4 (Security fix)

14.12.2015 | Romchik®

И очередное обновление-патч для XenForo, закрывающее XSS-уязвимость. Патч закрывает XSS-уязвимость, которую может вызвать особо сгенерированная ссылка в профиле пользователя. В этом случае могут быть украдены данные пользователя, в том числе куки, или же выполнены некоторые действия (в том числе административные) без ведома пользователя. Всем обязательно рекомендуется обновиться.

Также вышли версии с исправлением уязвимости для старых веток 1.3.10 и 1.4.12. Скачать патчи можно по ссылкам в темах на форуме.


Обсудить статью на форуме можно здесь.

XenForo 1.5.3

01.12.2015 | Romchik®

Сегодня XenForo обновился до версии 1.5.3. Версия минорная, а значит фокус как всегда на исправлении ошибок и улучшении стабильности.

Разработчикам плагинов: обратите внимание, что в версии 1.5.3 появились изменения, связанные с совместимостью сериализации. Почитатйте эту тему для более подробной информации.

Список некоторых изменений в XenForo 1.5.3:

  • Добавлена возможность (пока как бета-версия) импорта данных для IPB 4.0/4.1 и phpBB 3.1.
  • Предотвращение фатальной ошибки, если импорт был незавершен, а импортер был удален.
  • Исправлена ошибка в журнале изменений пользователя, когда пользователь изменил значение дополнительного поля, которое больше не существует.
  • Исправлено преобразования ссылки у названий страниц, когда тег заголовка занимает более 20 КБ на страницу (например, на страницах Amazon).
  • Аватары не применяются автоматически, если у пользователя нет на это прав.

И другие...

Пожалуйста, обратите внимание, что разработчики уже давно рекомендуют обновить всем PHP до версии 5.4 или новее. В XenForo 2.0 будет требоваться как минимум PHP 5.4. Если вы работаете с PHP 5.3 или ниже, то при установке или обновлении XenForo вы получите предупреждение об устаревающей версии PHP.


Обсудить статью на форуме можно здесь.


Также сегодня обновились официальные плагины галереи и менеджера ресурсов:
Enhanced Search 1.1.3
Resource Manager 1.2.2
Media Gallery 1.1.3

XenForo 1.5.2 (Security fix)

20.10.2015 | Romchik®

Вышло очередное дежурное обновление XenForo для главной ветки - 1.5.2. Кроме мелких ошибок была исправлена уязвимость, так что всем обязательно рекомендуется обновиться.

Уязвимость использует тактику, известную как "reverse tabnabbing", при которой ссылка, открывающаяся в новой вкладке, содержит код, который может перенаправить оригинальную вкладку по другому URL, который, в свою очередь, может быть использован для попытки фишинговой атаки.

Также вышли версии с исправлением уязвимости для старых веток 1.3.9 и 1.4.11. Скачать патчи можно по ссылкам в темах на форуме.


Ну и кроме того, сегодня обновилась галерея:
Media Gallery 1.1.2.


Обсудить статью на форуме можно здесь.

XenForo 1.5.1

22.09.2015 | Romchik®

Сегодня день обновлений. XenForo обновился до версии 1.5.1. Версия минорная, а значит фокус как всегда на исправлении ошибок и улучшении стабильности.

Список некоторых изменений в XenForo 1.5.1:

  • При навигации к якорным ссылкам прокрутка меняет позицию для учета фиксированной высоты шапки.
  • Исправлена ошибка сервера в определенных ситуациях, связанная с упоминаемыми пользователями, имеющими слишком длинные ники.
  • Исправлено неправильное получение веса некоторых меток в облаке.
  • Исправлено неправильное обнаружение сенсорных устройств в браузерах IE Mobile и Microsoft Edge.
  • Отрегулировано действие перестраивания прав, чтобы избегать тайм-аут, когда это возможно.
  • При копировании сообщения из темы, не перестраивался счетчик сообщений у целевой темы.
  • Исправлена проблема, иногда возникающая у новых пользователей и мешавшая им получать уведомление о приветственном письме.
  • Исправлено неправильное отображение нескольких столбцов в определенных ситуациях в Chrome.
  • Изменен медиа-код для видео Facebook.
  • Исправлены оповещения о комментариях в профиле, сгенерированных перед обновлением до версии 1.5.0 и отображающихся неправильно.
  • Временное решение для проблемы с некоторыми версиями iOS, на которых не происходил фокус в поле поиска при первом касании.
  • И другие исправления...

Обсудить статью на форуме можно здесь.


Также сегодня обновились официальные плагины галереи и менеджера ресурсов:
Media Gallery 1.1.1 | Resource Manager 1.2.1.

XenForo 1.5.0 Final

18.08.2015 | Romchik®

Сегодня вышла финальная версия XenForo 1.5.

Узнать, что нового появилось в 1.5, можно на странице со списком изменений.

Все, у кого есть активная лицензия, могут скачать скрипт из пользовательской зоны.

Как обычно, команда нашего сайта подготовила русификатор, как раз к выходу новой версии. Скачать его можно отсюда.


Обсудить статью на форуме можно здесь.

Патчи, беты...

28.07.2015 | Romchik®

Что-то прям зачастили с патчами разработчики. К тому же еще и очередные беты вышли. Запакуем все в одну новость с ссылками на форум.

Итак, сначала релизы с исправлениями безопасности:

XenForo 1.4.10 (Security Fix)
XenForo 1.3.8 (Security Fix)
XenForo 1.2.9 (Security Fix)
Media Gallery 1.0.9 (Security Fix)
Media Gallery 1.0.8 (Security Fix)

Патчи можно найти внутри тем. Как можно увидеть, галерея и вовсе два патча успела получить.

И выход очередных бета-версий:

XenForo 1.5.0 Beta 4
Resource Manager 1.2.0 Beta 2
Media Gallery 1.1.0 Beta 2

Resource Manager 1.2.0 Beta 1

22.07.2015 | Romchik®

Ну и кроме того, сегодня вышла другая первая бета плагина менеджера ресурсов для XenForo Resource Manager 1.2.0.

Из нововведений:

  • возможность расставлять метки для ресурсов;
  • блок последних рецензий в боковой панели главной страницы ресурсов;
  • блок последних ресурсов в боковой панели главной страницы форума;
  • настройка сортировки ресурсов по умолчанию;
  • поддержка упоминаний пользователей (через @) для ресурсов и их обновлений;
  • уведомления авторов ресурсов при выполнении действий с их ресурсами (например, удаление, редактирование, смена автора);
  • изменен фильтр ресурсов на главной странице (раньше были вкладки, теперь подменю).

Обратите внимание, что теперь для работы менеджера ресурсов необходим установленный XenForo версии 1.5.0 Beta 3 или выше.

Т.к. это бета-версия, то пока не рекомендуется ставить плагин на рабочие форумы.


Обсудить статью на форуме можно здесь.

Media Gallery 1.1.0 Beta 1

22.07.2015 | Romchik®

Вышла первая бета галереи для XenForo Media Gallery 1.1.0.

О нововведениях можно прочесть здесь.

Обратите внимание, что теперь для работы галереи необходим установленный XenForo версии 1.5.0 Beta 3 или выше.

Т.к. это бета-версия, то пока не рекомендуется ставить галерею на рабочие форумы.


Обсудить статью на форуме можно здесь.

XenForo 1.5.0 Beta 3

22.07.2015 | Romchik®

Сегодня вышла очередная бетка для XenForo 1.5, третья по счету. Незначительные исправления.

Русификатор обновления не требует, ничего не изменилось.

Что нового в XenForo 1.5.


Обсудить статью на форуме можно здесь.

Media Gallery 1.0.7

21.07.2015 | Romchik®

Вышло обновление для галереи - XenForo Media Gallery 1.0.7. Это еще не обещанная 1.1, а выпуск с исправлениями к прошлой ветке.

Примерный список исправлений, сделанных с момента выхода XenForo Media Gallery 1.0.6:

  • Правильная обработка конфиденциальности для гостей, просматривающих новые медиа-элементы.
  • Улучшения в форме добавления, если нет категории, в которую можно добавить медиа-элементы.
  • Предотвращение неверно сформированных запросов для превьюшек медиа-элементов, вызывавших ошибки сервера.
  • Передача параметров страницы навигации на страницу медиа-элементов пользователя должным образом, чтобы сохранялся порядок при переходе от страницы к странице.
  • Обработка потенциальной ошибки "undefined variable" при импорте данных из плагина XFR User Albums.
  • Использование надлежащих данных внешнего URL для "nothumb" изображений.
  • Более четкая обработка случаев, когда определенные инструменты (отметка пользователей и обрезание) не доступны на сенсорных устройствах.

Список измененных шаблонов:

  • xengallery_album_wrapper
  • xengallery_category_wrapper
  • xengallery_media_add
  • xengallery_media_user
  • xengallery_media_view.css
  • xengallery_wrapper.css

Для XenForo Media Gallery необходим установленный XenForo версии 1.3.0 или выше.


Обсудить статью на форуме можно здесь.