1. Приветствуем Вас на неофициальном форуме технической поддержки XenForo на русском языке. XenForo - новый и перспективный форумный движок от бывших создателей vBulletin.

1.1.1 Не выбираются цвета в wysiwyg редакторе

Тема в разделе "Основные вопросы по XenForo", создана пользователем leaderru, 7 фев 2012.

Загрузка
  1. leaderru

    leaderru Пользователь

    Регистрация:
    05.02.12
    Сообщения:
    48
    Симпатии:
    4
    Версия XF:
    1.1.4
    У меня проблема: Когда я набираю на своем форуме сообщение, хочу выбрать цвет того или иного куска текста, окно с выбором цвета появляется, но курсор как во время написания текста ( | ). Следовательно, цвет не выбирается. На других сайтах работает! Как исправить?

    А, вообще присмотрелся получше - у меня в форуме вообще не нажимаются бб коды, которые выпадают поверх поля для ввода текста. То есть, цвета выбираются только первые два ряда (т.к. окошко там не вылезает на поле), смайлики - только первый ряд добавляется
     
  2. CyberAP

    CyberAP Местный

    Регистрация:
    05.10.10
    Сообщения:
    2.577
    Симпатии:
    1.614
    Версия XF:
    1.5.10
    Похоже на баг движка, а если быть точнее, то на баг TinyMCE. Нужно писать разработчикам. Правильно понимаю, у вас браузер - Опера?
     
  3. leaderru

    leaderru Пользователь

    Регистрация:
    05.02.12
    Сообщения:
    48
    Симпатии:
    4
    Версия XF:
    1.1.4
    опера, опера
    --- добавлено : Feb 7, 2012 6:57 PM ---
    Специально с оперы сижу всегда- на ней баги все видны :)
    --- добавлено : Feb 7, 2012 7:04 PM ---
    Можно ли переустановить этот TinyMCE или что-нибудь другое поставить?
     
  4. CyberAP

    CyberAP Местный

    Регистрация:
    05.10.10
    Сообщения:
    2.577
    Симпатии:
    1.614
    Версия XF:
    1.5.10
    Могу лишь дать грязный фикс. Код нужно вставить в самый конец шаблона editor_ui.css

    Код:
    /* fixes */
     
    body .xenForoSkin.mce_xenforo_smilies,
    body .mce_xenforo_smilies.mceSmiliesMenu,
    body .xenForoSkin .mceSmiliesMenu div,
    body .xenForoSkin a.bbCodeEditorButton
    {
        z-index: 99999 !important;
    }
     
    .xenForoSkin table,
    .xenForoSkin tbody,
    .xenForoSkin a,
    .xenForoSkin img,
    .xenForoSkin tr,
    .xenForoSkin div,
    .xenForoSkin td,
    .xenForoSkin iframe,
    .xenForoSkin span,
    .xenForoSkin *,
    .xenForoSkin .mceText
    {
        z-index: 0;
    }
     
    body .mce_xenforo_smilies.mceSmiliesMenu,
    body .xenForoSkin .mceSmiliesMenu div,
    .xenForoSkin table,
    .xenForoSkin tbody,
    .xenForoSkin a,
    .xenForoSkin img,
    .xenForoSkin tr,
    .xenForoSkin div,
    .xenForoSkin td,
    .xenForoSkin iframe,
    .xenForoSkin span,
    .xenForoSkin *,
    .xenForoSkin .mceText,
    body .xenForoSkin a.bbCodeEditorButton
    {
        position: relative;
    }
     
  5. leaderru

    leaderru Пользователь

    Регистрация:
    05.02.12
    Сообщения:
    48
    Симпатии:
    4
    Версия XF:
    1.1.4
    а почему "Грязный"? Вообще, главное, чтобы работало
     
  6. CyberAP

    CyberAP Местный

    Регистрация:
    05.10.10
    Сообщения:
    2.577
    Симпатии:
    1.614
    Версия XF:
    1.5.10
    Грязный потому что не решает проблемы, а лишь её скрывает. Когда будет ясно из-за чего это происходит тогда и можно будет сделать красивое решение.
     
  7. leaderru

    leaderru Пользователь

    Регистрация:
    05.02.12
    Сообщения:
    48
    Симпатии:
    4
    Версия XF:
    1.1.4
    А нельзя сам редактор заменить или переустановить?
     
  8. CyberAP

    CyberAP Местный

    Регистрация:
    05.10.10
    Сообщения:
    2.577
    Симпатии:
    1.614
    Версия XF:
    1.5.10
    Вроде уже у кого-то получалось поставить другой редактор, нужно у программистов спросить.
     
  9. leaderru

    leaderru Пользователь

    Регистрация:
    05.02.12
    Сообщения:
    48
    Симпатии:
    4
    Версия XF:
    1.1.4
    Кстати на денвере тотже самый дистрибутив работает нормально!
     
  10. CyberAP

    CyberAP Местный

    Регистрация:
    05.10.10
    Сообщения:
    2.577
    Симпатии:
    1.614
    Версия XF:
    1.5.10
    Баг вылезает неожиданно. Скорее всего проблема кроется в джаваскриптах TinyMCE, либо в сторонних js. Может быть, если в следующей версии XF обновят TinyMCE, баг пропадёт.
     
  11. leaderru

    leaderru Пользователь

    Регистрация:
    05.02.12
    Сообщения:
    48
    Симпатии:
    4
    Версия XF:
    1.1.4
    Тот же дистрибутив отлично работает на денвере

    --- добавлено : Feb 9, 2012 3:23 AM ---

    Я выяснил, что это баг шаблона.
    Шаблон XenBlue dark. Из изменений шаблона стоят только подкатегории в столбики, тег хайд и несколько цветовых изменений
    Все! Проблема решилась! Тему можно закрывать. Решилось элементарно: Экспорт стиля - удалить стиль - импорт стиля
     
  12. CyberAP

    CyberAP Местный

    Регистрация:
    05.10.10
    Сообщения:
    2.577
    Симпатии:
    1.614
    Версия XF:
    1.5.10
    Это не решение на самом деле, через некоторое время баг опять вылезет, и это не проблема стиля.
     
  13. leaderru

    leaderru Пользователь

    Регистрация:
    05.02.12
    Сообщения:
    48
    Симпатии:
    4
    Версия XF:
    1.1.4
    При написании поста удалилось. А теперь снова появились эти же ошибки при создании темы!

    Но проблема, вообще то в шаблоне. Когда я на стандартный меняю, то сразу нормально тема создается
     

Поделиться этой страницей