1. Приветствуем Вас на неофициальном форуме технической поддержки XenForo на русском языке. XenForo - новый и перспективный форумный движок от бывших создателей vBulletin.

Ошибка 500 internal server error при включенном ЧПУ

Тема в разделе "Основные вопросы по XenForo", создана пользователем valera, 20 окт 2011.

Загрузка
  1. valera

    valera Активный пользователь

    Регистрация:
    18.10.11
    Сообщения:
    31
    Симпатии:
    4
    Помогите пожалуйста, установил движок, все как надо, форум работает, пошел делать настройки, там, тут то се, все работает переходит из тему в тему, а как поставил галочку на ИСПОЛЬЗОВАТЬ ЧПУ ССЫЛКИ, в темы не переходит, выдает ошибку , что надо прописать или дописать В htaccess файл? подскажите плииииизз
     
  2. Romchik®

    Romchik® The Power of Dreams Команда форума

    Регистрация:
    26.09.10
    Сообщения:
    5.740
    Симпатии:
    5.269
    Версия XF:
    1.5.11
    Для работы ЧПУ необходим установленный mod_rewrite.
    А также файл .htaccess в корне форума. Взять его можно из архива установки.
     
  3. FractalizeR

    FractalizeR XenForo Addicted Команда форума

    Регистрация:
    27.09.10
    Сообщения:
    1.085
    Симпатии:
    823
    Версия XF:
    1.3.2
    А лог апача вы можете посмотреть?
     
  4. valera

    valera Активный пользователь

    Регистрация:
    18.10.11
    Сообщения:
    31
    Симпатии:
    4
    Ошибка была исправлена, проблема была вроде как в этом RewriteBase , но все же спасибо за поддержку!
     
  5. duckmen

    duckmen Местный

    Регистрация:
    07.02.12
    Сообщения:
    12
    Симпатии:
    0
    Версия XF:
    1.1.1
    а можно поподробней как это решить?
     
  6. TAIFUN

    TAIFUN Человек

    Регистрация:
    27.09.10
    Сообщения:
    2.121
    Симпатии:
    1.560
    Версия XF:
    1.5.9
    У Вас аналогичная проблема? Скиньте содержимое файла .htaccess
     
  7. duckmen

    duckmen Местный

    Регистрация:
    07.02.12
    Сообщения:
    12
    Симпатии:
    0
    Версия XF:
    1.1.1
    ну , полазив некоторое время на просторах интернета , я ее решил
     
  8. Федор

    Федор Пользователь

    Регистрация:
    19.02.12
    Сообщения:
    32
    Симпатии:
    0
    Версия XF:
    1.1.3
    Здравствуйте,
    после включения режима ЧПУ
    выдает ошибку 500 на портале

    Вот содержимое .htaccess, на хостинге говорят, что mod_rewrite установлен уже давно.
     
  9. Serega_Blink

    Serega_Blink Активный пользователь

    Регистрация:
    23.10.11
    Сообщения:
    27
    Симпатии:
    0
    Версия XF:
    1.1.3
    Может стоит сменить кодировку PHP?
     
  10. Федор

    Федор Пользователь

    Регистрация:
    19.02.12
    Сообщения:
    32
    Симпатии:
    0
    Версия XF:
    1.1.3
    Может быть, но у меня простой хостинг.
    Как это сделать?
     
  11. Serega_Blink

    Serega_Blink Активный пользователь

    Регистрация:
    23.10.11
    Сообщения:
    27
    Симпатии:
    0
    Версия XF:
    1.1.3
    В ISP менеджере...
     
  12. Федор

    Федор Пользователь

    Регистрация:
    19.02.12
    Сообщения:
    32
    Симпатии:
    0
    Версия XF:
    1.1.3
    Я вообще ничего не понял, про кодировку какого файла вы говорите?
     
  13. TAIFUN

    TAIFUN Человек

    Регистрация:
    27.09.10
    Сообщения:
    2.121
    Симпатии:
    1.560
    Версия XF:
    1.5.9
    Что-о-о-о?

    ---
    Федор попробуйте раскомментировать строку:
    Код:
    #RewriteBase /xenforo
    затем очистите кэш браузера и перезапустите браузер.

    И пользуйтесь поиском, прежде чем создать тему.
     
  14. Федор

    Федор Пользователь

    Регистрация:
    19.02.12
    Сообщения:
    32
    Симпатии:
    0
    Версия XF:
    1.1.3
  15. TAIFUN

    TAIFUN Человек

    Регистрация:
    27.09.10
    Сообщения:
    2.121
    Симпатии:
    1.560
    Версия XF:
    1.5.9
    Хм, что-то не так на сервере. Мод секъюрити включен? Попробуйте отключить его, если включен.
     
  16. Федор

    Федор Пользователь

    Регистрация:
    19.02.12
    Сообщения:
    32
    Симпатии:
    0
    Версия XF:
    1.1.3
    Кто же мне даст его отключить :)
     
  17. TAIFUN

    TAIFUN Человек

    Регистрация:
    27.09.10
    Сообщения:
    2.121
    Симпатии:
    1.560
    Версия XF:
    1.5.9
    Прочтите моё предыдущее сообщение :) Речь о мод секъюрити.
     
  18. Федор

    Федор Пользователь

    Регистрация:
    19.02.12
    Сообщения:
    32
    Симпатии:
    0
    Версия XF:
    1.1.3
    Извините,
    я не знаю включен ли он, это у тех. поддержки надо узнать?

    как-то связано с этими строками?
    Код:
    #<IfModule mod_security.c>
    #SecFilterEngine Off
    #SecFilterScanPOST Off
    #</IfModule>
    
     
  19. TAIFUN

    TAIFUN Человек

    Регистрация:
    27.09.10
    Сообщения:
    2.121
    Симпатии:
    1.560
    Версия XF:
    1.5.9
    Кстати, да, попробуйте раскомментировать эти строки (убрать символы # с которых начинаются эти строки)
     
  20. Федор

    Федор Пользователь

    Регистрация:
    19.02.12
    Сообщения:
    32
    Симпатии:
    0
    Версия XF:
    1.1.3
    Ничего не получается
     

Поделиться этой страницей