1. Приветствуем Вас на неофициальном форуме технической поддержки XenForo на русском языке. XenForo - новый и перспективный форумный движок от бывших создателей vBulletin.

Перенос с vB - собираем известные баги переноса

Тема в разделе "Переезд на XenForo c других движков", создана пользователем phpclub, 20 окт 2010.

Загрузка
  1. phpclub

    phpclub Местный

    Регистрация:
    01.10.10
    Сообщения:
    7
    Симпатии:
    2
    Версия XF:
    1.5.10
    Пока ссылку на аналогичный тред. Кто сможет перевести на русский?
    http://xenforo.com/community/threads/vb-as-an-import-intermediate-share-your-experiences.5942/
    --- добавлено : 20 окт 2010 в 20:57 ---
    xenForo не может перенести threads с пустым postusername
    Попробуйте выполнить на своей БД, у меня нашлось 3 записи. Посмотрим поможет ли.
    Code:
    UPDATE `set this to your vB database`.`thread` SET `postusername` = 'Guest' WHERE `thread`.`postusername` =''
     
  2. CyberAP

    CyberAP Местный

    Регистрация:
    05.10.10
    Сообщения:
    2.577
    Симпатии:
    1.614
    Версия XF:
    1.5.10
    Ещё баг с импортом опросов пофиксили в бета2, насколько я знаю.
     
    Romchik® нравится это.
  3. Romchik®

    Romchik® The Power of Dreams Команда форума

    Регистрация:
    26.09.10
    Сообщения:
    5.740
    Симпатии:
    5.269
    Версия XF:
    1.5.11
    Т.к. этот форум был совсем мал во время переноса, то багов не заметил, кроме неверного переноса результатов голосования. Но раз уже пофиксили, то просто отлично :)
     
  4. CyberAP

    CyberAP Местный

    Регистрация:
    05.10.10
    Сообщения:
    2.577
    Симпатии:
    1.614
    Версия XF:
    1.5.10
    Кстати возможно только у меня такой баг, но поиск не работает, то есть весь контент есть, а индексации по нему нет, ни в последних новостях, ни в том же поиске. Наверное это ещё может быть потому что я три раза импортировал форум, но два предыдущих раза я просто удалял разделы без удаления тем, но с удалением юзеров.
     
  5. Romchik®

    Romchik® The Power of Dreams Команда форума

    Регистрация:
    26.09.10
    Сообщения:
    5.740
    Симпатии:
    5.269
    Версия XF:
    1.5.11
    Пока не замечал такого. Здесь вроде с поиском проблем нет...
     
  6. phpclub

    phpclub Местный

    Регистрация:
    01.10.10
    Сообщения:
    7
    Симпатии:
    2
    Версия XF:
    1.5.10
    Есть проблеммы с двойное перекодировкой в
    /XenForo/Importer/vBulletin.php [1781]
    надо убрать перекодировку user и message - и все пойдет :)
     
    CyberMama и AleX нравится это.
  7. SID

    SID Активный пользователь

    Регистрация:
    20.10.10
    Сообщения:
    31
    Симпатии:
    6
    Всем привет. Попробовал переехать с 4.0.3, установив соответствующий скрипт переноса. Вообщем все ступорится на переносе пользователей. Как только начинаю импорт, пишет "Произошла ошибка на сервере, бла бла бла". С чем может быть связано? Пользователей на 4ке чуть больше 1500 человек.
     
  8. deity

    deity Read only

    Регистрация:
    07.10.10
    Сообщения:
    136
    Симпатии:
    87
    Версия XF:
    1.1.0 Final
    С "бла бла бла" связно, к бабке не ходи.
     
    CyberMama и CyberAP нравится это.
  9. SID

    SID Активный пользователь

    Регистрация:
    20.10.10
    Сообщения:
    31
    Симпатии:
    6
    Хорошо, цитирую.
    "
    Ошибка

    На сервере произошла ошибка. Пожалуйста, попробуйте позже."

    Сильно отличается от "бла бла бла" ? ;)
     
  10. deity

    deity Read only

    Регистрация:
    07.10.10
    Сообщения:
    136
    Симпатии:
    87
    Версия XF:
    1.1.0 Final
    Нет, не сильно. Я подумал, что ты опустил содержание "бла бла бла", сорри.
     
  11. g0rn

    g0rn Местный

    Регистрация:
    03.10.10
    Сообщения:
    107
    Симпатии:
    146
    В админке есть журнал ошибок. Но вообще проще подождать пару-тройку дней до второй беты, там много ошибок с импортом было исправлено, вполне вероятно, что и эта тоже.
     
  12. SID

    SID Активный пользователь

    Регистрация:
    20.10.10
    Сообщения:
    31
    Симпатии:
    6
    В логе ошибок ничего нет =)
     
  13. FractalizeR

    FractalizeR XenForo Addicted Команда форума

    Регистрация:
    27.09.10
    Сообщения:
    1.085
    Симпатии:
    823
    Версия XF:
    1.3.2
    А в логе PHP?
     
  14. sonic

    sonic Местный

    Регистрация:
    08.10.10
    Сообщения:
    279
    Симпатии:
    216

    а форум отключен? при включенном форуме у меня такое же выдавало.. а когда форум отключить то все нормально.
     
  15. SID

    SID Активный пользователь

    Регистрация:
    20.10.10
    Сообщения:
    31
    Симпатии:
    6
    Тоже самое. выключено оба форума...
     
  16. Romchik®

    Romchik® The Power of Dreams Команда форума

    Регистрация:
    26.09.10
    Сообщения:
    5.740
    Симпатии:
    5.269
    Версия XF:
    1.5.11
    А группы пользователей имеются дополнительные? Если да, попробуйте всех в одну группу перенести - к зарегистрированным.
     
  17. SID

    SID Активный пользователь

    Регистрация:
    20.10.10
    Сообщения:
    31
    Симпатии:
    6
    Всего 2 группы, Админы и Юзеры. В админах 2 человека, в юзерах 1573.
    И снова тоже самое...
     
  18. SID

    SID Активный пользователь

    Регистрация:
    20.10.10
    Сообщения:
    31
    Симпатии:
    6
    Даже переход на бету 2 не помог...
     
  19. Romchik®

    Romchik® The Power of Dreams Команда форума

    Регистрация:
    26.09.10
    Сообщения:
    5.740
    Симпатии:
    5.269
    Версия XF:
    1.5.11
    Я бы поэкспериментировал.
    Начал бы сначала с удаления неактивных пользователей. Удалил бы тех, у кого 0 сообщений и кто не был на форуме, допустим, 60-90 дней.
    Если и после сокращения числа пользователей не поможет, то смотрел бы на ники, может есть какие-то спецсимволы у некоторых.
    Может статусы какие-нибудь или же в подписях что-то.
    При наличии копии можно радикально экспериментировать. Оставить вообще одного админа и проверить. Может дело вообще не в пользователях.
    Счетчики тоже на всякий случай все прогнать и обновить.
     
    SID нравится это.
  20. CyberAP

    CyberAP Местный

    Регистрация:
    05.10.10
    Сообщения:
    2.577
    Симпатии:
    1.614
    Версия XF:
    1.5.10
    Во-первых, нужно разобраться с кодировкой, если БД имеет кодировку UTF-8 то можно продолжать.
    Во-вторых, удалить кастомные (созданные вручную) группы у которых название на кириллице.
    В-третьих, почитать логи сайта.
     
    SID нравится это.

Поделиться этой страницей