1. Приветствуем Вас на неофициальном форуме технической поддержки XenForo на русском языке. XenForo - новый и перспективный форумный движок от бывших создателей vBulletin.

Перенос с хостинга на Denwer

Тема в разделе "Для новичков", создана пользователем Lender, 27 май 2015.

Загрузка
  1. Lender

    Lender Новичок

    Регистрация:
    27.05.15
    Сообщения:
    9
    Симпатии:
    0
    Версия XF:
    1.4.7
    Привет, скачал\установил денвер, залил все файлы форума с хостинга, в phpMyAdmin создал нового пользователя и БД.
    импортировал БД скриптом sxd
    поправил файл library/config.php

    Код:
    <?php
    
    $config['db']['host'] = 'localhost';
    $config['db']['port'] = '3306';
    $config['db']['username'] = ***;
    $config['db']['password'] = ***;
    $config['db']['dbname'] = ***;
    $config['superAdmins'] = '1';
    ---------------------
    далее при открытии форума в браузере открывается только главная страница(отображается коректно)
    а темы не открывает, логинится нельзя, и т.д. пишет ошибку

    Not Found
    The requested URL /login/login was not found on this server.


    Подсказка Денвера
    Вы ошиблись при наборе URL в браузере. Вероятнее всего, сервер пытается найти файл Z:/home/forum_leveronfx/www/login/login, которого не существует.

    В случае использования CGI-скриптов, корректные пути к CGI-директориям следующие:

    URL Куда указывает
    http://***/cgi-glob/script.cgi /home/cgi-glob/script.cgi
    http://***/cgi/script.cgi /home/***/cgi/script.cgi
    http://***/cgi-bin/script.cgi /home/***/cgi-bin/script.cgi

    Apache/2.2.22 (Win32) mod_ssl/2.2.22 OpenSSL/1.0.1c PHP/5.3.13 Server at forum_leveronfx Port 80

    ------------------------------------------
    что можно сделать, как решать?

    я так понял что при переходе по ссылках "/login/login"(или других в зависимости от действий) не вызываются методы соотведствующих класов, а сервер просто ищет файлы по адресу в ссылке
     
  2. Lender

    Lender Новичок

    Регистрация:
    27.05.15
    Сообщения:
    9
    Симпатии:
    0
    Версия XF:
    1.4.7
    при чем не работает только сам форум, админка работает нормально(заходил через /admin.php)
     
  3. SrDEN

    SrDEN Местный

    Регистрация:
    29.08.14
    Сообщения:
    114
    Симпатии:
    52
    Версия XF:
    1.5.0
    Ставь опенсервер: http://open-server.ru/

    Денвер еще та кривотня, и когда ксен перейдет полностью на 5.4, на денвере хапнеш геморроя :)
     
    Mirovinger нравится это.
  4. Lender

    Lender Новичок

    Регистрация:
    27.05.15
    Сообщения:
    9
    Симпатии:
    0
    Версия XF:
    1.4.7
    удалил денвер, поставил опенсервер, закинул туда файлы форума, также в phpMyAdmin создал нового пользователя и БД.
    импортировал БД скриптом sxd.
    проблема осталась...
    все также главная страница показывает все отлично, на никаких действий типа открыть тему, залосниться, открыть страницу пользователя из статистики нельзя, и сообщений в чате на главной нету, хотя в должны быть

    ошибку пишет аналогичню
    Object not found!
    The requested URL was not found on this server. The link on the referring page seems to be wrong or outdated. Please inform the author of that page about the error.

    If you think this is a server error, please contact the webmaster.

    Error 404
    forum.leveronfx2.com
    05/28/15 17:46:47
    Apache/2.2.29 (Win32)
     
  5. Lender

    Lender Новичок

    Регистрация:
    27.05.15
    Сообщения:
    9
    Симпатии:
    0
    Версия XF:
    1.4.7

Поделиться этой страницей