1. Приветствуем Вас на неофициальном форуме технической поддержки XenForo на русском языке. XenForo - новый и перспективный форумный движок от бывших создателей vBulletin.

При нажатии на ссылку темы браузеры виснут с бесконечной переадресацией страницы

Тема в разделе "Баги XenForo", создана пользователем vitalik, 17 окт 2010.

Загрузка
  1. vitalik

    vitalik Местный

    Регистрация:
    17.10.10
    Сообщения:
    62
    Симпатии:
    18
    Xenforo не поддерживает full friendly urls? есть форум на xf, если в настройках поставить full friendly urls и include content title, то при нажатии на ссылку тему - браузеры виснут с бесконечной переадресацией страницы. это так?
     
  2. CyberAP

    CyberAP Местный

    Регистрация:
    05.10.10
    Сообщения:
    2.577
    Симпатии:
    1.614
    Версия XF:
    1.5.10
    Проверьте файл .htaccess, все современные браузеры должны корректно отображать URLы xenforo.
     
  3. Pepelac

    Pepelac Продам луц в бутылках Команда форума

    Регистрация:
    28.09.10
    Сообщения:
    1.794
    Симпатии:
    1.349
    в .htaccess все правильно указано?
     
  4. Pepelac

    Pepelac Продам луц в бутылках Команда форума

    Регистрация:
    28.09.10
    Сообщения:
    1.794
    Симпатии:
    1.349
    ну тогда включить запись логов rewrite модуля и смотреть, где оно начинает глючить
     
  5. vitalik

    vitalik Местный

    Регистрация:
    17.10.10
    Сообщения:
    62
    Симпатии:
    18
    RewriteLogLevel not allowed here вот что выдается в error_log при установкк RewriteLogLevel 1
     
  6. Pepelac

    Pepelac Продам луц в бутылках Команда форума

    Регистрация:
    28.09.10
    Сообщения:
    1.794
    Симпатии:
    1.349
    стоит тогда обратиться к хостерам, чтобы они этот лог каким-либо способом сгенерили. ибо же, насколько я понял, хостинг обычный шаред?
     
  7. vitalik

    vitalik Местный

    Регистрация:
    17.10.10
    Сообщения:
    62
    Симпатии:
    18
    эмм, счас поговорю насчет этого с саппортом
     
  8. vitalik

    vitalik Местный

    Регистрация:
    17.10.10
    Сообщения:
    62
    Симпатии:
    18
    up, техподдержка ответила отказом. на денвере на локальном компе все работает, на хостинге нет, причем только в темах с русскими буквами, английские темы нормально обрабатываются :(
     
  9. Pepelac

    Pepelac Продам луц в бутылках Команда форума

    Регистрация:
    28.09.10
    Сообщения:
    1.794
    Симпатии:
    1.349
    странный у вас хостинг. имхо единственный вариант для вас - убрать галочку "Включать заголовок страницы в URL" в настройках оптимизации для поисковых систем
     
  10. vitalik

    vitalik Местный

    Регистрация:
    17.10.10
    Сообщения:
    62
    Симпатии:
    18
    да я понял это уже, будем надеятся, что мои завтрашние угрозы в саппорт хостинга подействуют и он согласится дать mod_rewrite логи :)
     
  11. FractalizeR

    FractalizeR XenForo Addicted Команда форума

    Регистрация:
    27.09.10
    Сообщения:
    1.085
    Симпатии:
    823
    Версия XF:
    1.3.2
    Скиньте в приват URL форума.

    Еще можно попробовать RewriteBase /<цензура> добавить в .htaccess. Похоже, что хостер намутил что-то с алиасами.
     
    vitalik нравится это.
  12. FractalizeR

    FractalizeR XenForo Addicted Команда форума

    Регистрация:
    27.09.10
    Сообщения:
    1.085
    Симпатии:
    823
    Версия XF:
    1.3.2
    RewriteBase попробовали?
     
  13. vitalik

    vitalik Местный

    Регистрация:
    17.10.10
    Сообщения:
    62
    Симпатии:
    18
    эмм, пока нет, думаю через пару часов доберусь до компа с доступом к хосту и посмотрю rewritebase. Как альтернатива: хостер предложил бесплатно vps для тестов на 10 дней. Ох-ох-ох. :( Завтра думаю выложить логи по mod_rewrite на vps серваке, если сам не разберусь в чем причина
     
    FractalizeR нравится это.
  14. vitalik

    vitalik Местный

    Регистрация:
    17.10.10
    Сообщения:
    62
    Симпатии:
    18
    rewritebase не помогает :(
     
  15. FractalizeR

    FractalizeR XenForo Addicted Команда форума

    Регистрация:
    27.09.10
    Сообщения:
    1.085
    Симпатии:
    823
    Версия XF:
    1.3.2
    Тогда пока больше ничего не посоветую. Мне кажется, это связано не с форумом, а с настройками хоста. Например, у меня из-за "тихой" установки mod_security на сервере хостера долго не работал flash-загрузчик WordPress на моем сайте. Тихо отваливался с сообщением "Ошибка HTTP". Я только недавно допер, в чем причина. Выходов в таких случая два. Первый - применение терморектального криптоанализа к хостеру, и второй - долгие копания гугла и сайта.
     
    vitalik нравится это.
  16. vitalik

    vitalik Местный

    Регистрация:
    17.10.10
    Сообщения:
    62
    Симпатии:
    18
    хех, virtual private server даст мне ответы, я надеюсь. если нет - остается вариант сменить хостера :)
     
    FractalizeR нравится это.
  17. g0rn

    g0rn Местный

    Регистрация:
    03.10.10
    Сообщения:
    107
    Симпатии:
    146
    Не заходит с таким паролем через ssh и webmin
     
  18. deity

    deity Read only

    Регистрация:
    07.10.10
    Сообщения:
    136
    Симпатии:
    87
    Версия XF:
    1.1.0 Final
    Уже кто-то сменил, наверное. Vitalik, пользователя нужно было создать для экспериментов.
     
    CyberAP нравится это.
  19. CyberAP

    CyberAP Местный

    Регистрация:
    05.10.10
    Сообщения:
    2.577
    Симпатии:
    1.614
    Версия XF:
    1.5.10
    От рута лучше пароль вообще не давать.
     
    deity нравится это.
  20. g0rn

    g0rn Местный

    Регистрация:
    03.10.10
    Сообщения:
    107
    Симпатии:
    146
    Вот только зачем менять? VPS очень много кто даёт бесплатно потестировать и воровать смысла мало :)
     
    CyberAP нравится это.

Поделиться этой страницей