1. Приветствуем Вас на неофициальном форуме технической поддержки XenForo на русском языке. XenForo - новый и перспективный форумный движок от бывших создателей vBulletin.

Проблема NGINX

Тема в разделе "Основные вопросы по XenForo", создана пользователем ANGEL OF FIRE, 23 мар 2015.

Загрузка
  1. ANGEL OF FIRE

    ANGEL OF FIRE Модератор Команда форума

    Регистрация:
    06.11.11
    Сообщения:
    393
    Симпатии:
    179
    Версия XF:
    1.1.3
    Возникла такая проблема. Был форум, и портал на вордпресс.

    Вордпресс стоял в руте, а вот форум в подпапке /forum/

    Так как решили установить портал вместо вордпресса, пришлось перенести форум в рут.

    Теперь в портале включаем функцию отображать как главную, и получается так, портал как главная, а вот форум становится /forums/

    Само собой разумеется папки forums на фтп не существует.

    Так вот, нужно было изменить forums, на forum, что я сделал через Фильтры роутинга, но многое всё равно не работает, так как запросы идут на forums/

    К примеру как редактирование сообщения и т.д.

    Если же я в нгинксе прописываю перенаправление, то форум вообще не открывается, так как папки /forum/ тоже не существует.

    Как это исправить? Может кто-то сталкивался с подобной проблемой?
     
  2. Exile

    Exile Местный

    Регистрация:
    27.06.11
    Сообщения:
    999
    Симпатии:
    543
    Версия XF:
    1.4.4
    Ну вообще тут конфиг стандартный для nginx должен применяться, типа такого: http://nginxlibrary.com/xenforo-configuration/

    И с директории forum/ нужно сделать 301 редирект на /, с сохранением параметров. Фильтры роутингов никакие при этом не нужны.
     
    ANGEL OF FIRE нравится это.

Поделиться этой страницей