1. Приветствуем Вас на неофициальном форуме технической поддержки XenForo на русском языке. XenForo - новый и перспективный форумный движок от бывших создателей vBulletin.

1.4.x Проблема с кэшем - Fatal Error: XCache: Сannot init

Тема в разделе "Основные вопросы по XenForo", создана пользователем Karat7, 29 сен 2014.

Загрузка
  1. Karat7

    Karat7 Заблокирован

    Регистрация:
    19.03.14
    Сообщения:
    140
    Симпатии:
    12
    Версия XF:
    1.4.2
    Помогите понять в чем проблема
    error.JPG
     
  2. santamo

    santamo Местный

    Регистрация:
    03.06.13
    Сообщения:
    252
    Симпатии:
    23
    Версия XF:
    1.2.4
    Чото с кешем у вас не в порядке.
    У меня такое в конфигфайле:
    $config['cache']['enabled'] = true;
    $config['cache']['frontend'] = 'Core';
    $config['cache']['frontendOptions']['cache_id_prefix'] = 'xf_';

    #$config['cache']['backend'] = 'Memcached';
    $config['cache']['backendOptions'] = array(
    'compression' => false,
    'servers' => array(
    array(
    // your memcached server IP /address
    'host' => 'localhost',

    // memcached port
    'port' => 11211,
    )
    )
    );
    Может в настройках смотреть надо.
    Вооще когда-то тут этатепа обсуждалась - поиищите
     
  3. Karat7

    Karat7 Заблокирован

    Регистрация:
    19.03.14
    Сообщения:
    140
    Симпатии:
    12
    Версия XF:
    1.4.2
    На одном сервере нормально а на этом вот так, хожу по форуму а он мне выстреливает каждый раз ошибку при переходе, я его уже заново переставил он все равно глючит так

    Конфиг фал это то что в папке library?
     
  4. santamo

    santamo Местный

    Регистрация:
    03.06.13
    Сообщения:
    252
    Симпатии:
    23
    Версия XF:
    1.2.4
    Может XCache неподдерживается у хостера. У моего точно так.
     
  5. Karat7

    Karat7 Заблокирован

    Регистрация:
    19.03.14
    Сообщения:
    140
    Симпатии:
    12
    Версия XF:
    1.4.2
    А можно это отключить чтоб он не забивал сообщениями об ошибке?
    --- добавлено : Sep 28, 2014 9:39 PM ---
    И еще такой вопрос, как обновить шаблон? У меня Charm есть шаблон но старой версии, работает но в админке говорит что шаблон старый
     
    Последнее редактирование модератором: 6 окт 2014
  6. santamo

    santamo Местный

    Регистрация:
    03.06.13
    Сообщения:
    252
    Симпатии:
    23
    Версия XF:
    1.2.4
    да - в лайбрари
    там и смотрите
    как обновить - сам пока не знаю.
     
  7. Karat7

    Karat7 Заблокирован

    Регистрация:
    19.03.14
    Сообщения:
    140
    Симпатии:
    12
    Версия XF:
    1.4.2
    Там у меня только данные базы и все, кода как у вас нет
     
  8. Exile

    Exile Местный

    Регистрация:
    27.06.11
    Сообщения:
    999
    Симпатии:
    546
    Версия XF:
    1.4.4
    Значит у кого-то есть уже форум на сервере на XF и у вас конфиг с его кеша подгружается. Поправьте вот эту строчку:
    PHP:
    $config['cache']['frontendOptions']['cache_id_prefix'] = 'xf_';
    Например myxf_ там напишите.
     
  9. infis

    infis Местный Команда форума

    Регистрация:
    27.06.11
    Сообщения:
    5.525
    Симпатии:
    3.321
    Версия XF:
    1.5.9
    Если у кого-то уже есть форум на XF на том же сервере, то я бы вообще не стал использовать XCache. Ведь ничто не мешает в этом случае "угнать" сессии с чужого форума, а значит, могут угнать сессии и Ваши. Ну и т.д.
     
  10. Karat7

    Karat7 Заблокирован

    Регистрация:
    19.03.14
    Сообщения:
    140
    Симпатии:
    12
    Версия XF:
    1.4.2
    Вот что у меня там, больше ничего нету:
    <?php

    $config['db']['host'] = 'localhost';
    $config['db']['port'] = '3306';
    $config['db']['username'] = '******';
    $config['db']['password'] = '********';
    $config['db']['dbname'] = '*******';


    $config['superAdmins'] = '1';
     
  11. infis

    infis Местный Команда форума

    Регистрация:
    27.06.11
    Сообщения:
    5.525
    Симпатии:
    3.321
    Версия XF:
    1.5.9
    Тогда вообще не понятно, почему появляется ошибка инициализации кеша переменных...
    Возможно, какие-то файлы движка битые. Но не уверен.
     
  12. Exile

    Exile Местный

    Регистрация:
    27.06.11
    Сообщения:
    999
    Симпатии:
    546
    Версия XF:
    1.4.4
  13. Karat7

    Karat7 Заблокирован

    Регистрация:
    19.03.14
    Сообщения:
    140
    Симпатии:
    12
    Версия XF:
    1.4.2
    Была статья насчет кеша и дернул меня черт )) Форум заменил по новой (установил) но глюк не пропал :(
     
  14. FractalizeR

    FractalizeR XenForo Addicted Команда форума

    Регистрация:
    27.09.10
    Сообщения:
    1.085
    Симпатии:
    823
    Версия XF:
    1.3.2
    Поскольку проблема так и не была решена, рискну поднять старый тред. Скорее всего, проблема в том, что при старте XCache не смог проинициализировать разделяемую память. Проверьте настройки XCache. Путь, указываемый директивой xcache.mmap_path не должен существовать. XCache создает и удаляет эту папку сам.
     

Поделиться этой страницей