1. Приветствуем Вас на неофициальном форуме технической поддержки XenForo на русском языке. XenForo - новый и перспективный форумный движок от бывших создателей vBulletin.

Проблема с кодировкой после перехода с IPB

Тема в разделе "Переезд на XenForo c других движков", создана пользователем Xansen, 19 май 2012.

Загрузка
  1. Xansen

    Xansen Местный

    Регистрация:
    16.12.11
    Сообщения:
    12
    Симпатии:
    0
    Версия XF:
    1.1.2
    подскажите пожалуйста, как после импорта по сложной схеме IPB2.3.6->VB4->XF1.1.1
    исправить кодировку постов на форуме?!

    Сейчас у меня все разделы и темы отображаются кракозяброй:(
    ссылка на форум: snegforum.ru
     
  2. TAIFUN

    TAIFUN Человек

    Регистрация:
    27.09.10
    Сообщения:
    2.121
    Симпатии:
    1.560
    Версия XF:
    1.5.9
    В phpMyAdmin посты отображаются кракозябрами или кириллицей?
     
  3. Xansen

    Xansen Местный

    Регистрация:
    16.12.11
    Сообщения:
    12
    Симпатии:
    0
    Версия XF:
    1.1.2
    Там теже самые кракозябры... Проблема в том что все форумы которые конвертил были в cp1251...
     
  4. infis

    infis Местный Команда форума

    Регистрация:
    27.06.11
    Сообщения:
    5.525
    Симпатии:
    3.321
    Версия XF:
    1.5.9
    А в VB4 данные корректно отображались? Там они были в какой кодировке?
    В ксене должна быть кодировка utf-8. Т.е., как минимум, на этапе конвертации из VB4 в XF1.1 нужно перекодировать.
     
  5. Xansen

    Xansen Местный

    Регистрация:
    16.12.11
    Сообщения:
    12
    Симпатии:
    0
    Версия XF:
    1.1.2
    ДА, в ВБ всё ок было. Посмотрел в VB в базе всё отлично и кодировка у таблицы threads стоит
    cp1251_general_ci.
    конвертировал через impex. В принципе есть рабочая БД от VB и от IPB...

    Что мне сделать чтобы всё заработало?
     
  6. infis

    infis Местный Команда форума

    Регистрация:
    27.06.11
    Сообщения:
    5.525
    Симпатии:
    3.321
    Версия XF:
    1.5.9
    Посмотрите конвертор, там, насколько помню, была опция, в какой кодировке база vB. А ксен в любом случае в utf-8.
     
  7. Xansen

    Xansen Местный

    Регистрация:
    16.12.11
    Сообщения:
    12
    Симпатии:
    0
    Версия XF:
    1.1.2
    я пробовал всевозможные кодировки в конвертере... ставил utf8, cp1251... не помогает... Только посты вместо кракозябр вообще знаками вопроса становятся...
     
  8. TAIFUN

    TAIFUN Человек

    Регистрация:
    27.09.10
    Сообщения:
    2.121
    Симпатии:
    1.560
    Версия XF:
    1.5.9
    Что Вы конвертировали с помощью Impex и зачем?
    Если на vB 4 кодировка была нормальная, тогда что-то не так делаете при конвертировании vB 4 > XF.
     
  9. Xansen

    Xansen Местный

    Регистрация:
    16.12.11
    Сообщения:
    12
    Симпатии:
    0
    Версия XF:
    1.1.2
    изначально у меня был ipb 2.0.4. Я его обновлял до ipb 3, который потом impex'ом конвертировал в VB4. А уже из VB конвертировал в XF.

    Вот данные таблицы vb_thread:

    Вот это перевожу с помощью конвертера который скачал для XF с дефолтными настройками и получаются кракозябры...

    Может быть есть кто сможет за вознаграждение решить проблему?
     
  10. infis

    infis Местный Команда форума

    Регистрация:
    27.06.11
    Сообщения:
    5.525
    Симпатии:
    3.321
    Версия XF:
    1.5.9
    Тупо в конвертере либо установите параметр кодировки базы VB, либо дополнительно один запрос сделайте в функции установления соединения с базой данных, где нужно выполнить запрос "SET NAMES CP1251".
     
  11. TAIFUN

    TAIFUN Человек

    Регистрация:
    27.09.10
    Сообщения:
    2.121
    Симпатии:
    1.560
    Версия XF:
    1.5.9
    Могу посмотреть. Контакты на странице моего профиля.
     
  12. Xansen

    Xansen Местный

    Регистрация:
    16.12.11
    Сообщения:
    12
    Симпатии:
    0
    Версия XF:
    1.1.2
    Тупо в конвертере уже ставил и 1251 и utf-8 - бесполезно. Вставляю кракозябры в преобразователь кодировок, выдает что текст в 1251->utf-8 дважды перегнан... Как такое может быть не понимаю... Откуда вообще 1252 взялась...

    А где эту функцию найти можно? посмотрел в файле config.php - только настройки доступа нашел...
    отписал в icq, и тишина...
     
  13. TAIFUN

    TAIFUN Человек

    Регистрация:
    27.09.10
    Сообщения:
    2.121
    Симпатии:
    1.560
    Версия XF:
    1.5.9
    Нет в ICQ ничего.
     
  14. Xansen

    Xansen Местный

    Регистрация:
    16.12.11
    Сообщения:
    12
    Симпатии:
    0
    Версия XF:
    1.1.2
    отписал еще раз
     
  15. TAIFUN

    TAIFUN Человек

    Регистрация:
    27.09.10
    Сообщения:
    2.121
    Симпатии:
    1.560
    Версия XF:
    1.5.9
    Проблема решена.
    После импорта все данные сконвертировались в latin1. В общем, там ещё проблема с мускулом на сервере.
     
  16. Xansen

    Xansen Местный

    Регистрация:
    16.12.11
    Сообщения:
    12
    Симпатии:
    0
    Версия XF:
    1.1.2
    Отлично! Спасибо. Жду на связи в аське.
     

Поделиться этой страницей