1. Приветствуем Вас на неофициальном форуме технической поддержки XenForo на русском языке. XenForo - новый и перспективный форумный движок от бывших создателей vBulletin.

Произошла ошибка, либо отправка запроса была отменена

Тема в разделе "Основные вопросы по XenForo", создана пользователем krivylkin, 31 май 2011.

Загрузка
  1. krivylkin

    krivylkin Активный пользователь

    Регистрация:
    22.05.11
    Сообщения:
    19
    Симпатии:
    5
    При установке какого либо дополнения выскакивает:

    Перестраивание кэша...
    Произошла ошибка, либо отправка запроса была отменена.
    Продолжить перестраивание
    Нажимаю на продолжить перестраивание и получаю пустую страницу, самое что интересное дополнение отображается в списке дополнений, но не работает. Подскажите как исправить этот касяк или что я делаю не так? Может на папки какие нибудь нужно выставить права?
     
  2. Romchik®

    Romchik® The Power of Dreams Команда форума

    Регистрация:
    26.09.10
    Сообщения:
    5.740
    Симпатии:
    5.269
    Версия XF:
    1.5.11
    Это сразу так было или вначале дополнения грузились нормально?
    Проверяли хостинг на совместимость тестовым скриптом?
     
  3. krivylkin

    krivylkin Активный пользователь

    Регистрация:
    22.05.11
    Сообщения:
    19
    Симпатии:
    5
    я с локал хоста переехал на хостинг
     
  4. Romchik®

    Romchik® The Power of Dreams Команда форума

    Регистрация:
    26.09.10
    Сообщения:
    5.740
    Симпатии:
    5.269
    Версия XF:
    1.5.11
    Это не ответ на мои 2 вопросы выше.
     
  5. krivylkin

    krivylkin Активный пользователь

    Регистрация:
    22.05.11
    Сообщения:
    19
    Симпатии:
    5
    Дополнения перестали устанавливаться сразу после переноса на хостинг, а хостинг всему соответствует.
     
  6. Romchik®

    Romchik® The Power of Dreams Команда форума

    Регистрация:
    26.09.10
    Сообщения:
    5.740
    Симпатии:
    5.269
    Версия XF:
    1.5.11
    В логах что-нибудь отображается?
    И нет ли проблем с загрузкой вложений и аватаров? По сути права только на это могли бы повлиять.

    Какая версия MySQL?
     
  7. krivylkin

    krivylkin Активный пользователь

    Регистрация:
    22.05.11
    Сообщения:
    19
    Симпатии:
    5
    В логах ошибок нету, но с загрузкой вложений есть проблемы картинки загружаются, но миниатюры не создаются и при публикации не отображаются вложения, а аватарки загружаются нормально.
    Версия MySQL 5.0.83
     
  8. Romchik®

    Romchik® The Power of Dreams Команда форума

    Регистрация:
    26.09.10
    Сообщения:
    5.740
    Симпатии:
    5.269
    Версия XF:
    1.5.11
    На папки data и internal_data нужно выставить права 777. Может и плагины начнутся устанавливаться нормально. Хотя это вроде не связано, но кто знает.
     
  9. krivylkin

    krivylkin Активный пользователь

    Регистрация:
    22.05.11
    Сообщения:
    19
    Симпатии:
    5
    На эти папки у меня стоят права 777 и на под папки тоже, значит дело в чем то другом.
     
  10. Romchik®

    Romchik® The Power of Dreams Команда форума

    Регистрация:
    26.09.10
    Сообщения:
    5.740
    Симпатии:
    5.269
    Версия XF:
    1.5.11
    Тогда смотрите логи ошибок не форума, а сервера.
     
  11. krivylkin

    krivylkin Активный пользователь

    Регистрация:
    22.05.11
    Сообщения:
    19
    Симпатии:
    5
    Так я и смотрел логи сервера, а где смотреть ошибки форума?
     
  12. Romchik®

    Romchik® The Power of Dreams Команда форума

    Регистрация:
    26.09.10
    Сообщения:
    5.740
    Симпатии:
    5.269
    Версия XF:
    1.5.11
    Админка - Инструменты - Журнал ошибок сервера
     
    krivylkin нравится это.
  13. zixel

    zixel Местный

    Регистрация:
    04.07.11
    Сообщения:
    9
    Симпатии:
    1
    Версия XF:
    1.1.1
    Вылазит та же самая ошибка, не знаю как решить
    Хостинг sweb

    PHP5: 5.3.6
    MySQL: 5.0.83
     
  14. krivylkin

    krivylkin Активный пользователь

    Регистрация:
    22.05.11
    Сообщения:
    19
    Симпатии:
    5
    попроси перевсти тебя на другой сервер где MySQL чуть по новее, но не факт что заработает, у меня так и не получилось на sweb ничего сделать на хенфоро, если получится отпишись.
     
  15. zixel

    zixel Местный

    Регистрация:
    04.07.11
    Сообщения:
    9
    Симпатии:
    1
    Версия XF:
    1.1.1
    Мда, у XenForo минус в неподдержке многими хостерами. У sweb для установки мне пришлось просить хостера, что бы аккаунт перенесли на другой сервер где есть нужная XenForo версия PHP, после переезда XenForo запустился, но при установке плагинов выдает ту же ошибку. Скрипт для проверки возможности установки на сервер ошибок не выдает. Остается только ждать, что в новой версии XenForo станит менне требовательна к железу или нужные нам плагины включат в сам движок (Например очень нехватает редактору BB-codes возможности вставки таблиц и спойлеров) Я лично пока радуюсь, что форум вообще запустился на хостинге и работает, пускай без дополнений.
     
  16. Yoskaldyr

    Yoskaldyr Пользователь

    Регистрация:
    27.09.10
    Сообщения:
    1.921
    Симпатии:
    1.160
    Версия XF:
    1.0.4
    Это проблемы не движка, а проблема таких хостеров, которые используют очень старое ПО. Ксен новый движок, использующий новые возможности пхп и мускуля (и даже не последние а просто относительно новые).
     
    Romchik® нравится это.

Поделиться этой страницей