1. Приветствуем Вас на неофициальном форуме технической поддержки XenForo на русском языке. XenForo - новый и перспективный форумный движок от бывших создателей vBulletin.

Пропал редактор сообщений на форуме

Тема в разделе "Для новичков", создана пользователем poohhf, 21 авг 2014.

Загрузка
  1. poohhf

    poohhf Пользователь

    Регистрация:
    08.07.14
    Сообщения:
    10
    Симпатии:
    0
    Версия XF:
    1.3.0
    Добрый вечер.

    Столкнулся с проблемой - на форуме, в окошке быстрых сообщений и овтетов пропали кнопочки, осталось лишь окно, в котором можно вводить текст. Случилось это сегодня, так как на акках, которые хареганы до сеголняшнего дня все нормально отображается, при создании нового же в редакторе пропадает все, кроме, как я описал выше, окошка для текста.

    В настройках пользователя галочка для полнофункционального редактора выключена теперь у новых пользователей, но даже если я ее включаю, редактор все равно остается без кнопок.

    Вот так вот выглядит на старом акке, и так было раньше на всех:
    [​IMG]

    А так, теперь на всех новых акках:
    [​IMG]

    Из-за чего такое могло случится и как исправить?
     
  2. poohhf

    poohhf Пользователь

    Регистрация:
    08.07.14
    Сообщения:
    10
    Симпатии:
    0
    Версия XF:
    1.3.0
    Никто не знает?
     
  3. poohhf

    poohhf Пользователь

    Регистрация:
    08.07.14
    Сообщения:
    10
    Симпатии:
    0
    Версия XF:
    1.3.0
  4. FractalizeR

    FractalizeR XenForo Addicted Команда форума

    Регистрация:
    27.09.10
    Сообщения:
    1.085
    Симпатии:
    823
    Версия XF:
    1.3.2
    Вероятно, что-то не так с шаблонами. Возможно, плагин мешает. Сами такие вещи не происходят.

    Но попробуйте перестроить все, зайдя на ваш форум по ссылке /install: www.example.com/install.

    XenForo скажет вам, что установка уже завершена и предложит все перестроить. Согласитесь и дождитесь завершения процесса. Если не поможет - отключайте плагины по одному.
     
    Mirovinger нравится это.
  5. poohhf

    poohhf Пользователь

    Регистрация:
    08.07.14
    Сообщения:
    10
    Симпатии:
    0
    Версия XF:
    1.3.0
    Инсталл делал, плагины по одному отключал, движок обновлял, парва перепроверял - ничего не помогает. У всех, кто регистрировался раньше - редактор работает, у всех, кто сейчас - расширенные возможности редактора не работают.
     
  6. FractalizeR

    FractalizeR XenForo Addicted Команда форума

    Регистрация:
    27.09.10
    Сообщения:
    1.085
    Симпатии:
    823
    Версия XF:
    1.3.2
    Значит, в настройках профиля http://www.xf-russia.ru/forum/account/preferences отключено использование расширенного редактора. Выполните запрос
    Код:
    UPDATE xf_user_option SET enable_rte=1
    для реактивации расширенного редактора у всех пользователей.
     
    Mirovinger нравится это.
  7. poohhf

    poohhf Пользователь

    Регистрация:
    08.07.14
    Сообщения:
    10
    Симпатии:
    0
    Версия XF:
    1.3.0
    Не помогло =(
     
  8. FractalizeR

    FractalizeR XenForo Addicted Команда форума

    Регистрация:
    27.09.10
    Сообщения:
    1.085
    Симпатии:
    823
    Версия XF:
    1.3.2
    Но в настройках у них отключена эта опция или нет?
     
  9. poohhf

    poohhf Пользователь

    Регистрация:
    08.07.14
    Сообщения:
    10
    Симпатии:
    0
    Версия XF:
    1.3.0
    Отключена. И при попытке включить, что с админки от лица администратора, что в профиле от лица пользователя, результат один - нажимаешь "сохранить изменения", страница обновляется, "галочка" пропадает.
     
  10. FractalizeR

    FractalizeR XenForo Addicted Команда форума

    Регистрация:
    27.09.10
    Сообщения:
    1.085
    Симпатии:
    823
    Версия XF:
    1.3.2
    Гм. А целостность MySQL таблиц проверяли? Так ведь не должно быть.
     
  11. poohhf

    poohhf Пользователь

    Регистрация:
    08.07.14
    Сообщения:
    10
    Симпатии:
    0
    Версия XF:
    1.3.0
    Как это можно осуществить?
     
  12. FractalizeR

    FractalizeR XenForo Addicted Команда форума

    Регистрация:
    27.09.10
    Сообщения:
    1.085
    Симпатии:
    823
    Версия XF:
    1.3.2
    Через PHPMyAdmin в панели управления хостингом.
     
  13. poohhf

    poohhf Пользователь

    Регистрация:
    08.07.14
    Сообщения:
    10
    Симпатии:
    0
    Версия XF:
    1.3.0
    А каким образом это можно сделать?
     
  14. infis

    infis Местный Команда форума

    Регистрация:
    27.06.11
    Сообщения:
    5.525
    Симпатии:
    3.320
    Версия XF:
    1.5.9
    Вы хотя бы пробуйте что-то сделать, а не только вопросы задавать. Ну что за ленивые админы пошли????
     
  15. poohhf

    poohhf Пользователь

    Регистрация:
    08.07.14
    Сообщения:
    10
    Симпатии:
    0
    Версия XF:
    1.3.0
    Как бы вторую неделю уже этот вопрос решить не получается. Испробовал все что только мог, ничего не помогает.
     
  16. infis

    infis Местный Команда форума

    Регистрация:
    27.06.11
    Сообщения:
    5.525
    Симпатии:
    3.320
    Версия XF:
    1.5.9
    Вы две недели не можете найти phpMyAdmin в панели хостера? Вы прочитали хотя бы строчку документации MySQL и phpMyAdmin? Вы хотя бы в поиск вбивали "целостность MySQL таблиц"?
     
  17. Oleg-2012

    Oleg-2012 Местный

    Регистрация:
    21.04.12
    Сообщения:
    646
    Симпатии:
    267
    Целостность базы можно проверить ещё и этим:http://sypex.net/

    Он даже лучше по мойму чем phpmyadmin !

    А в логах что-нить есть ?

    Если глюк в базе, наверняка-бы какие ошибки посыпались и ещё включите например в Мозиле "Веб разработка" и проснифите что идёт от пользователя до сервера, т.е. есть ли какие ошибки, может сервер что блокирует...

    Это-же можно проще даже просмотреть в логах апача !

    К сожалению мало инфы что-бы решить проблему, нужны логи форума и апача как минимум ! ;)
     
  18. aligon7

    aligon7 Местный

    Регистрация:
    22.12.12
    Сообщения:
    983
    Симпатии:
    62
    Версия XF:
    1.4.7
    А я вообще думаю, что шаблон не подходит под версию xenforo
     
  19. Kirill_61

    Kirill_61 Новичок

    Регистрация:
    15.11.15
    Сообщения:
    3
    Симпатии:
    0
    Версия XF:
    1.4.5
    Нашли решение проблемы? а то у меня такая ж проблема. Снимаешь галочку с "Полнофункционального" становится как у автора, ставишь обратно галочку- вообще его нет. С форумом ничего не делал. Возможно ли, с технической стороны, что где-то есть стучалка и просто убралось все?
     
  20. Kirill_61

    Kirill_61 Новичок

    Регистрация:
    15.11.15
    Сообщения:
    3
    Симпатии:
    0
    Версия XF:
    1.4.5
    Нашел следствие ошибки:
    Вот так отображается сейчас то поле, где должен быть редактор:
    PHP:
    <form action="forums/%D0%9F%D1%80%D0%B0%D0%B2%D0%B8%D0%BB%D0%B0-%D1%84%D0%BE%D1%80%D1%83%D0%BC%D0%B0.4/add-thread" method="post" id="ThreadCreate" class="xenForm Preview AutoValidator" data-previewurl="forums/%D0%9F%D1%80%D0%B0%D0%B2%D0%B8%D0%BB%D0%B0-%D1%84%D0%BE%D1%80%D1%83%D0%BC%D0%B0.4/create-thread/preview" data-redirect="on">
    а должно быть, примерно, вот так:
    PHP:
    <form action="index.php?forums/uluchshenie-foruma.3/add-thread" method="post" id="ThreadCreate" class="xenForm Preview AutoValidator" data-previewurl="index.php?forums/uluchshenie-foruma.3/create-thread/preview" data-redirect="on">
    Кто может подсказать куда рыть дальше?
    Там случайно не кириллица в длинном коде?

    Кириллица... Сделал транслит ссылок, но редактора так и нет ((((((
     
    Последнее редактирование: 24 ноя 2015

Поделиться этой страницей