1. Приветствуем Вас на неофициальном форуме технической поддержки XenForo на русском языке. XenForo - новый и перспективный форумный движок от бывших создателей vBulletin.

1.4.6 XenForo 1.4.6

Тема в разделе "Новости XenForo", создана пользователем Romchik®, 7 апр 2015.

Загрузка
Статус темы:
Закрыта.
  1. Romchik®

    Romchik® The Power of Dreams Команда форума

    Регистрация:
    26.09.10
    Сообщения:
    5.740
    Симпатии:
    5.269
    Версия XF:
    1.5.11
    И очередное обновление для XenForo.

    Улучшена защита от перебора логина и пароля, которая не только ограничивает число попыток, но и временно блокирует IP, с которых были произведены неудачные попытки.

    Также был обновлен Facebook Open Graph API до версии 2.0. Особых изменений вы не увидите, просто все будет работать и дальше после того, как старая версия API официально не будет больше поддерживаться. Разве что блок рекомендаций выпилен из шаблонов, т.к. он устарел и с июня не будет больше работать.

    Заметьте, что разработчики официально рекомендуют перейти на PHP версии 5.4 или выше. Для XenForo 2.0 будет требоваться PHP 5.4 или выше.

    Список некоторых исправлений, включенных в релиз 1.4.6:
    • Prevent double escaping of ampersands in image tags.
    • Add limits to the number of images being fetched by the image proxy simultaneously and add more strict limits to time outs and retrieval speed.
    • Allow a character set to be specified in the SMF importer.
    • Fix an off-by-one style error with the flood check that could allow multiple requests through in a 1 second window.
    • On the customized components page, only revert items matching the filter.
    • Remove deprecated Facebook social buttons and convert to use the HTML5-style versions.
    • Fix an issue where Chrome would not re-focus the editor properly when opening a menu.
    • In the editor, update the current button state using the browser APIs when backspacing.
    • Load external JS/CSS when opening the smilie menu.
    • When running the spam cleaner, stop redirecting when not checking IPs.
    • Dynamically change whether fixed overlays are used based on the overlay height (when loaded).
    • Properly number format user upgrade costs
    Смотрите раздел Resolved Bug Reports на оф. форуме для дополнительной информации.

    Список измененных в этой версии шаблонов:
    • account_external_accounts
    • member_list
    • member_notable
    • member_warn
    • news_feed_page
    • news_feed_page_global
    • PAGE_CONTAINER
    • quick_navigation_menu
    • register_facebook
    • report_view
    • share_page
    • sidebar_share_page
     
    Последнее редактирование: 7 апр 2015
    TAIFUN, infis, Yoskaldyr и 4 другим нравится это.
  2. Alex777

    Alex777 Местный

    Регистрация:
    16.04.11
    Сообщения:
    89
    Симпатии:
    13
    Версия XF:
    1.4.6
    Обновил, полет нормальный.
     
  3. illusionist

    illusionist Заблокирован

    Регистрация:
    09.03.13
    Сообщения:
    141
    Симпатии:
    26
    Версия XF:
    1.4.7
    я уже давно перелетел на php 5.5
    Не понятно другого, чего это разработчики с каждой новой обновкой напоминают сваливать с 5.3?
    не ужели так им важен этот зендоптимизер :unsure:
     
  4. lepagrn

    lepagrn Местный

    Регистрация:
    06.03.13
    Сообщения:
    62
    Симпатии:
    23
    Версия XF:
    1.2.5
    Наверно от того, что php 5.3 больше не поддерживаются. А это значит, что больше не будет выпускаться обновление безопасности для 5.3.
     
    illusionist нравится это.
  5. infis

    infis Местный Команда форума

    Регистрация:
    27.06.11
    Сообщения:
    5.525
    Симпатии:
    3.322
    Версия XF:
    1.5.9
    Некоторые функции и конструкции в новых версиях PHP перестают работать, либо меняются. Разработчикам XenForo нет смысла ориентироваться на старые версии PHP, которые и на хостингах уже перестают жить. Также в новых версиях PHP добавляется что-то новое, которое может быть использовано в новых версиях XenForo. Вот потому и появляются требования к совместимости, а также подталкивают к смене версии PHP на более новую.
     
  6. illusionist

    illusionist Заблокирован

    Регистрация:
    09.03.13
    Сообщения:
    141
    Симпатии:
    26
    Версия XF:
    1.4.7
    значит это хороший регулятор для говнохостеров, не поддерживать старые не адаптивный версии.
    А то научаться только поднимать сервак на пэхапэ или апач с директивами по-дефолту со старыми версии мускула — и начинают бабло качать с наивных клиентов, забивая болт на безопасности :)
     
  7. Yoskaldyr

    Yoskaldyr Пользователь

    Регистрация:
    27.09.10
    Сообщения:
    1.921
    Симпатии:
    1.160
    Версия XF:
    1.0.4
    Очень рекомендуемое обновление
     
    SeM13, Romchik® и illusionist нравится это.
Статус темы:
Закрыта.

Поделиться этой страницей