1. Приветствуем Вас на неофициальном форуме технической поддержки XenForo на русском языке. XenForo - новый и перспективный форумный движок от бывших создателей vBulletin.

За что отвечает - 1.5.2.min.js

Тема в разделе "Основные вопросы по XenForo", создана пользователем Skrimm, 5 фев 2013.

Загрузка
  1. Skrimm

    Skrimm Активный пользователь

    Регистрация:
    23.06.12
    Сообщения:
    151
    Симпатии:
    38
    Версия XF:
    1.1.4
    Подскажите пожалуйста за за что в xenforo отвечает jquery-1.5.2.min.js и в каком шаблоне подключен данный скрипт
    нашел строку подключения <script src="{xen:helper javaScriptUrl, '{$javaScriptSource}/xenforo/xenforo.js?_v={$xenOptions.jsVersion}'}"></script>
    Подскажите пожалуйста можно ли сменить версию jquery с 1.5.2 на 1.7.1
     
  2. infis

    infis Местный Команда форума

    Регистрация:
    27.06.11
    Сообщения:
    5.525
    Симпатии:
    3.321
    Версия XF:
    1.5.9
    Можно в конфиге library/config.php прописать нужную версию:
    PHP:
    $config['jsVersion']='1.7.1';
    Естественно, что нужно перед этим подложить нужный файл в js/jquery.

    Ну и можно вместо файла использовать ссылку на внешний источник. Номер версии указывается также. А в админке в опциях jQuery нужно просто указать внешний источник вместо local.
     
    Skrimm нравится это.
  3. Skrimm

    Skrimm Активный пользователь

    Регистрация:
    23.06.12
    Сообщения:
    151
    Симпатии:
    38
    Версия XF:
    1.1.4
    не сработало вот так при внешнем источнике показывает все сделал как вы написали
     
  4. Pepelac

    Pepelac Продам луц в бутылках Команда форума

    Регистрация:
    28.09.10
    Сообщения:
    1.794
    Симпатии:
    1.349
    И не сработает. Ибо jsVersion - это хэш, который добавляется к адресу подключаемого файла. Чтобы при обновлении версии яваскрипта у пользователей тоже все обновилось, а не бралось из кэша браузера.

    Хотите версию посвежее - измените занчение переменной $jQueryVersion в файле library/XenForo/Application.php. Только я не уверен, что все работать будет :)
     
    infis и Skrimm нравится это.
  5. Skrimm

    Skrimm Активный пользователь

    Регистрация:
    23.06.12
    Сообщения:
    151
    Симпатии:
    38
    Версия XF:
    1.1.4
    да Вы были правы много чего перестает работать :unsure:
     
  6. infis

    infis Местный Команда форума

    Регистрация:
    27.06.11
    Сообщения:
    5.525
    Симпатии:
    3.321
    Версия XF:
    1.5.9
    Упс. Точно. Непонятно зачем переменная выведена в загрузку через конфиг, хотя реально она переопределяется в процессе работы скрипта. А версия jQuery действительно жестко "вшита" в код в переменной $jQueryVersion.
    Извиняюсь, что посоветовал, не проверив :(
     
    Mirovinger и Pepelac нравится это.
  7. Skrimm

    Skrimm Активный пользователь

    Регистрация:
    23.06.12
    Сообщения:
    151
    Симпатии:
    38
    Версия XF:
    1.1.4
    Ребят скажите а где можно настроить скрипт(Query эффект) объявлений и возможно ли это
     
  8. BLEF

    BLEF Местный

    Регистрация:
    01.02.12
    Сообщения:
    466
    Симпатии:
    56
    Так возможно ли как-то обновить версию jquery? Или подключить внешнюю?
     
  9. infis

    infis Местный Команда форума

    Регистрация:
    27.06.11
    Сообщения:
    5.525
    Симпатии:
    3.321
    Версия XF:
    1.5.9
    Возможно. Но при этом появятся проблемы. Т.е. вероятность того, что что-то не будет работать или будет работать неправильно - 100%.
     
  10. Pepelac

    Pepelac Продам луц в бутылках Команда форума

    Регистрация:
    28.09.10
    Сообщения:
    1.794
    Симпатии:
    1.349
    А чем вас не устраивает текущая?

    И в версии форума 1.2 будет новая версия jQuery (сейчас там 1.10.1)
     
    BLEF нравится это.
  11. BLEF

    BLEF Местный

    Регистрация:
    01.02.12
    Сообщения:
    466
    Симпатии:
    56
    Карусельку хотел поставить, но она не пашет.
    Отписал автору плагина, описал проблему... говорит проблема в jQuery.
     
  12. CyberAP

    CyberAP Местный

    Регистрация:
    05.10.10
    Сообщения:
    2.577
    Симпатии:
    1.614
    Версия XF:
    1.5.10
    В XF 1.2 будет (и сейчас в бете уже есть) последняя версия jQuery — 1.10.1.
     
  13. lev76g

    lev76g Новичок

    Регистрация:
    06.06.13
    Сообщения:
    4
    Симпатии:
    2
    Версия XF:
    1.1.4
    Открываешь блокнотом свою библиотеку 1.5.2.min.js и идешь на сайт :
    http://code.jquery.com/jquery-1.10.1.min.js

    Затем копипастиш код и вставляешь этот код в свой файлик и сохраняешь. Вот тебе и все дела, всегда себе обновляю до последней стабл версии и все нормалек
     
    BLEF нравится это.
  14. BLEF

    BLEF Местный

    Регистрация:
    01.02.12
    Сообщения:
    466
    Симпатии:
    56
    После этой процедуры, перестал работать чат, :( но карусель заработала. :)
    И вроде скорость загрузки лучше стала...
    Теперь вопрос, как поправить чат?
    --- добавлено : 20 июн 2013 в 09:27 ---
    Ещё проблема, все всплывающие окна перестали открываться...
    Короче вариант не рабочий, не знаю как вы lev76g, там себе обновляете.
     

Поделиться этой страницей