1. Приветствуем Вас на неофициальном форуме технической поддержки XenForo на русском языке. XenForo - новый и перспективный форумный движок от бывших создателей vBulletin.

Письмо подтверждения регистрации

Тема в разделе "Для новичков", создана пользователем Blues Road, 18 янв 2015.

Загрузка
  1. Blues Road

    Blues Road Новичок

    Регистрация:
    27.12.14
    Сообщения:
    2
    Симпатии:
    0
    Всем доброго времени, такая проблема, только - только установил движок ксенфоро, пытаюсь сделать человека модератором, в админке вроде бы права настроил и сделал аккаунт модератором, проблема в том, что при регистрации ему не приходит письмо подтверждения, и не может он нормально существовать на форуме, с чем это связанно, может где то не заполнена в админке эта самая форма подтверждения, только где она?
     
  2. SrDEN

    SrDEN Местный

    Регистрация:
    29.08.14
    Сообщения:
    114
    Симпатии:
    52
    Версия XF:
    1.5.0
    Для начала пусть в спаме письмо посмотрит, если его там нету, то попробуйте сами по регистрироваться на разные почтовые сервисы.
     
  3. Blues Road

    Blues Road Новичок

    Регистрация:
    27.12.14
    Сообщения:
    2
    Симпатии:
    0
    в спаме нету, так понял на главной в админке есть кнопка настройки, а там уже настройки есть почты и регистрации пользователей, как что правильно тут настраивать подскажет кто нибудь?
     
  4. jerter

    jerter Новичок

    Регистрация:
    24.01.15
    Сообщения:
    22
    Симпатии:
    0
    Версия XF:
    1.4.3
    Кстати у меня тоже самое. Сообщение на почту не приходят.
     
  5. jerter

    jerter Новичок

    Регистрация:
    24.01.15
    Сообщения:
    22
    Симпатии:
    0
    Версия XF:
    1.4.3
    Спустя долго время письмо пришло,но упало в папку спам.
    Перехожу по ссылки которая указана в письме а мне по новой выкидывает текст:
    1. В настоящий момент Ваша учётная запись ожидает подтверждения. Письмо с инструкциями отправлено по адресу lar********@yandex.ru.
      Отправить ещё раз письмо с подтверждением
    Нажимаю отправить ещё и всё повторяется.
     
  6. Exile

    Exile Местный

    Регистрация:
    27.06.11
    Сообщения:
    999
    Симпатии:
    546
    Версия XF:
    1.4.4
    jerter и Mirovinger нравится это.
  7. jerter

    jerter Новичок

    Регистрация:
    24.01.15
    Сообщения:
    22
    Симпатии:
    0
    Версия XF:
    1.4.3
    Попробывал ещё раз с новой почтой.
    Зарегал аккаунт, отправил письмо с подтверждением ,письмо на почту пришло мгновенно.
    Нажимаю на ссылку в письме. Но всё равно пишет
    1. В настоящий момент Ваша учётная запись ожидает подтверждения. Письмо с инструкциями отправлено по адресу lar********@yandex.ru.
     
  8. Exile

    Exile Местный

    Регистрация:
    27.06.11
    Сообщения:
    999
    Симпатии:
    546
    Версия XF:
    1.4.4
    Очень странно тогда. Пример ссылки из письма привести можете?
     
    jerter нравится это.
  9. jerter

    jerter Новичок

    Регистрация:
    24.01.15
    Сообщения:
    22
    Симпатии:
    0
    Версия XF:
    1.4.3
  10. Exile

    Exile Местный

    Регистрация:
    27.06.11
    Сообщения:
    999
    Симпатии:
    546
    Версия XF:
    1.4.4
    jerter, попробуйте все же включить ЧПУ в настройках форума. Админка - Настройки - Основная информация о форуме.

    admin.php?options/list/basicBoard#_useFriendlyUrls
     

    Вложения:

    jerter нравится это.
  11. infis

    infis Местный Команда форума

    Регистрация:
    27.06.11
    Сообщения:
    5.525
    Симпатии:
    3.321
    Версия XF:
    1.5.9
    Это никак не влияет на ссылку через index.php. Проблема в другом чем-то.
     
  12. jerter

    jerter Новичок

    Регистрация:
    24.01.15
    Сообщения:
    22
    Симпатии:
    0
    Версия XF:
    1.4.3
  13. Exile

    Exile Местный

    Регистрация:
    27.06.11
    Сообщения:
    999
    Симпатии:
    546
    Версия XF:
    1.4.4
    jerter, ну в общем так как вы ссылку не поправили полностью, причина проблемы сразу стала ясна. Отключайте портал или нормально настраивайте.

    Вам приходит ссылка на http://www.alose.ru/forum/account-confirmation/2/email?c=BEn5nZuoGYtbWXTM, а должна быть http://www.alose.ru/account-confirmation/2/email?c=BEn5nZuoGYtbWXTM - все из-за того, что вы роутинг портала неправильно настроили.

    И я вам аккаунт случайно активировал перейдя по второй ссылке, да.

    infis, ну по сути предположение было верное - проблемы с перенаправлениями, только была идея про ЧПУ для начала.
     
    jerter нравится это.
  14. jerter

    jerter Новичок

    Регистрация:
    24.01.15
    Сообщения:
    22
    Симпатии:
    0
    Версия XF:
    1.4.3
    И как можно найти информацию чтобы правильно настроить?
     
  15. Exile

    Exile Местный

    Регистрация:
    27.06.11
    Сообщения:
    999
    Симпатии:
    546
    Версия XF:
    1.4.4
    Спрашивайте у автора дополнения, оно платное, поддержка должна быть.
     
    jerter нравится это.
  16. jerter

    jerter Новичок

    Регистрация:
    24.01.15
    Сообщения:
    22
    Симпатии:
    0
    Версия XF:
    1.4.3
    Переустановка двигателя с версии 1.3.2 на 1.4.2(4.4) решит проблему?
    Или куда обратится?
     
  17. Exile

    Exile Местный

    Регистрация:
    27.06.11
    Сообщения:
    999
    Симпатии:
    546
    Версия XF:
    1.4.4
    Туда где вы скачали сам движок и плагин.
     
    jerter нравится это.
  18. jerter

    jerter Новичок

    Регистрация:
    24.01.15
    Сообщения:
    22
    Симпатии:
    0
    Версия XF:
    1.4.3
    Поставил XenForo 1.4.3 нечего не изменилось.
    Зашел в "основная информация о форуме" и изменил url форума с "www.***.ru/forum на "www.***.ru
    Письмо пришло правильное.И всё активировалось
     

Поделиться этой страницей